After Instalation, loss of Networking...

CaptainCalvin1987
Posts: 4
Joined: Wed Jul 14, 2010 1:26 pm

After Instalation, loss of Networking...

Postby CaptainCalvin1987 » Wed Jul 14, 2010 1:30 pm

I have installed Fedora 12 where i have internet through my eth1(eth0 is dead) and i install Amahi and after the reboot i loose that connection with eth1. I have gone through the wiki page to "support" eth1 but that doesn't change a thing. When i go under network connections it doesn't show any network connections, unlike before the install it showed eth0 and eth1.

What am i doing wrong? Amahi is installed but i just have no access to the internet and what seems to be my network card. Is there a way to change my installed gigabit card to eth0??

Thanks

User avatar
moredruid
Expert
Posts: 791
Joined: Tue Jan 20, 2009 1:33 am
Location: Netherlands
Contact:

Re: After Instalation, loss of Networking...

Postby moredruid » Wed Jul 14, 2010 1:39 pm

does ifconfig give you the output of eth0 and eth1?
if not: ifup eth1 might do the trick.
you might need to edit /etc/sysconfig/network-scripst/ifcfg-eth1 and set the parameter ONBOOT to ONBOOT=yes if this is not the case.
echo '16i[q]sa[ln0=aln100%Pln100/snlbx]sbA0D2173656C7572206968616D41snlbxq' | dc
Galileo - HP Proliant ML110 G6 quad core Xeon 2.4GHz, 4GB RAM, 2x750GB RAID1 + 2x1TB RAID1 HDD

CaptainCalvin1987
Posts: 4
Joined: Wed Jul 14, 2010 1:26 pm

Re: After Instalation, loss of Networking...

Postby CaptainCalvin1987 » Wed Jul 14, 2010 3:08 pm

ifconfig does give an output for both eth0 and eth1.

eth0 Link encap:Ethernet HWaddr 00:0D:56:15:B8:61
inet addr:10.0.1.20 Bcast:10.0.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth1 Link encap:Ethernet HWaddr 00:1D:0F:F8:57:45
inet6 addr: fe80::21d:fff:fef8:5745/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1214 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:77997 (76.1 KiB) TX bytes:468 (468.0 b)
Interrupt:17 Base address:0xcf00

I also checked that file and it does have eth1 ONBOOT = Yes.

whetu
Posts: 30
Joined: Tue Jul 13, 2010 3:32 am

Re: After Instalation, loss of Networking...

Postby whetu » Wed Jul 14, 2010 3:24 pm

If you want to force your gigabit card to be eth0, you can do that with udev. I've had to do this a few times to resurrect dead servers. I'm at work on a Windows box at the moment, so this is off the top of my head and referencing from a suse box I'm currently scripting on:

/etc/udev/rules.d/70-persistent-net.rules is the file you want to change. There should be a line in there that reads like:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
where ATTR{address}=="xx:xx:xx:xx:xx:xx", is the mac address. I'll give you an example:

Code: Select all

somelinuxbox# ifconfig eth0 Link encap:Ethernet HWaddr AA:BB:CC:DD:EE:FF .... eth1 Link encap:Ethernet HWaddr 11:22:33:44:55:66 ....
Equates to a udev file that reads:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="AA:BB:CC:DD:EE:FF", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="11:22:33:44:55:66", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
Note that the mac addresses match. The very short explanation is: Udev sees the mac address AA:BB:CC:DD:EE:FF and assigns the device name "eth0" and a driver to that bit of hardware. Now let's say that for whatever reason we want to swap the interfaces, so that the current eth0 is eth1 and vice versa. First we change the udev rule to read:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="11:22:33:44:55:66", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="AA:BB:CC:DD:EE:FF", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
...then we ensure that any mac address listed in /etc/sysconfig/network-scripst/ifcfg-eth0 and ifcfg-eth1 are removed or commented out (it's not required anyway). On top of that, change the onboot parameter as moredruid pointed out. There may be other lines in there worth changing while you're there. Once you're done, fully restart and you should be sorted.

As I said, I've had to resurrect a few boxes using this trick. I've had servers die at 3am, and the fastest way to restore service is to simply chuck the disks into another box, boot up and force udev to point eth0/eth1/eth2/eth3 to the mac addresses of my choosing.

Let me know if you have any problems, I'll answer sooner or later :)

/edit: Just saw you posted while I was typing this up. Try this:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1D:0F:F8:57:45", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0D:56:15:B8:61", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
I also note your eth1 doesn't have an IP address etc listed, you may want to try system-config-network

Who is online

Users browsing this forum: No registered users and 1 guest