No Internet when connected to OpenVPN

sharmac
Posts: 12
Joined: Wed Jan 18, 2017 6:12 pm

No Internet when connected to OpenVPN

Postby sharmac » Wed Sep 19, 2018 12:17 am

I am running Amahi 10 on Fedora 25. I configured OpenVPN server on Amahi manually and was able to connect from a client outside my Amahi/HDA network. However, internet didn't work on the client machine when connected to OpenVPN. I could see in the OpenVPN logs on Amahi server that the connection was made from the client but there was no indication as to why internet is not working.

It felt I was so close but I don't want to spend more time trying to resolve the internet issue with my manual configuration. I am wondering if using the OpenVPN app will help. My goal is to be able to access the samba/greyhole drives from outside network via VPN.

My HDA address and addresses of devices on my HDA network are of form 192.168.1.*. The outside network I would like to access my samba shares from also has addresses of form 192.168.1.*.

Would using the OpenVPN app help my scenario above?
Or, even if I use the app, would I still need to change the IP address range on my HDA to something other than 192.168.1.*?

P.S. I tried change the HDA address to 192.168.2.10 but that didn't go well with my router configuration. So I reverted the HDA address back to 192.168.1.10.
Running Amahi 10 on Fedora 25
with Samba and Amahi Anywhere servers

User avatar
bigfoot65
Project Manager
Posts: 11449
Joined: Mon May 25, 2009 4:31 pm

Re: No Internet when connected to OpenVPN

Postby bigfoot65 » Fri Sep 21, 2018 11:56 am

Would using the OpenVPN app help my scenario above?
Use of the openvpn App should work.
My HDA address and addresses of devices on my HDA network are of form 192.168.1.*. The outside network I would like to access my samba shares from also has addresses of form 192.168.1.*.
I have no issues with mine and it's pretty much the same setup.
ßîgƒσστ65
Applications Manager

sharmac
Posts: 12
Joined: Wed Jan 18, 2017 6:12 pm

Re: No Internet when connected to OpenVPN

Postby sharmac » Mon Sep 24, 2018 2:19 pm

Thank you for the reply bigfoot65!

I will try the OpenVpn app tonight. Would I need to undo the manual setup I did on my Amahi server or would the app installation automatically override my OpenVpn files and configurations?

Thanks again!
Running Amahi 10 on Fedora 25
with Samba and Amahi Anywhere servers

User avatar
bigfoot65
Project Manager
Posts: 11449
Joined: Mon May 25, 2009 4:31 pm

Re: No Internet when connected to OpenVPN

Postby bigfoot65 » Mon Sep 24, 2018 5:35 pm

Would I need to undo the manual setup I did on my Amahi server
Yes you will first need to undo anything you manually configured.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: Bing [Bot] and 0 guests