SOLVED: Samba Server Stopped

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

SOLVED: Samba Server Stopped

Postby hemington1 » Thu Dec 31, 2015 11:46 pm

Happy New Year to all.
Yesterday afternoon samba just stopped. I did not install any apps or delete any.
Any clues to a fix?

Code: Select all

[root@localhost ~]# systemctl status smb ● smb.service - Samba SMB Daemon Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled) Active: failed (Result: start-limit) since Fri 2016-01-01 14:39:45 AWST; 2min 27s ago Process: 10016 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=127) Main PID: 10016 (code=exited, status=127) Jan 01 14:39:45 localhost.localdomain systemd[1]: smb.service: main process exited, code=exited, status=127/n/a Jan 01 14:39:45 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon. Jan 01 14:39:45 localhost.localdomain systemd[1]: Unit smb.service entered failed state. Jan 01 14:39:45 localhost.localdomain systemd[1]: smb.service failed. Jan 01 14:39:45 localhost.localdomain systemd[1]: start request repeated too quickly for smb.service Jan 01 14:39:45 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon. Jan 01 14:39:45 localhost.localdomain systemd[1]: smb.service failed. Jan 01 14:39:46 localhost.localdomain systemd[1]: start request repeated too quickly for smb.service Jan 01 14:39:46 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon. Jan 01 14:39:46 localhost.localdomain systemd[1]: smb.service failed. [root@localhost ~]#
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Server Stopped

Postby bigfoot65 » Fri Jan 01, 2016 7:10 am

Try:

Code: Select all

systemctl start smb
Check status again.
Also check /var/log/ samba/smbd.log for errors.
ßîgƒσστ65
Applications Manager

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

Re: Samba Server Stopped

Postby hemington1 » Fri Jan 01, 2016 6:34 pm

smbd.log is full of cups errors, unable to connect to printer.
I tried removing cups but get this:

Code: Select all

[root@localhost ~]# yum erase cups Loaded plugins: fastestmirror No Match for argument: cups No Packages marked for removal

Code: Select all

[2015/12/28 03:49:50.293063, 0] ../source3/printing/print_cups.c:151(cups_connect) Unable to connect to CUPS server localhost:631 - Bad file descriptor [2015/12/28 03:49:50.293381, 0] ../source3/printing/print_cups.c:528(cups_async_callback) failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL [2015/12/28 04:02:50.884236, 0] ../source3/printing/print_cups.c:151(cups_connect) Unable to connect to CUPS server localhost:631 - Bad file descriptor [2015/12/28 04:02:50.884575, 0] ../source3/printing/print_cups.c:528(cups_async_callback) failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Server Stopped

Postby bigfoot65 » Sat Jan 02, 2016 8:05 am

Try installing cups then start Samba. Check status and report back.
ßîgƒσστ65
Applications Manager

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

Re: Samba Server Stopped

Postby hemington1 » Sat Jan 02, 2016 7:31 pm

cups installed.
Samba is still in a permanently stopped state.
I restarted the HDA to be sure. Still no samba.
I noticed OpenVPN server had also permanently stopped after the restart. A re-install of OpenVPN was the only way to get it working again.
Samba still stopped..........
:cry:
Some critical files/folder corrupted?

Code: Select all

Jan 03 10:39:26 localhost.localdomain smbd[3854]: /usr/sbin/smbd: error while loading shared libraries: libwbclient.so.0: cannot open shared object file: No such file or directory
Is the folder in the wrong location?

Code: Select all

[root@localhost ~]# locate libwbclient.so.0 /usr/lib64/samba/wbclient/libwbclient.so.0 /usr/lib64/samba/wbclient/libwbclient.so.0.11 [root@localhost ~]#
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Server Stopped

Postby bigfoot65 » Sat Jan 02, 2016 9:30 pm

Is the OS updated?

Code: Select all

yum update
ßîgƒσστ65
Applications Manager

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

Re: Samba Server Stopped

Postby hemington1 » Sun Jan 03, 2016 4:46 am

Yes, up to date.
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Server Stopped

Postby bigfoot65 » Sun Jan 03, 2016 11:40 am

You might be able to fix it by reinstalling Samba:

Code: Select all

yum reinstall samba
It should work, but no guarantee. Also please understand it might make things worse, but worth a shot in my opinion.
ßîgƒσστ65
Applications Manager

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

Re: Samba Server Stopped

Postby hemington1 » Sun Jan 03, 2016 7:32 pm

Thanks Big. Before I do that, is there a way to redirect Samba to find the library in /usr/lib64/samba/ ?
Where is this library in your setup? Is it in /usr/sbin/smbd ?
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Server Stopped

Postby bigfoot65 » Mon Jan 04, 2016 11:57 am

I have not checked, but I think the reinstall is the best option. It should fix the missing files but you may need to manually start the service.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 0 guests