amahi dashboard incorrect server status

wvdlee
Posts: 61
Joined: Wed Feb 25, 2009 9:19 am

Re: amahi dashboard incorrect server status

Postby wvdlee » Tue Dec 16, 2014 1:43 pm

Code: Select all

[root@localhost ~]# echo "SELECT pidfile FROM servers WHERE name = 'Crashplan'" | mysql -uroot -phda hda_production pidfile /usr/local/crashplan/CrashPlanEngine.pid
when I search for crashplan I do get a result. maybe this helps?

User avatar
bigfoot65
Project Manager
Posts: 11386
Joined: Mon May 25, 2009 4:31 pm

Re: amahi dashboard incorrect server status

Postby bigfoot65 » Tue Dec 16, 2014 2:05 pm

My guess would be that OpenVPN is not properly installed. You may need to uninstall and reinstall. There should have been a result from the query.
ßîgƒσστ65
Applications Manager

wvdlee
Posts: 61
Joined: Wed Feb 25, 2009 9:19 am

Re: amahi dashboard incorrect server status

Postby wvdlee » Tue Dec 16, 2014 3:22 pm

hmmm that worked, sort of.
The status is still stopped, but this time the status is correct, since it does not start anymore :(

So I tried a reboot, but still no succes i get the following error now in /var/log/messages

Code: Select all

Dec 16 23:10:51 localhost systemd[1]: Starting OpenVPN Robust And Highly Flexible Tunneling Application On amahi... Dec 16 23:10:51 localhost openvpn[1349]: /usr/sbin/openvpn: symbol lookup error: /usr/sbin/openvpn: undefined symbol: pkcs11h_openssl_session_getEVP Dec 16 23:10:51 localhost systemd[1]: openvpn@amahi.service: control process exited, code=exited status=127 Dec 16 23:10:51 localhost systemd[1]: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:10:51 localhost systemd[1]: Unit openvpn@amahi.service entered failed state.
Probably I need to clean up old seetings after the uninstall and then reinstall again??

This is also weird as my remote amahi has the same problem, there must be a bug somewhere, maybe because openvpn was the first app I installed on both machines, as far as I can recall.

wvdlee
Posts: 61
Joined: Wed Feb 25, 2009 9:19 am

Re: amahi dashboard incorrect server status

Postby wvdlee » Tue Dec 16, 2014 3:35 pm

It keeps giving errors and also a weird kernel message.

Code: Select all

Dec 16 23:25:51 localhost systemd[1]: Starting OpenVPN Robust And Highly Flexible Tunneling Application On amahi... Dec 16 23:25:51 localhost openvpn[2206]: /usr/sbin/openvpn: symbol lookup error: /usr/sbin/openvpn: undefined symbol: pkcs11h_openssl_session_getEVP Dec 16 23:25:51 localhost systemd[1]: openvpn@amahi.service: control process exited, code=exited status=127 Dec 16 23:25:51 localhost systemd[1]: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:25:51 localhost systemd[1]: Unit openvpn@amahi.service entered failed state. Dec 16 23:27:21 localhost systemd[1]: Starting OpenVPN Robust And Highly Flexible Tunneling Application On amahi... Dec 16 23:27:21 localhost openvpn[2306]: /usr/sbin/openvpn: symbol lookup error: /usr/sbin/openvpn: undefined symbol: pkcs11h_openssl_session_getEVP Dec 16 23:27:21 localhost systemd[1]: openvpn@amahi.service: control process exited, code=exited status=127 Dec 16 23:27:21 localhost systemd[1]: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:27:21 localhost systemd[1]: Unit openvpn@amahi.service entered failed state. Dec 16 23:27:41 localhost kernel: [ 1130.782400] perf samples too long (2514 > 2500), lowering kernel.perf_event_max_sample_rate to 50000 Dec 16 23:28:29 localhost systemd[1]: Stopped OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:28:29 localhost systemd[1]: Starting OpenVPN Robust And Highly Flexible Tunneling Application On amahi... Dec 16 23:28:29 localhost openvpn[2466]: /usr/sbin/openvpn: symbol lookup error: /usr/sbin/openvpn: undefined symbol: pkcs11h_openssl_session_getEVP Dec 16 23:28:29 localhost systemd[1]: openvpn@amahi.service: control process exited, code=exited status=127 Dec 16 23:28:29 localhost systemd[1]: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:28:29 localhost systemd[1]: Unit openvpn@amahi.service entered failed state. Dec 16 23:28:51 localhost systemd[1]: Starting OpenVPN Robust And Highly Flexible Tunneling Application On amahi... Dec 16 23:28:51 localhost openvpn[2500]: /usr/sbin/openvpn: symbol lookup error: /usr/sbin/openvpn: undefined symbol: pkcs11h_openssl_session_getEVP Dec 16 23:28:51 localhost systemd[1]: openvpn@amahi.service: control process exited, code=exited status=127 Dec 16 23:28:51 localhost systemd[1]: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:28:51 localhost systemd[1]: Unit openvpn@amahi.service entered failed state. Dec 16 23:30:21 localhost systemd[1]: Starting OpenVPN Robust And Highly Flexible Tunneling Application On amahi... Dec 16 23:30:21 localhost openvpn[2615]: /usr/sbin/openvpn: symbol lookup error: /usr/sbin/openvpn: undefined symbol: pkcs11h_openssl_session_getEVP Dec 16 23:30:21 localhost systemd[1]: openvpn@amahi.service: control process exited, code=exited status=127 Dec 16 23:30:21 localhost systemd[1]: Failed to start OpenVPN Robust And Highly Flexible Tunneling Application On amahi. Dec 16 23:30:21 localhost systemd[1]: Unit openvpn@amahi.service entered failed state.

wvdlee
Posts: 61
Joined: Wed Feb 25, 2009 9:19 am

Re: amahi dashboard incorrect server status

Postby wvdlee » Tue Dec 16, 2014 4:00 pm

So i did an uninstall of openvpn
then a reboot
then I re installed openvpn
still the same error, see the complete messages logfile attached
Attachments
hda_reboot_and_reinstall_openvpn_messages_log.txt
(92.44 KiB) Downloaded 29 times

User avatar
bigfoot65
Project Manager
Posts: 11386
Joined: Mon May 25, 2009 4:31 pm

Re: amahi dashboard incorrect server status

Postby bigfoot65 » Tue Dec 16, 2014 4:37 pm

Are you on the latest Amahi release. Latest OS updates installed?
ßîgƒσστ65
Applications Manager

wvdlee
Posts: 61
Joined: Wed Feb 25, 2009 9:19 am

Re: amahi dashboard incorrect server status

Postby wvdlee » Tue Dec 16, 2014 4:41 pm

yes I installes everything a month ago, it's amahi 7

Systeem 3.14.23-100.fc19.x86_64 ,x86_64
Platform 7.4.0-1
Core 5.4.2-1
Bedrijfstijd 00:40:16 up 21 min, 0 users, load average: 0.05, 0.10, 0.14

I also did a yum update about two weeks ago (maybe that caused it?????) but then everybody that does a yum update should have the same problem.

User avatar
bigfoot65
Project Manager
Posts: 11386
Joined: Mon May 25, 2009 4:31 pm

Re: amahi dashboard incorrect server status

Postby bigfoot65 » Tue Dec 16, 2014 4:58 pm

My system reflects kernel 3.14.22-100 and it's up to date. Can you reboot and try that kernel?
ßîgƒσστ65
Applications Manager

wvdlee
Posts: 61
Joined: Wed Feb 25, 2009 9:19 am

Re: amahi dashboard incorrect server status

Postby wvdlee » Tue Dec 16, 2014 6:05 pm

Is there a way to do that without a monitor and gpu installed? Or do I need to install that hardware first?

[ Post made via Android ] Image

User avatar
bigfoot65
Project Manager
Posts: 11386
Joined: Mon May 25, 2009 4:31 pm

Re: amahi dashboard incorrect server status

Postby bigfoot65 » Tue Dec 16, 2014 6:13 pm

You will need a monitor and keyboard attached.

EDIT: There are other ways, but they are more complicated.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests