[SOLVED] Issue with running sh install-amahi

cptdave
Posts: 2
Joined: Sat Aug 04, 2012 7:27 am

[SOLVED] Issue with running sh install-amahi

Postby cptdave » Mon Feb 04, 2013 1:03 pm

I have been using Amahi on Ubuntu 12.04 LTS server for about 6 months. I decided to do a fresh install since to wipe clean all the modifications and things I broke. I install Ubuntu fine, and then when I try to install amahi, I recieve the following error.

Code: Select all

Welcome to Amahi for Ubuntu! This will install Amahi and will ask for your password, for admin access It creates a log file in /tmp/amahi-repo-setup.4718.log The installer must stop here, sorry. Amahi is only supported on Ubuntu 12.04 LTS Please download the latest 12.04 LTS version (eg. 12.04.1).
Now interestingly enough, I used the same Ubuntu server CD that I used last few times I installed Amahi. I also tried to re-download and re-burn Ubuntu 12.04.1 LTS server, and still the same error. I also ran the commands to update and check for a new version of 12.04.1 LTS. Still same error as above. Internet connection seems to work, everything else seems to be working. Any ideas?

I downloaded Amahi from

Code: Select all

http://u12.amahi.org/install-amahi
as listed in the installation instructions and on the wiki. I viewed the log and did not find the cause in there either.

*edit: Fixed title of thread.

*edit 2: clarified that ubuntu 12.04.1 LTS was downloaded and installed.
Last edited by cptdave on Wed Feb 06, 2013 4:51 pm, edited 1 time in total.

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: Issue with running sh install-amahi

Postby bigfoot65 » Mon Feb 04, 2013 3:04 pm

Follow the guidance at http://docs.amahi.org and download Ubuntu 12.04.1 LTS.
ßîgƒσστ65
Applications Manager

User avatar
cpg
Administrator
Posts: 2604
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Issue with running sh install-amahi

Postby cpg » Mon Feb 04, 2013 10:00 pm

Oops. We screwed up -- the script should allow to install 12.04 plain too.

We'll release a new script tolerating both soon.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

erangaj
Posts: 3
Joined: Thu Dec 27, 2012 6:59 pm

Re: Issue with running sh install-amahi

Postby erangaj » Mon Feb 04, 2013 11:09 pm

In install-amahi script, change

Code: Select all

if [ "$VERSION" != "12041" ]; then
to

Code: Select all

if [ "$VERSION" != "12042" ]; then

User avatar
cpg
Administrator
Posts: 2604
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Issue with running sh install-amahi

Postby cpg » Mon Feb 04, 2013 11:27 pm

or "1204" which is what he seems to have. is 12.04.2 out? :)

actually, we wanted to check on anything matching "1204.*" but we did not get to that just yet.

[[ "$VERSION" =~ "1204.*" ]] did not work and we're busy with another issue.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

erangaj
Posts: 3
Joined: Thu Dec 27, 2012 6:59 pm

Re: Issue with running sh install-amahi

Postby erangaj » Tue Feb 05, 2013 4:12 am

Yes, 12.04.2 is out. I installed 12.04LTS today and apt-get upgrade changed the version to 12.04.2. Managed to install amahi with the above trick.

[ Post made via iPad ] Image

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: Issue with running sh install-amahi

Postby bigfoot65 » Tue Feb 05, 2013 5:48 am

Thanks for the update. I did not know 12.04.2 was out. Our script should sense all 3 versions, so looks like it will be modified in the near future.
ßîgƒσστ65
Applications Manager

User avatar
cpg
Administrator
Posts: 2604
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Issue with running sh install-amahi

Postby cpg » Tue Feb 05, 2013 9:27 pm

This issue has been solved and the latest install-amahi script is more robust now. Thanks for reporting it!
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

cptdave
Posts: 2
Joined: Sat Aug 04, 2012 7:27 am

Re: [SOLVED] Issue with running sh install-amahi

Postby cptdave » Wed Feb 06, 2013 4:49 pm

Hey, sorry I could not respond back fast enough. Work had me tied up all day and night yesterday.

I should have specified in my original post that I did download the 12.04.1 LTS and it threw the same error at me.

I did not realize that I had to make an EFI boot partition for my UEFI motherboard. It appears that after I made this partition, and directed the BIOS to boot the server install CD as UEFI, instead of AHCP, in order to appease the ubuntu install. It appears that most ubuntu users with an UEFI motherboard were receiving GRUB2 errors on install, unless they made a EFI partition. In my case, it appears that I did not receive the error, but the ubuntu install was botched a bit, even though it appeared to be normal.

Thanks for the fast response though.

Good to see that my error had indirectly fixed another error. :D

rkillcrazy
Posts: 44
Joined: Wed May 19, 2010 9:01 am
Location: USA

Re: [SOLVED] Issue with running sh install-amahi

Postby rkillcrazy » Tue Feb 12, 2013 3:58 pm

I'm having a similar issue. The first time I ran the installer, it just froze. Subsequent retries, since a reboot, yield the error below.

Code: Select all

willybay@willybay-hda:~$ sh install-amahi Welcome to Amahi for Ubuntu! This will install Amahi and will ask your password, for admin access It creates a log file in /tmp/amahi-repo-setup.1197.log Please enter your install code from http://amahi.org for this HDA: <insert code here> [sudo] password for willybay: Disabling apparmor Installing the amahi Amahi Ubuntu repo Updating the repo Installing the Amahi platform (this may take a few minutes) Patching the dhcpd PID issue. Kicking off the Amahi installer (this may take a few more minutes) bash: line 42: /usr/bin/hda-install: No such file or directory install-amahi: 89: install-amahi: cannot create /home/willybay/Desktop/Amahi-Dashboard-Home.desktop: Permission denied install-amahi: 99: install-amahi: cannot create /home/willybay/Desktop/Amahi-Live-Help.desktop: Permission denied *************************************************** *************************************************** ***** Reboot to get started with Amahi ***** *************************************************** *************************************************** willybay@willybay-hda:~$
My server (no GUI) version is:

Code: Select all

willybay@willybay-hda:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 12.04.2 LTS Release: 12.04 Codename: precise willybay@willybay-hda:~$
/tmp/amahi-repo-setup.1197.log

Code: Select all

/etc/init.d/apparmor: 35: .: Can't open /lib/apparmor/functions invoke-rc.d: initscript apparmor, action "kill" failed. Removing any system startup links for /etc/init.d/apparmor ... E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. --2013-02-12 17:28:47-- http://u12.amahi.org/amahi-ubuntu.asc Resolving u12.amahi.org (u12.amahi.org)... 208.115.201.197 Connecting to u12.amahi.org (u12.amahi.org)|208.115.201.197|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 1748 (1.7K) [text/plain] Saving to: `amahi-ubuntu.asc' 0K . 100% 98.4M=0s 2013-02-12 17:28:47 (98.4 MB/s) - `amahi-ubuntu.asc' saved [1748/1748] --2013-02-12 17:28:47-- http://u12.amahi.org/amahi-dice.svg Resolving u12.amahi.org (u12.amahi.org)... 208.115.201.197 Connecting to u12.amahi.org (u12.amahi.org)|208.115.201.197|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 36827 (36K) [image/svg+xml] Saving to: `amahi-dice.svg' 0K .......... .......... .......... ..... 100% 328K=0.1s 2013-02-12 17:28:48 (328 KB/s) - `amahi-dice.svg' saved [36827/36827] OK Ign http://security.ubuntu.com precise-security InRelease Hit http://security.ubuntu.com precise-security Release.gpg Ign http://us.archive.ubuntu.com precise InRelease Ign http://us.archive.ubuntu.com precise-updates InRelease Ign http://us.archive.ubuntu.com precise-backports InRelease Hit http://security.ubuntu.com precise-security Release Hit http://us.archive.ubuntu.com precise Release.gpg Hit http://us.archive.ubuntu.com precise-updates Release.gpg Hit http://u12.amahi.org Amahi InRelease Hit http://us.archive.ubuntu.com precise-backports Release.gpg Hit http://us.archive.ubuntu.com precise Release Hit http://security.ubuntu.com precise-security/main Sources Hit http://us.archive.ubuntu.com precise-updates Release Hit http://us.archive.ubuntu.com precise-backports Release Hit http://security.ubuntu.com precise-security/restricted Sources Hit http://security.ubuntu.com precise-security/universe Sources Hit http://security.ubuntu.com precise-security/multiverse Sources Hit http://security.ubuntu.com precise-security/main amd64 Packages Hit http://security.ubuntu.com precise-security/restricted amd64 Packages Hit http://security.ubuntu.com precise-security/universe amd64 Packages Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages Hit http://security.ubuntu.com precise-security/main i386 Packages Hit http://security.ubuntu.com precise-security/restricted i386 Packages Hit http://security.ubuntu.com precise-security/universe i386 Packages Hit http://us.archive.ubuntu.com precise/main Sources Hit http://us.archive.ubuntu.com precise/restricted Sources Hit http://us.archive.ubuntu.com precise/universe Sources Hit http://us.archive.ubuntu.com precise/multiverse Sources Hit http://us.archive.ubuntu.com precise/main amd64 Packages Hit http://us.archive.ubuntu.com precise/restricted amd64 Packages Hit http://us.archive.ubuntu.com precise/universe amd64 Packages Hit http://us.archive.ubuntu.com precise/multiverse amd64 Packages Hit http://us.archive.ubuntu.com precise/main i386 Packages Hit http://security.ubuntu.com precise-security/multiverse i386 Packages Hit http://us.archive.ubuntu.com precise/restricted i386 Packages Hit http://us.archive.ubuntu.com precise/universe i386 Packages Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages Hit http://us.archive.ubuntu.com precise/main TranslationIndex Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex Hit http://security.ubuntu.com precise-security/main TranslationIndex Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex Hit http://security.ubuntu.com precise-security/restricted TranslationIndex Hit http://security.ubuntu.com precise-security/universe TranslationIndex Hit http://u12.amahi.org Amahi/main amd64 Packages Hit http://us.archive.ubuntu.com precise/universe TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/main Sources Hit http://us.archive.ubuntu.com precise-updates/restricted Sources Hit http://us.archive.ubuntu.com precise-updates/universe Sources Hit http://us.archive.ubuntu.com precise-updates/multiverse Sources Hit http://us.archive.ubuntu.com precise-updates/main amd64 Packages Hit http://us.archive.ubuntu.com precise-updates/restricted amd64 Packages Hit http://us.archive.ubuntu.com precise-updates/universe amd64 Packages Hit http://us.archive.ubuntu.com precise-updates/multiverse amd64 Packages Hit http://us.archive.ubuntu.com precise-updates/main i386 Packages Hit http://security.ubuntu.com precise-security/main Translation-en Hit http://security.ubuntu.com precise-security/multiverse Translation-en Hit http://security.ubuntu.com precise-security/restricted Translation-en Hit http://us.archive.ubuntu.com precise-updates/restricted i386 Packages Hit http://us.archive.ubuntu.com precise-updates/universe i386 Packages Hit http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages Hit http://us.archive.ubuntu.com precise-updates/main TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/universe TranslationIndex Hit http://us.archive.ubuntu.com precise-backports/main Sources Hit http://us.archive.ubuntu.com precise-backports/restricted Sources Hit http://security.ubuntu.com precise-security/universe Translation-en Hit http://us.archive.ubuntu.com precise-backports/universe Sources Hit http://us.archive.ubuntu.com precise-backports/multiverse Sources Hit http://us.archive.ubuntu.com precise-backports/main amd64 Packages Hit http://us.archive.ubuntu.com precise-backports/restricted amd64 Packages Hit http://us.archive.ubuntu.com precise-backports/universe amd64 Packages Hit http://us.archive.ubuntu.com precise-backports/multiverse amd64 Packages Hit http://us.archive.ubuntu.com precise-backports/main i386 Packages Hit http://us.archive.ubuntu.com precise-backports/restricted i386 Packages Hit http://us.archive.ubuntu.com precise-backports/universe i386 Packages Hit http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages Hit http://us.archive.ubuntu.com precise-backports/main TranslationIndex Hit http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex Hit http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex Hit http://us.archive.ubuntu.com precise-backports/universe TranslationIndex Hit http://us.archive.ubuntu.com precise/main Translation-en Hit http://u12.amahi.org Amahi/main i386 Packages Hit http://us.archive.ubuntu.com precise/multiverse Translation-en Hit http://us.archive.ubuntu.com precise/restricted Translation-en Hit http://us.archive.ubuntu.com precise/universe Translation-en Hit http://us.archive.ubuntu.com precise-updates/main Translation-en Hit http://us.archive.ubuntu.com precise-updates/multiverse Translation-en Hit http://us.archive.ubuntu.com precise-updates/restricted Translation-en Hit http://us.archive.ubuntu.com precise-updates/universe Translation-en Hit http://us.archive.ubuntu.com precise-backports/main Translation-en Hit http://us.archive.ubuntu.com precise-backports/multiverse Translation-en Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en Hit http://us.archive.ubuntu.com precise-backports/universe Translation-en Hit http://u12.amahi.org Amahi/main TranslationIndex E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. sed: can't read /etc/init/isc-dhcp-server.conf: No such file or directory sed: can't read /etc/init/isc-dhcp-server.conf: No such file or directory
Now, within the last few lines, it tells you to run sudo dpkg --configure -a. I ran that and it "did stuff" - seemingly without issue - but the script didn't seem to do all it was supposed to do. The IP is never statically assigned. So, running it again yields the errors and logs below.

error

Code: Select all

willybay@willybay-hda:~$ sh install-amahi Welcome to Amahi for Ubuntu! This will install Amahi and will ask your password, for admin access It creates a log file in /tmp/amahi-repo-setup.1822.log Please enter your install code from http://amahi.org for this HDA: EKQSH2G [sudo] password for willybay: Disabling apparmor Installing the amahi Amahi Ubuntu repo Updating the repo Installing the Amahi platform (this may take a few minutes) Patching the dhcpd PID issue. Kicking off the Amahi installer (this may take a few more minutes) Verbose log file at '/root/hda-install-130212-175330.log'. Retrieving install code ... Install code looks good /usr/lib/ruby/1.8/open-uri.rb:211: command not found: gem list Starting MySQL /usr/lib/ruby/1.8/open-uri.rb:32:in `initialize': Input/output error - /etc/sysconfig/dnssec (Errno::EIO) from /usr/lib/ruby/1.8/open-uri.rb:32:in `open_uri_original_open' from /usr/lib/ruby/1.8/open-uri.rb:32:in `open' from /usr/bin/hda-install:1247:in `disable_dnssec' from /usr/bin/hda-install:943:in `do_full_install' from /usr/bin/hda-install:1490:in `main' from /usr/bin/hda-install:1493 install-amahi: 89: install-amahi: cannot create /home/willybay/Desktop/Amahi-Dashboard-Home.desktop: Read-only file system install-amahi: 99: install-amahi: cannot create /home/willybay/Desktop/Amahi-Live-Help.desktop: Read-only file system *************************************************** *************************************************** ***** Reboot to get started with Amahi ***** *************************************************** *************************************************** willybay@willybay-hda:~$
log

Code: Select all

/etc/init.d/apparmor: 35: .: Can't open /lib/apparmor/functions invoke-rc.d: initscript apparmor, action "kill" failed. Removing any system startup links for /etc/init.d/apparmor ... Reading package lists... Building dependency tree... Reading state information... Package apparmor is not installed, so not removed Package apparmor-utils is not installed, so not removed The following packages were automatically installed and are no longer required: linux-headers-3.2.0-23-generic linux-headers-3.2.0-23 Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. --2013-02-12 17:52:36-- http://u12.amahi.org/amahi-ubuntu.asc Resolving u12.amahi.org (u12.amahi.org)... 208.115.201.197 Connecting to u12.amahi.org (u12.amahi.org)|208.115.201.197|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 1748 (1.7K) [text/plain] Saving to: `amahi-ubuntu.asc' 0K . 100% 97.3M=0s 2013-02-12 17:52:36 (97.3 MB/s) - `amahi-ubuntu.asc' saved [1748/1748] --2013-02-12 17:52:36-- http://u12.amahi.org/amahi-dice.svg Resolving u12.amahi.org (u12.amahi.org)... 208.115.201.197 Connecting to u12.amahi.org (u12.amahi.org)|208.115.201.197|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 36827 (36K) [image/svg+xml] Saving to: `amahi-dice.svg' 0K .......... .......... .......... ..... 100% 327K=0.1s 2013-02-12 17:52:36 (327 KB/s) - `amahi-dice.svg' saved [36827/36827] OK Ign http://us.archive.ubuntu.com precise InRelease Ign http://us.archive.ubuntu.com precise-updates InRelease Ign http://us.archive.ubuntu.com precise-backports InRelease Hit http://u12.amahi.org Amahi InRelease Hit http://us.archive.ubuntu.com precise Release.gpg Get:1 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B] Get:2 http://us.archive.ubuntu.com precise-backports Release.gpg [198 B] Hit http://us.archive.ubuntu.com precise Release Ign http://security.ubuntu.com precise-security InRelease Get:3 http://us.archive.ubuntu.com precise-updates Release [49.6 kB] Get:4 http://us.archive.ubuntu.com precise-backports Release [49.6 kB] Get:5 http://security.ubuntu.com precise-security Release.gpg [198 B] Hit http://u12.amahi.org Amahi/main amd64 Packages Hit http://us.archive.ubuntu.com precise/main Sources Hit http://us.archive.ubuntu.com precise/restricted Sources Hit http://us.archive.ubuntu.com precise/universe Sources Hit http://us.archive.ubuntu.com precise/multiverse Sources Hit http://us.archive.ubuntu.com precise/main amd64 Packages Hit http://us.archive.ubuntu.com precise/restricted amd64 Packages Hit http://us.archive.ubuntu.com precise/universe amd64 Packages Hit http://us.archive.ubuntu.com precise/multiverse amd64 Packages Hit http://us.archive.ubuntu.com precise/main i386 Packages Hit http://us.archive.ubuntu.com precise/restricted i386 Packages Hit http://us.archive.ubuntu.com precise/universe i386 Packages Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages Hit http://us.archive.ubuntu.com precise/main TranslationIndex Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex Hit http://us.archive.ubuntu.com precise/universe TranslationIndex Get:6 http://us.archive.ubuntu.com precise-updates/main Sources [366 kB] Get:7 http://security.ubuntu.com precise-security Release [49.6 kB] Hit http://u12.amahi.org Amahi/main i386 Packages Get:8 http://us.archive.ubuntu.com precise-updates/restricted Sources [5,135 B] Get:9 http://us.archive.ubuntu.com precise-updates/universe Sources [78.6 kB] Hit http://u12.amahi.org Amahi/main TranslationIndex Get:10 http://us.archive.ubuntu.com precise-updates/multiverse Sources [4,726 B] Get:11 http://us.archive.ubuntu.com precise-updates/main amd64 Packages [574 kB] Get:12 http://security.ubuntu.com precise-security/main Sources [63.1 kB] Get:13 http://us.archive.ubuntu.com precise-updates/restricted amd64 Packages [9,565 B] Get:14 http://us.archive.ubuntu.com precise-updates/universe amd64 Packages [180 kB] Get:15 http://us.archive.ubuntu.com precise-updates/multiverse amd64 Packages [9,435 B] Get:16 http://us.archive.ubuntu.com precise-updates/main i386 Packages [584 kB] Get:17 http://security.ubuntu.com precise-security/restricted Sources [1,950 B] Get:18 http://security.ubuntu.com precise-security/universe Sources [21.4 kB] Get:19 http://security.ubuntu.com precise-security/multiverse Sources [1,380 B] Get:20 http://security.ubuntu.com precise-security/main amd64 Packages [225 kB] Get:21 http://us.archive.ubuntu.com precise-updates/restricted i386 Packages [9,503 B] Get:22 http://us.archive.ubuntu.com precise-updates/universe i386 Packages [181 kB] Get:23 http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages [10.4 kB] Hit http://us.archive.ubuntu.com precise-updates/main TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex Hit http://us.archive.ubuntu.com precise-updates/universe TranslationIndex Get:24 http://us.archive.ubuntu.com precise-backports/main Sources [2,422 B] Get:25 http://us.archive.ubuntu.com precise-backports/restricted Sources [14 B] Get:26 http://us.archive.ubuntu.com precise-backports/universe Sources [21.8 kB] Get:27 http://us.archive.ubuntu.com precise-backports/multiverse Sources [2,669 B] Get:28 http://security.ubuntu.com precise-security/restricted amd64 Packages [3,969 B] Get:29 http://security.ubuntu.com precise-security/universe amd64 Packages [66.7 kB] Get:30 http://us.archive.ubuntu.com precise-backports/main amd64 Packages [1,945 B] Get:31 http://us.archive.ubuntu.com precise-backports/restricted amd64 Packages [14 B] Get:32 http://us.archive.ubuntu.com precise-backports/universe amd64 Packages [22.3 kB] Get:33 http://us.archive.ubuntu.com precise-backports/multiverse amd64 Packages [2,489 B] Get:34 http://us.archive.ubuntu.com precise-backports/main i386 Packages [1,941 B] Get:35 http://us.archive.ubuntu.com precise-backports/restricted i386 Packages [14 B] Get:36 http://us.archive.ubuntu.com precise-backports/universe i386 Packages [22.4 kB] Get:37 http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages [2,504 B] Hit http://us.archive.ubuntu.com precise-backports/main TranslationIndex Hit http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex Get:38 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2,182 B] Get:39 http://security.ubuntu.com precise-security/main i386 Packages [234 kB] Hit http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex Hit http://us.archive.ubuntu.com precise-backports/universe TranslationIndex Hit http://us.archive.ubuntu.com precise/main Translation-en Hit http://us.archive.ubuntu.com precise/multiverse Translation-en Hit http://us.archive.ubuntu.com precise/restricted Translation-en Hit http://us.archive.ubuntu.com precise/universe Translation-en Hit http://us.archive.ubuntu.com precise-updates/main Translation-en Hit http://us.archive.ubuntu.com precise-updates/multiverse Translation-en Hit http://us.archive.ubuntu.com precise-updates/restricted Translation-en Hit http://us.archive.ubuntu.com precise-updates/universe Translation-en Hit http://us.archive.ubuntu.com precise-backports/main Translation-en Hit http://us.archive.ubuntu.com precise-backports/multiverse Translation-en Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en Hit http://us.archive.ubuntu.com precise-backports/universe Translation-en Get:40 http://security.ubuntu.com precise-security/restricted i386 Packages [3,968 B] Get:41 http://security.ubuntu.com precise-security/universe i386 Packages [68.3 kB] Get:42 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,371 B] Hit http://security.ubuntu.com precise-security/main TranslationIndex Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex Hit http://security.ubuntu.com precise-security/restricted TranslationIndex Hit http://security.ubuntu.com precise-security/universe TranslationIndex Hit http://security.ubuntu.com precise-security/main Translation-en Hit http://security.ubuntu.com precise-security/multiverse Translation-en Hit http://security.ubuntu.com precise-security/restricted Translation-en Hit http://security.ubuntu.com precise-security/universe Translation-en Fetched 2,935 kB in 2s (1,458 kB/s) Reading package lists... Reading package lists... Building dependency tree... Reading state information... bc is already the newest version. The following packages were automatically installed and are no longer required: linux-headers-3.2.0-23-generic linux-headers-3.2.0-23 Use 'apt-get autoremove' to remove them. The following extra packages will be installed: hddtemp libdbd-mysql-ruby libencode-locale-perl libfcgi-ruby1.8 libfcgi0ldbl libfile-copy-recursive-perl libfile-listing-perl libfont-afm-perl libgd-ruby libgd-ruby1.8 libgruff-ruby libhtml-form-perl libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libio-socket-inet6-perl libio-socket-ssl-perl libjs-prototype libjs-scriptaculous libldap-ruby1.8 liblqr-1-0 liblwp-mediatypes-perl liblwp-protocol-https-perl libmagickcore4 libmailtools-perl libmemcache-client-ruby libmemcache-client-ruby1.8 libmysql-ruby1.8 libnet-http-perl libnet-ssleay-perl libruby libsocket6-perl libtzinfo-ruby libtzinfo-ruby1.8 liburi-perl libwww-perl libwww-robotrules-perl monit mysql-server php5 php5-mysql rails rake ri1.8 ruby-actionmailer-2.3 ruby-actionpack-2.3 ruby-activerecord-2.3 ruby-activeresource-2.3 ruby-activesupport-2.3 ruby-blankslate ruby-builder ruby-dbd-mysql ruby-gruff ruby-i18n ruby-ldap ruby-mysql ruby-rack ruby-rails-2.3 ruby-rchardet ruby-rmagick ruby-text-format ruby-tmail ruby1.8-dev rubygems samba samba-common samba-common-bin tdb-tools unzip update-inetd zip Suggested packages: ksensors libdata-dump-perl libcrypt-ssleay-perl libmagickcore4-extra libauthen-ntlm-perl exim4 postfix mail-transport-agent openbsd-inetd inet-superserver smbldap-tools ldb-tools ctdb The following NEW packages will be installed: hda-platform hdactl hddtemp libdbd-mysql-ruby libencode-locale-perl libfcgi-ruby1.8 libfcgi0ldbl libfile-copy-recursive-perl libfile-listing-perl libfont-afm-perl libgd-ruby libgd-ruby1.8 libgruff-ruby libhtml-form-perl libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libio-socket-inet6-perl libio-socket-ssl-perl libjs-prototype libjs-scriptaculous libldap-ruby1.8 liblqr-1-0 liblwp-mediatypes-perl liblwp-protocol-https-perl libmagickcore4 libmailtools-perl libmemcache-client-ruby libmemcache-client-ruby1.8 libmysql-ruby1.8 libnet-http-perl libnet-ssleay-perl libruby libsocket6-perl libtzinfo-ruby libtzinfo-ruby1.8 liburi-perl libwww-perl libwww-robotrules-perl monit mysql-server php5 php5-mysql rails rake ri1.8 ruby-actionmailer-2.3 ruby-actionpack-2.3 ruby-activerecord-2.3 ruby-activeresource-2.3 ruby-activesupport-2.3 ruby-blankslate ruby-builder ruby-dbd-mysql ruby-gruff ruby-i18n ruby-ldap ruby-mysql ruby-rack ruby-rails-2.3 ruby-rchardet ruby-rmagick ruby-text-format ruby-tmail ruby1.8-dev rubygems samba samba-common samba-common-bin tdb-tools unzip update-inetd zip Extracting templates from packages: 37% Extracting templates from packages: 75% Extracting templates from packages: 100% Preconfiguring packages ... 0 upgraded, 79 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B/25.0 MB of archives. After this operation, 91.2 MB of additional disk space will be used. Selecting previously unselected package ruby-mysql. (Reading database ... 80967 files and directories currently installed.) Unpacking ruby-mysql (from .../ruby-mysql_2.8.2+gem2deb-1build1_amd64.deb) ... Selecting previously unselected package ruby-dbd-mysql. Unpacking ruby-dbd-mysql (from .../ruby-dbd-mysql_0.4.4+gem2deb-1_all.deb) ... Selecting previously unselected package libdbd-mysql-ruby. Unpacking libdbd-mysql-ruby (from .../libdbd-mysql-ruby_0.4.4+gem2deb-1_all.deb) ... Selecting previously unselected package libencode-locale-perl. Unpacking libencode-locale-perl (from .../libencode-locale-perl_1.02-2_all.deb) ... Selecting previously unselected package libfcgi0ldbl. Unpacking libfcgi0ldbl (from .../libfcgi0ldbl_2.4.0-8.1_amd64.deb) ... Selecting previously unselected package libfcgi-ruby1.8. Unpacking libfcgi-ruby1.8 (from .../libfcgi-ruby1.8_0.8.8-1_amd64.deb) ... Selecting previously unselected package libfile-copy-recursive-perl. Unpacking libfile-copy-recursive-perl (from .../libfile-copy-recursive-perl_0.38-1_all.deb) ... Selecting previously unselected package libhttp-date-perl. Unpacking libhttp-date-perl (from .../libhttp-date-perl_6.00-1_all.deb) ... Selecting previously unselected package libfile-listing-perl. Unpacking libfile-listing-perl (from .../libfile-listing-perl_6.03-1_all.deb) ... Selecting previously unselected package libfont-afm-perl. Unpacking libfont-afm-perl (from .../libfont-afm-perl_1.20-1_all.deb) ... Selecting previously unselected package libgd-ruby1.8. Unpacking libgd-ruby1.8 (from .../libgd-ruby1.8_0.7.4.1-6.1_amd64.deb) ... Selecting previously unselected package libgd-ruby. Unpacking libgd-ruby (from .../libgd-ruby_0.7.4.1-6.1_all.deb) ... Selecting previously unselected package liblqr-1-0. Unpacking liblqr-1-0 (from .../liblqr-1-0_0.4.1-1.1_amd64.deb) ... Selecting previously unselected package libmagickcore4. Unpacking libmagickcore4 (from .../libmagickcore4_8%3a6.6.9.7-5ubuntu3.2_amd64.deb) ... Selecting previously unselected package ruby-rmagick. Unpacking ruby-rmagick (from .../ruby-rmagick_2.13.1-5build1_amd64.deb) ... Selecting previously unselected package ruby-gruff. Unpacking ruby-gruff (from .../ruby-gruff_0.3.6-5_all.deb) ... Selecting previously unselected package libgruff-ruby. Unpacking libgruff-ruby (from .../libgruff-ruby_0.3.6-5_all.deb) ... Selecting previously unselected package liburi-perl. Unpacking liburi-perl (from .../liburi-perl_1.59-1_all.deb) ... Selecting previously unselected package libhtml-tagset-perl. Unpacking libhtml-tagset-perl (from .../libhtml-tagset-perl_3.20-2_all.deb) ... Selecting previously unselected package libhtml-parser-perl. Unpacking libhtml-parser-perl (from .../libhtml-parser-perl_3.69-1build1_amd64.deb) ... Selecting previously unselected package liblwp-mediatypes-perl. Unpacking liblwp-mediatypes-perl (from .../liblwp-mediatypes-perl_6.01-1_all.deb) ... Selecting previously unselected package libhttp-message-perl. Unpacking libhttp-message-perl (from .../libhttp-message-perl_6.01-1_all.deb) ... Selecting previously unselected package libhtml-form-perl. Unpacking libhtml-form-perl (from .../libhtml-form-perl_6.00-1_all.deb) ... Selecting previously unselected package libhtml-tree-perl. Unpacking libhtml-tree-perl (from .../libhtml-tree-perl_4.2-1_all.deb) ... Selecting previously unselected package libhtml-format-perl. Unpacking libhtml-format-perl (from .../libhtml-format-perl_2.10-1_all.deb) ... Selecting previously unselected package libhttp-cookies-perl. Unpacking libhttp-cookies-perl (from .../libhttp-cookies-perl_6.00-2_all.deb) ... Selecting previously unselected package libhttp-daemon-perl. Unpacking libhttp-daemon-perl (from .../libhttp-daemon-perl_6.00-1_all.deb) ... Selecting previously unselected package libhttp-negotiate-perl. Unpacking libhttp-negotiate-perl (from .../libhttp-negotiate-perl_6.00-2_all.deb) ... Selecting previously unselected package libsocket6-perl. Unpacking libsocket6-perl (from .../libsocket6-perl_0.23-1build2_amd64.deb) ... Selecting previously unselected package libio-socket-inet6-perl. Unpacking libio-socket-inet6-perl (from .../libio-socket-inet6-perl_2.69-2_all.deb) ... Selecting previously unselected package libnet-ssleay-perl. Unpacking libnet-ssleay-perl (from .../libnet-ssleay-perl_1.42-1build1_amd64.deb) ... Selecting previously unselected package libio-socket-ssl-perl. Unpacking libio-socket-ssl-perl (from .../libio-socket-ssl-perl_1.53-1_all.deb) ... Selecting previously unselected package libjs-prototype. Unpacking libjs-prototype (from .../libjs-prototype_1.7.0-2_all.deb) ... Selecting previously unselected package libjs-scriptaculous. Unpacking libjs-scriptaculous (from .../libjs-scriptaculous_1.9.0-2_all.deb) ... Selecting previously unselected package ruby-ldap. Unpacking ruby-ldap (from .../ruby-ldap_0.9.11-1_amd64.deb) ... Selecting previously unselected package libldap-ruby1.8. Unpacking libldap-ruby1.8 (from .../libldap-ruby1.8_0.9.11-1_all.deb) ... Selecting previously unselected package libnet-http-perl. Unpacking libnet-http-perl (from .../libnet-http-perl_6.02-1_all.deb) ... Selecting previously unselected package libwww-robotrules-perl. Unpacking libwww-robotrules-perl (from .../libwww-robotrules-perl_6.01-1_all.deb) ... Selecting previously unselected package libwww-perl. Unpacking libwww-perl (from .../libwww-perl_6.03-1_all.deb) ... Selecting previously unselected package liblwp-protocol-https-perl. Unpacking liblwp-protocol-https-perl (from .../liblwp-protocol-https-perl_6.02-1_all.deb) ... Selecting previously unselected package libmailtools-perl. Unpacking libmailtools-perl (from .../libmailtools-perl_2.08-1_all.deb) ... Selecting previously unselected package libmysql-ruby1.8. Unpacking libmysql-ruby1.8 (from .../libmysql-ruby1.8_2.8.2+gem2deb-1build1_all.deb) ... Selecting previously unselected package libruby. Unpacking libruby (from .../archives/libruby_4.8_all.deb) ... Selecting previously unselected package mysql-server. Unpacking mysql-server (from .../mysql-server_5.5.29-0ubuntu0.12.04.1_all.deb) ... Selecting previously unselected package php5. Unpacking php5 (from .../php5_5.3.10-1ubuntu3.5_all.deb) ... Selecting previously unselected package php5-mysql. Unpacking php5-mysql (from .../php5-mysql_5.3.10-1ubuntu3.5_amd64.deb) ... Selecting previously unselected package rubygems. Unpacking rubygems (from .../rubygems_1.8.15-1ubuntu0.1_all.deb) ... Selecting previously unselected package rake. Unpacking rake (from .../rake_0.9.2.2-2_all.deb) ... Selecting previously unselected package ruby-blankslate. Unpacking ruby-blankslate (from .../ruby-blankslate_2.1.2.4-2_all.deb) ... Selecting previously unselected package ruby-builder. Unpacking ruby-builder (from .../ruby-builder_3.0.0-2_all.deb) ... Selecting previously unselected package ruby-i18n. Unpacking ruby-i18n (from .../ruby-i18n_0.6.0-1_all.deb) ... Selecting previously unselected package libmemcache-client-ruby1.8. Unpacking libmemcache-client-ruby1.8 (from .../libmemcache-client-ruby1.8_1.7.8-2_all.deb) ... Selecting previously unselected package libmemcache-client-ruby. Unpacking libmemcache-client-ruby (from .../libmemcache-client-ruby_1.7.8-2_all.deb) ... Selecting previously unselected package libtzinfo-ruby1.8. Unpacking libtzinfo-ruby1.8 (from .../libtzinfo-ruby1.8_0.3.19-1_all.deb) ... Selecting previously unselected package libtzinfo-ruby. Unpacking libtzinfo-ruby (from .../libtzinfo-ruby_0.3.19-1_all.deb) ... Selecting previously unselected package ruby-activesupport-2.3. Unpacking ruby-activesupport-2.3 (from .../ruby-activesupport-2.3_2.3.14-2ubuntu0.12.04.1_all.deb) ... Selecting previously unselected package ruby-activerecord-2.3. Unpacking ruby-activerecord-2.3 (from .../ruby-activerecord-2.3_2.3.14-1ubuntu0.12.04.1_all.deb) ... Selecting previously unselected package ruby-rack. Unpacking ruby-rack (from .../ruby-rack_1.3.5-1_all.deb) ... Selecting previously unselected package ruby-actionpack-2.3. Unpacking ruby-actionpack-2.3 (from .../ruby-actionpack-2.3_2.3.14-2ubuntu0.12.04.1_all.deb) ... Selecting previously unselected package ruby-text-format. Unpacking ruby-text-format (from .../ruby-text-format_1.0.0-3_all.deb) ... Selecting previously unselected package ruby-rchardet. Unpacking ruby-rchardet (from .../ruby-rchardet_1.3-2_all.deb) ... Selecting previously unselected package ruby-tmail. Unpacking ruby-tmail (from .../ruby-tmail_1.2.7.1-1build1_amd64.deb) ... Selecting previously unselected package ruby-actionmailer-2.3. Unpacking ruby-actionmailer-2.3 (from .../ruby-actionmailer-2.3_2.3.14-2_all.deb) ... Selecting previously unselected package ruby-activeresource-2.3. Unpacking ruby-activeresource-2.3 (from .../ruby-activeresource-2.3_2.3.14-1_all.deb) ... Selecting previously unselected package ruby-rails-2.3. Unpacking ruby-rails-2.3 (from .../ruby-rails-2.3_2.3.14-2_all.deb) ... Selecting previously unselected package rails. Unpacking rails (from .../rails_2.3.14.1_all.deb) ... Selecting previously unselected package ri1.8. Unpacking ri1.8 (from .../ri1.8_1.8.7.352-2ubuntu1.1_all.deb) ... Selecting previously unselected package ruby1.8-dev. Unpacking ruby1.8-dev (from .../ruby1.8-dev_1.8.7.352-2ubuntu1.1_amd64.deb) ... Selecting previously unselected package samba-common. Unpacking samba-common (from .../samba-common_2%3a3.6.3-2ubuntu2.3_all.deb) ... Selecting previously unselected package update-inetd. Unpacking update-inetd (from .../update-inetd_4.41_all.deb) ... Selecting previously unselected package samba-common-bin. Unpacking samba-common-bin (from .../samba-common-bin_2%3a3.6.3-2ubuntu2.3_amd64.deb) ... dpkg-deb (subprocess): data: internal gzip read error: '<fd:4>: invalid literal/lengths set' dpkg-deb: error: subprocess <decompress> returned error exit status 2 dpkg: error processing /var/cache/apt/archives/samba-common-bin_2%3a3.6.3-2ubuntu2.3_amd64.deb (--unpack): short read on buffer copy for backend dpkg-deb during `./usr/bin/net.samba3' Selecting previously unselected package samba. Unpacking samba (from .../samba_2%3a3.6.3-2ubuntu2.3_amd64.deb) ... dpkg-deb (subprocess): data: internal gzip read error: '<fd:4>: invalid literal/lengths set' dpkg-deb: error: subprocess <decompress> returned error exit status 2 dpkg: error processing /var/cache/apt/archives/samba_2%3a3.6.3-2ubuntu2.3_amd64.deb (--unpack): short read on buffer copy for backend dpkg-deb during `./usr/sbin/smbd' Bareword found where operator expected at /usr/share/perl/5.14/File/Basename.pm line 134, near "$type ey" (Missing operator before ey?) String found where operator expected at /usr/share/perl/5.14/File/Basename.pm line 134, near "ey "MacOS"" (Do you need to predeclare ey?) Selecting previously unselected package tdb-tools. Unpacking tdb-tools (from .../tdb-tools_1.2.9-4_amd64.deb) ... Selecting previously unselected package unzip. Unpacking unzip (from .../unzip_6.0-4ubuntu1_amd64.deb) ... Selecting previously unselected package zip. Unpacking zip (from .../archives/zip_3.0-4_amd64.deb) ... Selecting previously unselected package monit. Unpacking monit (from .../monit_1%3a5.3.2-1_amd64.deb) ... dpkg-deb (subprocess): data: internal gzip read error: '<fd:4>: data error' dpkg-deb: error: subprocess <decompress> returned error exit status 2 dpkg: error processing /var/cache/apt/archives/monit_1%3a5.3.2-1_amd64.deb (--unpack): subprocess dpkg-deb --fsys-tarfile returned error exit status 2 No apport report written because the error message indicates an issue on the local system Selecting previously unselected package hdactl. Unpacking hdactl (from .../hdactl_4.2.6_amd64.deb) ... Selecting previously unselected package hddtemp. Unpacking hddtemp (from .../hddtemp_0.3-beta15-51_amd64.deb) ... Selecting previously unselected package hda-platform. Unpacking hda-platform (from .../hda-platform_6.2.1_all.deb) ... dpkg-deb (subprocess): data: internal gzip read error: '<fd:4>: data error' dpkg-deb: error: subprocess <decompress> returned error exit status 2 dpkg: error processing /var/cache/apt/archives/hda-platform_6.2.1_all.deb (--unpack): subprocess dpkg-deb --fsys-tarfile returned error exit status 2 No apport report written because MaxReports is reached already Processing triggers for man-db ... Bus error (core dumped) Processing triggers for libapache2-mod-php5 ... * Reloading web server config apache2 ...done. Processing triggers for ufw ... Processing triggers for ureadahead ... ureadahead will be reprofiled on next reboot Errors were encountered while processing: /var/cache/apt/archives/samba-common-bin_2%3a3.6.3-2ubuntu2.3_amd64.deb /var/cache/apt/archives/samba_2%3a3.6.3-2ubuntu2.3_amd64.deb /var/cache/apt/archives/monit_1%3a5.3.2-1_amd64.deb /var/cache/apt/archives/hda-platform_6.2.1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
Frankly, I'm afraid to run it again. I'm not sure what's going on but it doesn't like something on this very basic Ubuntu 12.04.2 Server setup.
Amahi HDA:
  • MOBO: ASRock K10N78
  • CPU: AMD Athlon II 64 X2 Dual Core Processor 5600+
  • RAM: 2-GB (dual-channel)
  • HDDs: WD20EARS (qty: 4)
HTPC:
  • Boxee Box
  • Popcorn Hour A-400

Who is online

Users browsing this forum: No registered users and 2 guests