Can't Access Apps, VPN on and working...

topfire
Posts: 12
Joined: Tue Jul 24, 2012 2:21 am

Can't Access Apps, VPN on and working...

Postby topfire » Mon Jul 30, 2012 1:39 pm

Hey
New here and wow Amahi is really something, well compared to Windows Home Server anyway.
Everything is set-up fine, PDC, DHCP, Shares, etc etc
But I can't seem to access any apps from outside the network, VPN is setup and working as I can access \\HDA and \\10.0.0.33 and everything like that apart from as well as e.g "http://icalendar.home.com/" sends me to "Welcome to Home.com" and the proper site so obviously DNS isn't working as it should, shouldnt it re-direct me to the server's -APPNAME-.home.com instead of the actual website home.com?
Using HDA Connect 3 and as much as I would like to Purchasing Open VPN ALS isn't really a option at the moment
And especially as I am away trying to remotely setup for accessing apps it's a tad annoying
Any ideas guys?
Thanks
Jamie :)

User avatar
bigfoot65
Project Manager
Posts: 11391
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Access Apps, VPN on and working...

Postby bigfoot65 » Mon Jul 30, 2012 3:12 pm

Is home.com your domain for the HDA? Also, are you using Ubuntu or Fedora? For Ubuntu you have to install OpenVPN via a web app in your dashboard and then forward port 1194 UDP to your HDA IP.

If you have done all that, recommend you try the troubleshooter.

http://wiki.amahi.org/index.php/VPN_troubleshooting
ßîgƒσστ65
Applications Manager

topfire
Posts: 12
Joined: Tue Jul 24, 2012 2:21 am

Re: Can't Access Apps, VPN on and working...

Postby topfire » Mon Jul 30, 2012 3:23 pm

Yes it is the domain name and it's ubuntu sorry for not posting above, I don't think it's the setup of vpn as I can access the files via windows explorer but not the apps, so it's more of a dns problem? The amahi panel said it's all ready to use and just install a client, I have, so I think I've installed the app but will check in morning (11:22pm here uk), and thank you for your help so far
Jamie.

User avatar
bigfoot65
Project Manager
Posts: 11391
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Access Apps, VPN on and working...

Postby bigfoot65 » Mon Jul 30, 2012 3:28 pm

Ok, well hope the link might help. Otherwise we will have to pick a starting point and diagnose.
ßîgƒσστ65
Applications Manager

topfire
Posts: 12
Joined: Tue Jul 24, 2012 2:21 am

Re: Can't Access Apps, VPN on and working...

Postby topfire » Tue Jul 31, 2012 12:43 am

Good Morning from the UK :)
I tried going through the vpn troubleshooting and non of them seemed to apply, like I said earlier I can access it through windows explorer but not apps, here's a screenshot to help explain
Thanks
Jamie
Attachments
Untitled.png
Screen Shot Of accessing \\HDA but not being able to access site
Untitled.png (426.18 KiB) Viewed 969 times

User avatar
bigfoot65
Project Manager
Posts: 11391
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Access Apps, VPN on and working...

Postby bigfoot65 » Tue Jul 31, 2012 4:56 am

Can you access http://hda.home.com? Also what browser are you using and have you tried others?
ßîgƒσστ65
Applications Manager

topfire
Posts: 12
Joined: Tue Jul 24, 2012 2:21 am

Re: Can't Access Apps, VPN on and working...

Postby topfire » Tue Jul 31, 2012 5:42 am

Nope can't get on that or via any other browser, tried chrome, and Internet explorer, firefox that's why I think it's some sort of dns problem?

[ Post made via Android ] Image

User avatar
bigfoot65
Project Manager
Posts: 11391
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Access Apps, VPN on and working...

Postby bigfoot65 » Tue Jul 31, 2012 7:01 am

Ok, I presume you are using the HDA for DHCP and DNS. Try the network troubleshooter to see if it provides any clues?

http://wiki.amahi.org/index.php/Network_troubleshooting
ßîgƒσστ65
Applications Manager

topfire
Posts: 12
Joined: Tue Jul 24, 2012 2:21 am

Re: Can't Access Apps, VPN on and working...

Postby topfire » Tue Jul 31, 2012 8:59 am

Using the Network Troubleshooter, I failed step 11 - Router is reachable from clients?. Here's a paste to help troubleshoot: http://sprunge.us/ZjUe

Hmm care to take a look?
Thanks
Jamie :)

User avatar
bigfoot65
Project Manager
Posts: 11391
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Access Apps, VPN on and working...

Postby bigfoot65 » Tue Jul 31, 2012 10:39 am

Does your router IP match the gateway you listed on amahi.org? Also ensure the HDA IP and domain match the profile as well. If anything is off, that could cause problems.

Also is it possible there is a firewall in the way?
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest