Problem with DHCP and Debian and VirtIO network devices

Posts: 57
Joined: Mon Oct 22, 2012 5:10 pm

Problem with DHCP and Debian and VirtIO network devices

Postby genel » Mon Oct 27, 2014 5:41 pm

I have just finished upgrading to Amahi 7 and most everything is peachy. I have had a problem with DHCP, I have found a get around which is not too painful. I thought I would post both the problem and the get around so that maybe I could obtain some enlightenment or save someone some headache.

The setup:
I run Amahi under the Proxmox Virtual Environment (pve) normally I have no problems with this. I have a number of other virtual machines (One each Windows 7, Windows 8 and Windows 10) and a number of Debian clones I use to experiment with (mostly 7.6 but I upgraded one to 7.7). On most of these system I use the paravirtualized network device driver VirtIO.

The problem:
All of them worked except the Debian machines. Everything in the house (printer, TV, Wife's computer, several android gadgets) all work just fine and show up in the DHCP address list, but not the Debian machines. (Well Windows 10 is working pretty crappy, but for other reasons, what do you expect.)

The get around:
I changed the pve setting for the Debian machine to use one of the device emulators (either Intel E1000 or Realtec RTL8139; either one seems to work OK.) System came up and worked like a champ.

The question:
Anyone know why? The VirtIO device works fine on Windows 8 and on Windows 10 (when I can get it to boot). Even with Debian if I configure the IP address everything seems to work just fine. Is it the DHCP server or Debian or what?

So, if anyone else has this problem, this is what worked for me.


User avatar
Project Manager
Posts: 11922
Joined: Mon May 25, 2009 4:31 pm

Re: Problem with DHCP and Debian and VirtIO network devices

Postby bigfoot65 » Tue Oct 28, 2014 2:09 pm

I never use the VirtIO network device, typically one of the emulators. What I have found through experience with Proxmox and some Linux distros is that they aren't always compatible.

Makes more sense to use the emulator to me, plus I often don't use the Virtio drives either for the same reason.

Just my .02 cents.
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Who is online

Users browsing this forum: No registered users and 1 guest