Locally mounted shares show as empty

ksburgess
Posts: 34
Joined: Sun Jan 29, 2012 6:29 pm

Locally mounted shares show as empty

Postby ksburgess » Mon Apr 04, 2016 8:49 am

Hi friend at Amahi,

I followed the wiki instructions to mount my shares locally, and I can see the share names in /mnt/samba.

When I cd into a share directory, however, they show empty.

I look at the mysql troubleshooting and that doesn't seem to be a problem. Permissions in /var also look good for each share. In /mnt, the shares show as being owned by root:root. I changed one to username:users to see if that made a difference but that does not seem to have helped.

Any guidance would be greatly appreciated.

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Locally mounted shares show as empty

Postby bigfoot65 » Mon Apr 04, 2016 10:38 am

Check to ensure you have the .smb_credentials correct?

Also do as root user:

Code: Select all

service mount_shares_locally status
What is the output?
ßîgƒσστ65
Applications Manager

ksburgess
Posts: 34
Joined: Sun Jan 29, 2012 6:29 pm

Re: Locally mounted shares show as empty

Postby ksburgess » Mon Apr 04, 2016 2:27 pm

Thanks for replying Bigfoot :)

my .smb_credentials are definitely correct. They are set for my first admin user (my user) - with username and pass correct for that user. Domain is set as domain=HOME.

Our Windows workgroup has a different name than default, do you think that matters?

This is the output of that command:

Code: Select all

Usage: /etc/init.d/mount_shares_locally {start|stop|restart}
I tried doing a restart on the service and got this error thrown and I'm not sure why:

Code: Select all

Restarting mount_shares_locally (via systemctl): Error: No space left on device [ OK ]
There is lots of space on the OS disk - output of df -H:

Code: Select all

/dev/sdb3 311G 17G 279G 6% /


Both greyhole drives also have ~70% free

Wasn't getting that error earlier so now I'm really confused :(

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Locally mounted shares show as empty

Postby bigfoot65 » Mon Apr 04, 2016 5:23 pm

Please provide the URL for:

Code: Select all

fpaste --sysinfo
Also are your shares located in /var/hda/files? If so, then they are on the / drive.

Try stopping the mount_shares_locally script, restart Samba (file Server) via the dashboard, then start the mount_shares_locally script and see if that helps.
ßîgƒσστ65
Applications Manager

ksburgess
Posts: 34
Joined: Sun Jan 29, 2012 6:29 pm

Re: Locally mounted shares show as empty

Postby ksburgess » Tue Apr 05, 2016 2:35 am

fpaste:

http://paste.fedoraproject.org/349716/45984835/

My shares are in the default /var/hda/files, yes. Using grayhole to pool in two additional drives, but all three drives have tons of space on them so I do not know why I'm getting that error.

Anyways, I tried stopping the service, then restarting the samba service, and then starting the mount share service again, but the shares in /mnt/samba are still showing empty :(

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Locally mounted shares show as empty

Postby bigfoot65 » Tue Apr 05, 2016 1:28 pm

ßîgƒσστ65
Applications Manager

ksburgess
Posts: 34
Joined: Sun Jan 29, 2012 6:29 pm

Re: Locally mounted shares show as empty

Postby ksburgess » Tue Apr 05, 2016 2:00 pm

I definitely have cifs-utils installed, as I followed the guide exactly.

Any other way to troubleshoot to figure out what's going on?

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Locally mounted shares show as empty

Postby bigfoot65 » Tue Apr 05, 2016 7:08 pm

You can try checking log files in /var/logs directory.
ßîgƒσστ65
Applications Manager

ksburgess
Posts: 34
Joined: Sun Jan 29, 2012 6:29 pm

Re: Locally mounted shares show as empty

Postby ksburgess » Thu Apr 07, 2016 5:54 pm

:/ okay, don't really understand enough to know what to look for in there, so I'll try to find time to search online for help with that this weekend.

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Locally mounted shares show as empty

Postby bigfoot65 » Thu Apr 07, 2016 6:28 pm

The common log files page in the wiki may be helpful.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests