brand new install

jgutter
Posts: 9
Joined: Sat Jul 21, 2012 8:34 pm

brand new install

Postby jgutter » Sat Jul 21, 2012 8:40 pm

Hello i just did a brand new install of Ubuntu 12.04 x86 version server.
i did as requested and typed the following
wget http://u12.amahi.org/install-amahi

sh install-amahi

after its completed and asks me to reboot i then reboot my server
i then goto http://192.168.1.94:2000/
type in my code and hit install.
it goes thru and almost completes however the 1st line says this.

ERROR Verbose log file at '/root/hda-install-120721-233241.log'.

Retrieving install code ...

Install code looks good

Starting MySQL

Initializing MySQL

Initializing Storage Pooling ...

Installing pluginfactory ...

Initializing Ruby on Rails and DB

Activating your HDA's settings



at the bottom of the log it says"
mysql start/running, process 13255
^Gmysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
^Gmysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'
^Gmysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
rake aborted!
Access denied for user 'amahihda'@'localhost' (using password: YES)

Tasks: TOP => db:migrate
(See full trace by running task with --trace)
Error code: 1045
Error message: Access denied for user 'amahihda'@'localhost' (using password: YES)
Error SQLSTATE: 28000
"
any ideas ?
Thanks Jeff

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: brand new install

Postby bigfoot65 » Sat Jul 21, 2012 9:31 pm

Hello,

Please follow the instructions at http://doc.amahi.org. There is no web installer for Ubuntu and the instructions should not indicate such. You tried to install it twice, hence the errors on the second time.

Please let us know what instructions you followed. You will most likely need to start over from scratch with Ubuntu and Amahi install.
ßîgƒσστ65
Applications Manager

jgutter
Posts: 9
Joined: Sat Jul 21, 2012 8:34 pm

Re: brand new install

Postby jgutter » Sun Jul 22, 2012 7:41 am

instructions were located here that i used.
http://docs.amahi.org/ubuntu-12.html

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: brand new install

Postby bigfoot65 » Sun Jul 22, 2012 7:56 am

Ok, those are correct. However, no where in there does it say to use the web installer. You must follow those precisely for a successful install.

That extra step you took broke the install and will probably require you to start over from scratch. Please follow the instructions and report back.
ßîgƒσστ65
Applications Manager

jgutter
Posts: 9
Joined: Sat Jul 21, 2012 8:34 pm

Re: brand new install

Postby jgutter » Sun Jul 22, 2012 11:44 am

So if i do a clean install do i just choose ssh server so i can access it without having to move monitor and keyboard. and NOT choose LAMP ?

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: brand new install

Postby bigfoot65 » Sun Jul 22, 2012 11:55 am

If you are trying to install Ubuntu and Amahi headless, that is not currently possible. You have to have a monitor and keyboard to install both initially.

If you want to run a headless HDA, then use Ubuntu Server edition and not the desktop edition. Once you have both installed, you can then remove the keyboard and monitor from the HDA. There are apps to install SSH so you can access you server once you have Amahi installed. They are OpenSSH and Dropbear.

http://www.amahi.org/apps/openssh
http://www.amahi.org/apps/dropbear
ßîgƒσστ65
Applications Manager

prodriguezii
Posts: 32
Joined: Sun May 27, 2012 6:56 am

Re: brand new install

Postby prodriguezii » Sun Jul 22, 2012 1:10 pm

Not to deviate from the company line, but if you are installing Ubuntu 12.04 server, I had success installing with just SSH...no LAMP. Amahi will handle the LAMP setup when you install. This way you can setup the server with a monitor and keyboard but disconnect on reboot and install Amahi and everything else headless. Just my experience...yours may vary.

[ Post made via Windows Smartphone ] Image

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: brand new install

Postby bigfoot65 » Sun Jul 22, 2012 1:48 pm

Yes, that does work. If you install SSH, you can uninstall it once Amahi is installed and then instal the Amahi app. That gets you a more rebust setup with certs and a server status in the Dashboard.

There are many ways to install, but doing the LAMP install seems to cause problems with Amahi install. So best to stick with SSH as you did.
ßîgƒσστ65
Applications Manager

jgutter
Posts: 9
Joined: Sat Jul 21, 2012 8:34 pm

Re: brand new install

Postby jgutter » Mon Jul 23, 2012 2:17 pm

install was redone from scratch
now i have this .. is this normal ?
Welcome to Amahi for Ubuntu!
This will install Amahi and will ask your password, for admin access
It creates a log file in /tmp/amahi-repo-setup.1575.log
Please enter your install code from http://amahi.org for this HDA: C99CFM7
[sudo] password for jg:
Installing the amahi Amahi Ubuntu repo
Updating the repo
Installing the Amahi platform (this may take a few minutes)
Patching the dhcpd PID issue.
Kicking off the Amahi installer (this may take a few more minutes)
Verbose log file at '/root/hda-install-120723-163101.log'.
Retrieving install code ...
Install code looks good
Starting MySQL
Initializing MySQL
Initializing Storage Pooling ...
Installing pluginfactory ...
Initializing Ruby on Rails and DB
Activating your HDA's settings
ERROR 1045 (28000): Access denied for user 'amahihda'@'localhost' (using password: YES)
Patching the uid-500 issue.

***************************************************
***************************************************
***** Reboot to get started with Amahi *****
***************************************************
***************************************************
jgutter@ubuntu:~$

prodriguezii
Posts: 32
Joined: Sun May 27, 2012 6:56 am

Re: brand new install

Postby prodriguezii » Mon Jul 23, 2012 2:33 pm

I believe this would only happen if you installed MySQL (perhaps the LAMP option?) and set a db password before installing Amahi. If this is the case, do a fresh install and do not select ANYTHING from the additional features menu. Oh, and don't post your install code for all the world to see :-)

[ Post made via Windows Smartphone ] Image

Who is online

Users browsing this forum: No registered users and 2 guests