Seagate DockStar?

Posts: 1
Joined: Sun May 27, 2012 3:39 pm

Seagate DockStar?

Postby andyj » Sun May 27, 2012 4:00 pm

Anyone got a Seagate DockStar to work?

I have loaded v1.0 and v0.9 and everything seems ok at first - successful install screen shows up with the Reboot button. Reboot button does not work but I can Kitty ssh in and issue reboot from there ok.
Main problem is exactly the same as in -->
I have tried to reload without going to hda:2000 and found when I do a gems update it fails with "*** buffer overflow detected ***: /usr/bin/ruby terminated".
Guessing that if someone has a kernel that works - if I load, it should also work.

Please let me know if you have a working DockStar with Amahi.
And or any advice on this would help..

Thank you,

Posts: 3
Joined: Wed Jul 18, 2012 5:11 pm

Re: Seagate DockStar?

Postby jmcbri » Wed Jul 18, 2012 5:56 pm


I've been trying to setup Amahi on either a Dockstar or a Pogoplug 4 for about three weeks now using v.1.0.

There are apparently things I'm missing. I have not even been able to get either the PP4 or the Dockstar to boot. I'll focus on the Dockstar because I've had more success with it than the PP4.

When I boot the Dockstar with the Amahi rootfs (using instructions here:, the led goes solid yellow, but I can't see the ip on the dhcp client list on my router or with arp-scan or with nmap. I'm not that familar with those commands, but I can see all the other devices on the network with the those commands so I would think I'm in the ballpark.

I've installed multiple times, and the same thing over and over again. I've also tried multiple reboots, no help. Here's the output from netconsole on boot:

U-Boot 2011.12 (Feb 12 2012 - 21:33:07)
Seagate FreeAgent DockStar
arm-none-linux-gnueabi-gcc (Sourcery G++ Lite 2009q3-67) 4.4.1
GNU ld (Sourcery G++ Lite 2009q3-67)
Hit any key to stop autoboot: 0
(Re)start USB...
USB: Register 10011 NbrPorts 1
scanning bus for devices... 3 USB Device(s) found
scanning bus for storage devices... 1 Storage Device(s) found
Loading file "/rescueme" from usb device 0:1 (usbda1)
** File not found /rescueme
reading /rescueme.txt

** Unable to read "/rescueme.txt" from usb 0:1 **
Creating 1 MTD partitions on "nand0":
0x000002500000-0x000020000000 : "mtd=3"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size: 131072 bytes (128 KiB)
UBI: logical eraseblock size: 129024 bytes
UBI: smallest flash I/O unit: 2048
UBI: sub-page size: 512
UBI: VID header offset: 512 (aligned 512)
UBI: data offset: 2048
UBI: attached mtd1 to ubi0
UBI: MTD device name: "mtd=3"
UBI: MTD device size: 475 MiB
UBI: number of good PEBs: 3794
UBI: number of bad PEBs: 6
UBI: max. allowed volumes: 128
UBI: wear-leveling threshold: 4096
UBI: number of internal volumes: 1
UBI: number of user volumes: 0
UBI: available PEBs: 3753
UBI: total number of reserved PEBs: 41
UBI: number of PEBs reserved for bad PEB handling: 37
UBI: max/mean erase counter: 1/1
UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi:rootfs", error -19
Error reading superblock on volume 'ubi:rootfs'!
Loading file "/boot/uImage" from usb device 0:1 (usbda1)
1 bytes read
Found bootable drive on usb 0:1
Loading file "/boot/uImage" from usb device 0:1 (usbda1)
2828736 bytes read
Loading file "/boot/uInitrd" from usb device 0:1 (usbda1)
** File not found /boot/uInitrd
## Booting kernel from Legacy Image at 00800000 ...
Image Name: Linux-
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2828672 Bytes = 2.7 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
Loading Kernel Image ... OK

Starting kernel ...

After failing to "see" the device, eventually I cut the power and look at the logs in /var/logs on the usb key, and other files, and never find anything that suggests that it actually booted.

Interesting things I've noticed

Arch (installed with instructions from here: ... e-dockstar) boots regularly on the Dockstar, no problems, though the netconsole output is no different from the above as far as I can see. [So cool to have a "real" linux on it, as opposed to busybox. (Though who doesn't love busybox?)]

Interesting things I think don't matter:
* Both the Amahi rootfs and the Arch rootfs have weird, to me, fstab files. Specifically, I think the Arch has only a tmpfs mount point in the file (mount shows "normal" mount points once booted) and the Amahi rootfs fstab has root as a nfs mount (without an IP). I'm not used to seeing either of these things in my "normal" linux boxes.

* I tried to set some uboot parameters, using fw_setenv I think, but it didn't seem to make a difference, and all the instructions I've found don't seem to involve setting parameters for the Dockstar. (Except for those needed to get netconsole to work.)

* Ext2 vs. ext3 - I noticed the default install of Amahi on the Dockstar is to an ext3 partition. The Arch install that does boot is ext2. I'm pretty sure at a couple of points in my investigation I changed the install script on the Amahi to format as ext2, and I thought I confirmed that partition that resulted was ext2, but it still didn't boot.

* I think I've install Jeff's uboot as well as other's. I could be wrong about this one. I'm not even sure that there are different uboots for this. It could be that it was alway's Jeff's, and that I've been installing the uboot for Arch on the PP4 (which is what Arch recommends) and Jeff's uboot on the Dockstar (which is what everybody including Arch seems to recommend).

* Booting Arch on the PP4 - Unlike the Dockstar, the PP4 boots correctly ONCE on the PP4, but doesn't seem to reboot on the PP4 and instead boot fails.

* Trying to boot Fedora Arm - I can't get Fedora to boot on either. It does the same as Amahi, goes solid yellow. Which makes me think there's one simple thing that is wrong.

Anyway. Any ideas about how to parse out the issues one at a time? That has been the problem. There are too many variables, and so it's difficult to be methodical.

Thanks in advance.

Posts: 3
Joined: Wed Jul 18, 2012 5:11 pm

Re: Seagate DockStar?

Postby jmcbri » Fri Jul 20, 2012 4:06 am

cpg on IRC has suggested gently that maybe the initrd/ramdisk issue is something that I should look at more, so I'm going to do that and report the results.

Posts: 3
Joined: Wed Jul 18, 2012 5:11 pm

Re: Seagate DockStar?

Postby jmcbri » Fri Jul 20, 2012 6:35 pm

I looked, and there is no ramdisk image in the rootfs, so I don't know how I could fix that netconsole error above.

I wonder how others got this to work?

Been thinking about the raspberry pi, but frankly, other than the video, that is no more powerful a devie than the pp4 (in some ways, the pp4 has the edge: usb3 and potentially sata).

Oh well I don't know about next steps at this point.

Who is online

Users browsing this forum: No registered users and 0 guests