SOLVED: HDA assumed incorrect IP address

wizdum
Posts: 2
Joined: Sat May 12, 2012 8:33 pm

SOLVED: HDA assumed incorrect IP address

Postby wizdum » Sat May 12, 2012 8:39 pm

Hello,
My current network setup is a 10.*.*.* network. I have the gateway at 10.0.0.1, and I set up my Amahi server to assume the address of 10.0.0.20. When the install process finished, I attempted to access my HDA from another local computer, and was unable to. I used ifconfig to check the IP address so I could connect manually, and found that the Amahi server has assumed the IP address 192.168.1.20. What would cause this, and how do I change it? There are no network connections listed in the network config page.

User avatar
cpg
Administrator
Posts: 2600
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: HDA assumed incorrect IP address

Postby cpg » Sat May 12, 2012 9:31 pm

did you install in a different network?

what was the IP you set up in the control panel in amahi.org?
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

wizdum
Posts: 2
Joined: Sat May 12, 2012 8:33 pm

Re: HDA assumed incorrect IP address

Postby wizdum » Sat May 12, 2012 10:29 pm

did you install in a different network?

what was the IP you set up in the control panel in amahi.org?
When I originally installed Amahi, the server had access to the internet on a 192.168.1.* network. The IP address in the Amahi.org control panel is 10.0.0.20 (with a gateway of 10.0.0.1, for the network I planned to use it on). I decided to just reinstall Fedora and Amahi here (on the 10.*.*.* network). Everything is working fine now.

I would still like to know why this happened though. Its like it combined the 4th octect of the 10.0.0.20 IP address with the 192.168.1.* address it was using during the install. The 192.168.1.* network has a router handing out DHCP leases, so it would not have assigned the server an address below 192.168.1.100.

User avatar
cpg
Administrator
Posts: 2600
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: HDA assumed incorrect IP address

Postby cpg » Sat May 12, 2012 10:44 pm

yes, we started to add some experimental network autodetection, but your case breaks that.

it's veyr rare. we do not have an easy way to cope with this situation :(
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

mcholach
Posts: 1
Joined: Tue Apr 28, 2015 2:35 pm

Re: HDA assumed incorrect IP address

Postby mcholach » Tue May 05, 2015 11:55 am

I am having the same issue. I requested an IP address of 192.168.1.11, network is 192.168.1.x. The server pulled a DHCP address of 192.168.1.136 on boot-up and after several resets, with the DHCP services off on the router, it is still not using the assigned 192.168.1.11

User avatar
bigfoot65
Project Manager
Posts: 11299
Joined: Mon May 25, 2009 4:31 pm

Re: HDA assumed incorrect IP address

Postby bigfoot65 » Tue May 05, 2015 1:37 pm

It must be using the old DHCP lease from your router.

One way around this is to turn on your router's DHCP server, set a static IP by MAC Address for the HDA to the desired one. If you can scope how many DHCP leases it provides, set it to one.

That should force the correct IP address to match the HDA profile.
ßîgƒσστ65
Applications Manager

damers101
Posts: 1
Joined: Wed Oct 26, 2016 10:51 pm

Re: HDA assumed incorrect IP address

Postby damers101 » Wed Oct 26, 2016 10:54 pm

Yeah this is an issue, I noticed this installing 8 with fedora 21. You must use the network configuration you setup in your amahi.org while setting up box. For me I had to use a completely different lan setup.

User avatar
bigfoot65
Project Manager
Posts: 11299
Joined: Mon May 25, 2009 4:31 pm

Re: HDA assumed incorrect IP address

Postby bigfoot65 » Thu Oct 27, 2016 4:22 am

This thread is over a year old and likely resolved.

BTW, the static or fixed IP address to automatically assigned to the HDA during the install process.

Marking as closed.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests