CLOSED: Amahi 11 clean install, dashboard exception

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

CLOSED: Amahi 11 clean install, dashboard exception

Postby jkbuckethead » Thu Nov 22, 2018 12:52 am

Apparently my experiment with a new NIC was not my problem after all. I removed the NIC and went back to the motherboard NIC, which worked just fine for the past few versions of amahi. I used the netinstall method because I didn't want the default admin user that the express was giving me. (I'm sure I could have created a new user, but I wanted to make sure I matched my old setup so I'd have no credential issues with existing clients.)

After the install was complete, I rebooted and the terminal screen looks fine, but again I cannot load the dashboard in a browser. This is just installed with no apps installed or anything, just the minimal install.

With nothing but command line access I hardly even know how or where to start troubleshooting. Any ideas what could be wrong. Again, this is the same PC that was running amahi 10 just fine a couple days ago.

User avatar
bigfoot65
Project Manager
Posts: 11380
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 11 clean install, dashboard exception

Postby bigfoot65 » Thu Nov 22, 2018 5:29 am

Did you follow the install instructions precisely, making no deviations?

Also please provide URL for:

Code: Select all

apaste --sysinfo
Is it possible the install media is corrupt?

Start by looking at log files. Seems like something may not have installed properly.

Did you do OS updates? Might try:

Code: Select all

sudo dnf update
Might check out bug 2347 and bug 2315. Could be related.
ßîgƒσστ65
Applications Manager

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Re: Amahi 11 clean install, dashboard exception

Postby jkbuckethead » Thu Nov 22, 2018 11:58 am

Did you follow the install instructions precisely, making no deviations?
I have installed it 3 different ways; express, minimal and full. The only deviation I can think of is the partitioning. My system disk is 2TB since this is what I had on hand, so it is way bigger than necessary. I have always increased the system partitions a little, and even added a 4th partition for the left over space. I have never had a use for the extra partition, but it seemed easier to make it during setup. My disk was partitioned the same way for amahi 10 and never gave me problems. That said the one bug you gave me did hint at partition size being an issue. I will try again with default partitions, and see what happens.
Is it possible the install media is corrupt?
I have installed multiple times using 3 different installers. Its unlikely that all 3 would be corrupt. I did check the hash for the iso files, and they were all good.
Did you do OS updates?
I did now, and only ruby-related items upgraded. I rebooted after the update, and I am still getting the dashboard exception error.
Also please provide URL
https://paste.fedoraproject.org/paste/T ... fsotHCAamQ
Start by looking at log files.
Even if I knew what files to look at, I wouldn't know what I was looking at. If you'll suggest files with paths I know how to open them. Unfortunately I do not know how to copy them to a thumb drive for posting here. If they aren't too large I should be able to copy and paste the text.

mattman
Posts: 24
Joined: Thu Sep 09, 2010 2:46 pm

Re: Amahi 11 clean install, dashboard exception

Postby mattman » Thu Nov 22, 2018 4:05 pm

Hi
I have an issue with Amahi 11 and the dashboard not working this might not be related but anyway.
I upgraded from 10 to 11 and as far I can see everything else is working but just the Dashboard.
System info can be found here https://paste.fedoraproject.org/paste/a ... uWqO87e4qQ

I have also attached the platform-migration log.

I have updated every this and also clean up the gem installed files.

Any help would be great I'm holding of doing a clean install as this wipes out all the configuration that I have done.

Many Thanks
Matt
Attachments
amahi-platform-migration.log
(2.64 KiB) Downloaded 20 times

User avatar
bigfoot65
Project Manager
Posts: 11380
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 11 clean install, dashboard exception

Postby bigfoot65 » Thu Nov 22, 2018 4:49 pm

@mattman

Did you follow the upgrade guidance precisely? It doesn’t appear so based on info provided.

There is mention of uninstalling all apps and plugins. This is not optional.

Did you do as suggested. If not, that’s likely your issue.

Do you have desktop installed? We do not support anything but server.

Also next time would be best if you started a new thread. This was referencing a new install not upgrade.
ßîgƒσστ65
Applications Manager

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Re: Amahi 11 clean install, dashboard exception

Postby jkbuckethead » Fri Nov 23, 2018 12:27 am

I gave it another couple of tries without changing the partitioning scheme from automatic. Not surprisingly, there was no improvement. I still got the dashboard exception.

Then on a hunch, I decided to try another computer so I pulled out my laptop, and I connected no problem. Then I went back to my desktop, and tried a different browser, which also connected just fine. Finally, I went back to chrome (my usual browser) and cleared the cache, cookies, content settings, and hosted app data. After doing this, the dashboard loaded just fine. Not 100% sure what caused the problem, but it seems to be gone now.

This desktop PC, with chrome, is where I accessed amahi 99.9% of the time. Apparently there was a cookie or something that was not compatible with the new desktop. Since I never had issues using this browser to connect with amahi before, I certainly wasn't expecting problems with 11. Hopefully it will be smooth sailing the rest of the way.

User avatar
bigfoot65
Project Manager
Posts: 11380
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 11 clean install, dashboard exception

Postby bigfoot65 » Fri Nov 23, 2018 8:46 am

Interesting. The one suggestion I did not offer.

For some reason browser cache often solves issues.

I presume we can close this thread.
ßîgƒσστ65
Applications Manager

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Re: Amahi 11 clean install, dashboard exception

Postby jkbuckethead » Fri Nov 23, 2018 10:21 am

Yes, you can close it. As far as the basic installation goes I am good to go. I have another issue with the disk wizard, but that is a known big so I will start a new thread.

To sum up my install, it seems that the browser was the issue all along. I went back and changed to the Mellanox NIC, and my modified disk partitioning with no apparent install problems. I can't test the NIC speed until I get some storage up and running, but expect to see faster transfers to/from the HDA. The limiting factor now should be the speed of the HDDs themselves.

Who is online

Users browsing this forum: No registered users and 1 guest