SOLVED: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

madhatta
Posts: 28
Joined: Tue Oct 09, 2018 8:56 pm

SOLVED: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

Postby madhatta » Thu Oct 18, 2018 1:45 am

So I (like a few others, apparently) glossed over the part about removing web apps and plugins before doing the upgrade from Amahi 10 to 11. After getting the problem sorted of the httpd server not starting, thanks to another recent post, I got into the dashboard and started trying to remove apps from there. Most webapps have uninstalled successfully but some of them seem to be hanging. WebShell seems to be the main culprit, in that the uninstall fails and then seems to have a process running somewhere that is stuck and when I try to remove or add other apps, from the dashboard I am told (in the dashboard) that there is already an uninstall happening.

I was hoping to get some advice on which logs or services to look at to resolve this issue or simply how to manually remove the WebShell webapp. Can I remove the WebShell folder (and others that seem to be stuck) from the webapps directory or will that cause problems with calls the Amahi system might be making elsewhere or in databases that may be expecting that app to exist?

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

Postby bigfoot65 » Thu Oct 18, 2018 2:27 pm

Check out this post:

If you need additional help, just let us know.

If not, let us know if we can close this thread.
ßîgƒσστ65
Applications Manager

madhatta
Posts: 28
Joined: Tue Oct 09, 2018 8:56 pm

Re: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

Postby madhatta » Thu Oct 18, 2018 10:15 pm

Check out this post:

If you need additional help, just let us know.

If not, let us know if we can close this thread.
I read through that post and one other before making this one but I apparently don't have any plugins installed so the advice wasn't applicable. From inspecting one of the services I found a folder that contained some of the webapps configs elsewhere that I renamed and then it started.

Last night I had some success with log file inspection to see where it was hanging on the uninstall and got rid of a few more webapps. I may have stumbled across the solution but I will update on if I solved the problem, tonight when I get home.

Thanks

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

Postby bigfoot65 » Fri Oct 19, 2018 3:13 pm

Hope all goes well.

You now understand by apps need to be uninstalled prior to upgrade.

BTW apps that were LIVE in one Amahi version may not be in the next. Be cautious trying any app not LIVE as they often are broken.
ßîgƒσστ65
Applications Manager

madhatta
Posts: 28
Joined: Tue Oct 09, 2018 8:56 pm

Re: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

Postby madhatta » Sun Oct 21, 2018 10:25 pm

Hope all goes well.

You now understand by apps need to be uninstalled prior to upgrade.

BTW apps that were LIVE in one Amahi version may not be in the next. Be cautious trying any app not LIVE as they often are broken.
I definitely won't make that mistake again for the next upgrade.

I was worried that some of the apps not uninstalling weren't available for Fedora 27 and that was the reason. I did a tail on the install log though and although the interface was telling me other apps were being uninstalled, the log would show finished after some time. I am not sure if my dashboard is messed up though, as it still says another app is being installed every time I try to uninstall/install. Oh well, it finishes so ...

I guess this can be marked as solved.

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 11 upgrade - issues with uninstalling old web apps from dashboard

Postby bigfoot65 » Mon Oct 22, 2018 6:12 am

Sounds good.

I updated the install guidance to help prevent problems in the future.

Marking as resolved.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests