SOLVED: Post upgrade (11) assistance

tamorgen
Posts: 53
Joined: Wed Jul 17, 2013 1:48 pm

SOLVED: Post upgrade (11) assistance

Postby tamorgen » Fri Oct 12, 2018 5:08 am

Good morning,
This morning I upgraded my Amahi install to 11, Fedora 27. All the important things seem to be working fine (file shares, dns, dhcp), however, I'm getting a "We're sorry, but something went wrong" when trying to go to http://hda. This was an upgrade, and not a clean install. I use the server for other things that I did not want to have to reinstall (stuff that has webcerts). Any advice other than do a clean install? Truth is, I don't use the hda gui often, but I would like to get it fully functional.

Thanks.

User avatar
bigfoot65
Project Manager
Posts: 11604
Joined: Mon May 25, 2009 4:31 pm

Re: Post upgrade (11) assistance

Postby bigfoot65 » Fri Oct 12, 2018 7:11 am

I presume you did not uninstall apps as the instructions suggested.

If that is the case, you will need to do some manual work.

To do the manual piece, you will need to navigate to /var/hda/platform/html/plugins/. Inside that folder are directories named for the plugins affected (i.e. 1001-disks_info). Do:

Code: Select all

rm -rf /var/hda/platform/html/plugins/plugin_dir_name
Once you have removed those three, do a reboot and the dashboard should be working.
ßîgƒσστ65
Applications Manager

tamorgen
Posts: 53
Joined: Wed Jul 17, 2013 1:48 pm

Re: Post upgrade (11) assistance

Postby tamorgen » Fri Oct 12, 2018 7:20 am

Yup, that was it. I wasn't sure where the directory was for the plug-ins. Figured I might have missed something.

Thanks so much!

User avatar
bigfoot65
Project Manager
Posts: 11604
Joined: Mon May 25, 2009 4:31 pm

Re: Post upgrade (11) assistance

Postby bigfoot65 » Fri Oct 12, 2018 7:21 am

No problem.

Ensure you uninstall the plugin app from the dashboard as well.

Will mark as resolved.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests