Page 1 of 1

Added printer successfully, but unable to print

Posted: Tue Jan 17, 2017 10:17 pm
by Pratyay67
It's been a while I have my Amahi server up and running, and I have extended it's capabilities with no trouble until now.
Now when I want to make my hda a print server too, so I looked up the articles regarding setting up the hda as a printer server. I installed CUPS, with the help of this thread: viewtopic.php?t=5035 (otherwise I wasn't able to access the CUPS local)

Initially whenever I tried to add the printer from CUPS, it showed a forbidden error, whenever I tried to add a printer.
I looked up and found a solution in a link that actually worked ( I'm a linux noob after all, I pretty much look things up to make things work and when I get able to do that, I forget about that altogether).
Here's the link: ... dden-error

Summing things up, it required a little tweak in the cupsd.conf file, and running the following command:

sudo usermod -a -G sys username

After that, I was able to debug the add-printer --> forbidden error, and it actually let me add printers from then on. So I plugged in my HP Deskjet 2520, and went on with the steps that followed, and it seemed pretty straightforward. Now that I added the printer, when I tried to 'connect' it by right-clicking on the printer icon in my //hda, it does nothing ( a window pops up and closes so fast that I don't get a chance to read whats written ). When I try to print from my printer, it doesn't print, with a message "//hda/hp_deskjet_2520 is in an error state".

Any help regarding this? I think it might be due to the fact that I didn't install any drivers ( to my knowledge it didn't ask me anywhere to install the drivers, maybe it happened in the background ), or is it something else? Please help.

Re: Added printer successfully, but unable to print

Posted: Wed Jan 18, 2017 5:22 pm
by bigfoot65
You most likely need to install the printer driver on your client.