CLOSED: List of questions for upgrade from amahi 7 to 8

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby bigfoot65 » Tue Oct 27, 2015 5:00 pm

In the HDA dashboard, Shares tab there is a permissions reset button. Select Movies and then click that button. It should reset the permissions.

Once done, check again that things are correct. Might try ls -al so it reflects all possible files.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Maxpwr
Posts: 41
Joined: Tue Oct 23, 2012 7:50 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby Maxpwr » Wed Oct 28, 2015 8:15 pm

So I ran ls -al it states the following:
total 8
drwxrwxrwx 2 "username" users 4096
drwxr-xrwx 10 root root 4096

I also reset the permissions from the dashboard shares and I do not see the files in the folders when I try to explore it from my windows pc.

Since I used disk wizard to mount it it seems there is no option in disk wizard for me to make any changes to it. Is this normal?

Ok so while I was dealing with this issue 2 other things came up that I'm hoping to get some help on. I have 3 GB of ram but I set my swap size to 4 GB thus it seems to show my ram as only 2GB. The other issue is that I turned off the computer to make sure the ram was fully seated. I then turned the server back on and I couldn't get an ip for my windows PC. Only when I set a static ip on my windows PC and went into my router to turn on the DHCP server was I able to force a static IP to the MAC address of the server. Would this have anything to do with the fact that my motherboard has 2 ethernet ports built into or is this something else? How do i fix this to where the server just comes up and runs with the IP address it has and not need to force the ip through turning on DHCP in the router? Sorry for all the questions just trying to make my Amahi 8 install bullet proof but it seems like I'm floundering. Thanks for the help.

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby bigfoot65 » Thu Oct 29, 2015 6:47 am

Since I used disk wizard to mount it it seems there is no option in disk wizard for me to make any changes to it. Is this normal?
That is normal behavior. It's only designed to mount/format disks.
Would this have anything to do with the fact that my motherboard has 2 ethernet ports built into or is this something else?
Are both ports active? Amahi only supports one ethernet port, therefore only one can be enabled when installing the OS and Amahi. See the minimum hardware requirements in the wiki. This may be why things are not working correctly.

Not sure what the RAM issue could be.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Maxpwr
Posts: 41
Joined: Tue Oct 23, 2012 7:50 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby Maxpwr » Thu Oct 29, 2015 8:05 am

Do I need to reinstall the os with just one active ethernet port?
What about the fact I still cannot see the files on the had when I explore to the shared folders?

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby bigfoot65 » Thu Oct 29, 2015 8:50 am

I would recommend you do so.

This may be the reason for all your issues. This will ensure you have followed the installation procedure and should mitigate any further issues.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Maxpwr
Posts: 41
Joined: Tue Oct 23, 2012 7:50 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby Maxpwr » Sat Nov 07, 2015 7:59 pm

Ok so I have had a chance to do a fresh re-install and I'm about to lose my mind. Let me list my current problems by bullet points after explaining what I did. I disconnected by large hard drive that had all my files(pictures, movies, documents, etc.) then went into my BIOS and disabled one of the ethernet ports. Here are the list of problems I am currently facing and not sure what to do.
1. After doing a fresh install and adding back in my large storage drive that had all my previous files I cannot find them on the drive to adjust the the share location appropriately for each folder (books, docs, movies, images, etc.)
2. I have 3 GB of memory(which shows up in the BIOS and states only 2 GB is available) I set the Swap to 6 GB and I don't know why this is occurring. Didn't have this issue with Amahi 7.
3. Putty is now not working since I have went to Amahi 8, I get Network error, Software caused connection abort. I have also tried using JuiceSSH from my android phone which use to work. Now I'm getting a java.io.IOException: End of IO Stream Read error. So it seems to be with the server.

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby bigfoot65 » Sun Nov 08, 2015 7:47 am

1. After doing a fresh install and adding back in my large storage drive that had all my previous files I cannot find them on the drive to adjust the the share location appropriately for each folder (books, docs, movies, images, etc.)
Did you use Disk Wizard or follow the adding a second hard drive to your HDA? Also check /etc/fstab to see if the drive is included there as mounted.
2. I have 3 GB of memory(which shows up in the BIOS and states only 2 GB is available) I set the Swap to 6 GB and I don't know why this is occurring. Didn't have this issue with Amahi 7.
This could be a driver issue with the OS. The only way to resolve it is determine what is missing. Users who experience this sort of thing typically end up installing the Full DVD vs minimal.
3. Putty is now not working since I have went to Amahi 8, I get Network error, Software caused connection abort.
There could be many things causing this issue. Did the HDA get the right IP address? Are you using user name and password or Private/Public key method to log in? Was the install successful?
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Maxpwr
Posts: 41
Joined: Tue Oct 23, 2012 7:50 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby Maxpwr » Sun Nov 08, 2015 8:33 am

Did you use Disk Wizard or follow the adding a second hard drive to your HDA? Also check /etc/fstab to see if the drive is included there as mounted.
I used Disk Wizard but ended up checking fstab and saw the drive was in there and was able to go in and find the drive location and adjust share location for each folder. Now all my files are viewable from my windows machine.
This could be a driver issue with the OS. The only way to resolve it is determine what is missing. Users who experience this sort of thing typically end up installing the Full DVD vs minimal.
What is the best way to determine what is missing for this?
There could be many things causing this issue. Did the HDA get the right IP address? Are you using user name and password or Private/Public key method to log in? Was the install successful?
The HDA did get the right IP address. I tried with username and without hoping it would prompt for it. The install said successful.

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby bigfoot65 » Sun Nov 08, 2015 8:56 am

What is the best way to determine what is missing for this?
Not sure if there is a simple solution for this one. If there are drivers missing, only way to find them/install is to use the Fedora 21 Server Install which is the Full DVD. You might try searching the internet for a solution. This is a potential hardware/driver issue and bit beyond Amahi.
The HDA did get the right IP address. I tried with username and without hoping it would prompt for it. The install said successful.
If you followed the Fedora 21 Mininimal Install, there appears to be an issue with SSH caused by a Fedora 21 upstream update. We are looking into it now.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Maxpwr
Posts: 41
Joined: Tue Oct 23, 2012 7:50 pm

Re: List of questions for upgrade from amahi 7 to 8

Postby Maxpwr » Sun Nov 08, 2015 11:36 am

Not sure if there is a simple solution for this one. If there are drivers missing, only way to find them/install is to use the Fedora 21 Server Install which is the Full DVD. You might try searching the internet for a solution. This is a potential hardware/driver issue and bit beyond Amahi.
I will do some internet searching for this.
If you followed the Fedora 21 Mininimal Install, there appears to be an issue with SSH caused by a Fedora 21 upstream update. We are looking into it now.
Yes I followed the Fedora 21 minimal install since it is the recommended method. Can you let me know when you have resolved the issue and what I need to do to get SSH working on my server again? Thank you.

Who is online

Users browsing this forum: No registered users and 6 guests