[solved] Amahi doesn't properly work. Fedora 14

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

[solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 9:51 am

I'm testing Amahi for my home use. When setting up amahi through port 2000 it freezes at 69% Configuring your network (eth0).

tail /root/hda-install.log shows.

Code: Select all

error reading information on service yum-updatesd: Bad file descriptor yum-updatesd: unrecognized service error reading information on service ldap: Bad file descriptor ldap: unrecognized service iptables: Flushing firewall rules: [ OK ] iptables: Setting chains to policy ACCEPT: filter [ OK ] iptables: Unloading modules: [ OK ] Stopping NetworkManager daemon: [FAILED] Stopping unused services done. Stopping NetworkManager daemon: [FAILED]
I am currently running my Fedora 14 in runlevel 3 without a GUI.

Here's the exact method I installed Amahi and Fedora 14.
---------------------------------------------------------------------------------------------
Boot and install Fedora 14 with default settings configuring server name to amahiserver.

Restart the machine and create your user.

Disable GUI on start up
Just change in /etc/inittab the line
id:5:initdefault:
to
id:3:initdefault:
Here is more information : http://www.fedorafaq.org/basics/#runlevel

Reboot and do the rest through the terminal runlevel 3.

Remove Office/Productivity software...

Code: Select all

yum groupremove "Office/Productivity"
Check for updates.

Code: Select all

yum check-update
Update software.

Code: Select all

yum update
Install ssh server

Code: Select all

service sshd status service sshd start
If there is no sshd status then install openssh server.

Code: Select all

yum install openssh-server
Configure firewall to allow ssh.

Code: Select all

vi /etc/sysconfig/iptables
open ssh port, put it midway after the first open port setting
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT

Code: Select all

service iptables restart
Autostart sshd on startup.

Code: Select all

cd /etc/rc.d/rc3.d/ mv K25sshd S25sshd
Follow the instructions for installing amahi server self-install-existing.
Add the Amahi repository in the link above.

Code: Select all

yum clean all yum check-update yum install hda-suite amahi-netboot
You will need to open up port 2000 in the firewall to complete install

Code: Select all

vi /etc/sysconfig/iptables
-A INPUT -m state --state NEW -m tcp -p tcp --dport 2000 -j ACCEPT

View the ip address of the server.

Code: Select all

ifconfig
visit the amahi page and use install code
http://serverip:2000
---------------------------------------------------------------------------------

Note: Installing from the web is not recommended at this point; see posts further down in this thread on that issue. Also you should not be running the NetworkManager service; see posts further down in this thread on this issue also.

Up to this point everything works flawlessly. Now the last time I installed and encountered this problem I forced a restart on the machine which killed the amahi install at 69%. I opened port 80 in the firewall and the server worked. The only issue is that the service NetworkManager failed on start up. So I would have to restart it twice after bootup to get it working.
service NetworkManager restart
service NetworkManager restart

Everything else in Amahi appeared to work okay (I disabled dhcpd and dns service). So basically every time I restart the Amahi server from the web I have to manually log in to the machine and start the networking by restarting the NetworkManager service twice to get it to work. This defeats the purpose of setting up sshd and autostarting it.

This basically means I can't restart my Amahi server unless I have physical access to it. Any ideas to troubleshoot why Amahi broke the networking or won't get past 69%? I can restart the install process as many times as I like because it's in a Virtual Machine. I'd like to get all the bugs ironed out before I set this up as a main driver on my network.

I provided as much information as I possibly could so hopefully someone can help.
SAM
Last edited by sag47 on Mon Feb 14, 2011 3:41 pm, edited 8 times in total.

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: Amahi doesn't properly work.

Postby sag47 » Sun Feb 13, 2011 10:27 am

My goal is to run Amahi service with no running GUI on the server. I don't care if it's installed I just want as many resources as possible dedicated to Amahi. :geek:

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: Amahi doesn't properly work. [fixed]

Postby sag47 » Sun Feb 13, 2011 3:17 pm

Okay, well I figured out the solution. Apparently there's a bug in ruby with the web installer. When I tried starting the service I got the error "amahi-installer dead but subsys locked" which led me to this solution.

Amahi dev team is working on it. So for now do the following...

Code: Select all

#remove the config so that the install happens again rm /etc/sysconfig/amahi-hda #install from terminal and skip web install altogether hda-install YOURINSTALLCODE
Do not do the following in red, apparently the network manager should remain off because we want a static IP and not a dynamic IP. I'm still working on getting my HDA up and working.

It disables networking for some reason when the install completes so before you restart do the following...

Code: Select all

cd /etc/rc.d/rc3.d/ mv K84NetworkManager S84NetworkManager
Now everything should work as advertised. Continue configuring it how you want, with/without dns or dhcp, etc.[/color]

I asked in the irc channel for how to change the IP address of the HDA. sabat gave me the solution to that...

Code: Select all

hda-install -f [new install code]
Hopefully someone else finds this helpful.

SAM

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: [not-solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 5:08 pm

Okay. When I run /etc/init.d/networking restart I get the following error.

Code: Select all

Bringing up interface eth0: Device does not seem to be present, delaying initialization.
I found a solution to that here.
http://forums.amahi.org/viewtopic.php?f=9&t=2292

That didn't quite fix it but I feel I'm getting close.

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: [not-solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 5:28 pm

Okay I figured out why my interface was all screwed up. I needed to edit the following file and add to the top of it.
/etc/sysconfig/network-scripts/ifcfg-eth0

Code: Select all

DEVICE=eth0
That line was entirely missing which makes me think it's a bug in the hda-install process.

My dhcpd isn't working so now I have to figure that out. Almost there.

This resolves the following:
service network start

It used to fail but now doesn't.

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: [not-solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 5:57 pm

I've resolved my dhcpd issues. I ran the following command with output...
service dhcpd configtest

Code: Select all

Internet Systems Consortium DHCP Server 4.2.0-P2 Copyright 2004-2010 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ /etc/dhcp/dhcpd.conf line 20: semicolon expected. max-lease-time ^ /etc/dhcp/dhcpd.conf line 20: expecting a parameter or declaration max-lease-time ; ^ Configuration file errors encountered -- exiting This version of ISC DHCP is based on the release available on ftp.isc.org. Features have been added and other changes have been made to the base software release in order to make it work better with this distribution. Please report for this software via the Red Hat Bugzilla site: http://bugzilla.redhat.com exiting.
So I edited my dhcpd.conf with the following lines...

Code: Select all

default-lease-time 604800; max-lease-time 604800;
Now everything works and amahi.org recognizes my HDA. The only problem is that dhcpd.conf gets regenerated each time the computer is rebooted. So unfortunately I have to manually edit this each time. I'll post back when I figure out what generates it.

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: [not-solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 7:47 pm

Also after startup before I login stderr shows the following. I have to push ctrl+c to clear it before I can log in.

Code: Select all

PHP Warning: date_default_timezone_get(): It is not safe to rely on the system's timezone settings. Yu are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EST/-5.0/no DST' instead in /usr/bin/greyhole on line 39
Just thought I'd mention that since we're going through logs.

----------------------------update on this issue from IRC channel

Code: Select all

(10:48:11 PM) cpg: know issue (10:48:29 PM) cpg: it's actually a fedora 14 upstream issue in a redhat labs package called augeas (10:48:43 PM) cpg: we reported it and they fixed it, but it's not in the repos yet (10:48:46 PM) cpg: we found it first (10:48:52 PM) sag47: niice
There's also a fix for this issue.
Last edited by sag47 on Mon Feb 14, 2011 6:36 pm, edited 1 time in total.

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: [not-solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 9:54 pm

After working with cpg we've made some headway. The following database schema was missing. Only run this if you are missing the same settings. If you're a basic user then don't follow anything in this thread.

Code: Select all

-- -- Table structure for table `settings` -- CREATE TABLE IF NOT EXISTS `settings` ( `id` int(11) NOT NULL AUTO_INCREMENT, `name` varchar(255) DEFAULT NULL, `value` varchar(255) DEFAULT NULL, `kind` varchar(255) DEFAULT 'general', PRIMARY KEY (`id`) ) ENGINE=InnoDB DEFAULT CHARSET=latin1 AUTO_INCREMENT=43 ; -- -- Dumping data for table `settings` -- INSERT INTO `settings` (`id`, `name`, `value`, `kind`) VALUES (1, 'theme', '1', 'general'), (2, 'port_forward', '0', 'network'), (3, 'port_filter', '0', 'network'), (4, 'ip_filter', '0', 'network'), (5, 'mac_filter', '0', 'network'), (6, 'url_filter', '0', 'network'), (7, 'vpn', '0', 'network'), (8, 'dmz', '', 'network'), (9, 'firewall', '0', 'general'), (10, 'advanced', '0', 'general'), (11, 'debug', '0', 'shares'), (12, 'pdc', '0', 'shares'), (13, 'win98', '0', 'shares'), (14, 'workgroup', 'WORKGROUP', 'shares'), (15, 'router_model', NULL, 'network'), (16, 'router_username', NULL, 'network'), (17, 'router_password', NULL, 'network'), (18, 'dhcp_in_router', '0', 'network'), (19, 'dhcp_lease_time', '14400', 'network');
Found by searching with a regular expression through the diff ( ^[0-9]+a ).

Throw that into settings.sql and

Code: Select all

mysql -u root -phda hda_production < settings.sql
Last edited by sag47 on Wed Feb 16, 2011 8:48 am, edited 1 time in total.

sag47
Posts: 43
Joined: Sun Feb 13, 2011 9:27 am

Re: [not-solved] Amahi doesn't properly work. Fedora 14

Postby sag47 » Sun Feb 13, 2011 11:28 pm

The following bugs have been filed from this experience.

Bug #762
Bug #763

The Amahi source repository can be found at http://git.amahi.org/amahi.git
See also Contribute in the wiki.

User avatar
cpg
Administrator
Posts: 2601
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: [solved] Amahi doesn't properly work. Fedora 14

Postby cpg » Sun Feb 13, 2011 11:45 pm

Thanks for your patience sag47. Both bugs have been closed, one fixed (762) and one (763) unresolved, left as a mystery for future reference, in case it ever resurfaces, as these things always do in the long run.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

Who is online

Users browsing this forum: Google [Bot] and 1 guest