Help about installing Amahi Plug Edition on Dockstar

stanleyhosiuking
Posts: 5
Joined: Mon Feb 07, 2011 6:18 am

Help about installing Amahi Plug Edition on Dockstar

Postby stanleyhosiuking » Mon Feb 07, 2011 6:30 am

I have tried to install Amahi Plug Edition on my Segate Dockstar.

I have successfully modified the bootloader using "http://plugapps.com/os/pogoplug/uboot/i ... ot_mtd0.sh".

I have also successfully installed Debian 6.0 Squeeze on my 2GB thumb driver (sda). In Debian, I downloaded the root image "amahi-marvell-1.0.tar.bz2" and the script "create-amahi-f12-plug-disk.sh". I modified the script so that it would extract to my other 8GB thumb driver, which was nicely partitioned into sdb1 and sdb2.

Everything seems normal, but when I reboot, my 8GB thumb driver could not successfully be booted. Instead, the default Dockstar system from the flash memory was booted.

Could someone help me on this?

ppmt
Posts: 35
Joined: Fri Aug 20, 2010 6:29 pm

Re: Help about installing Amahi Plug Edition on Dockstar

Postby ppmt » Mon Feb 07, 2011 9:19 am

hello,

A first thing is if you have not done so already is to look at the wiki

http://wiki.amahi.org/index.php/Amahi_Plug_Edition

Then you need to instruct your Dock star to boot from the key rather than the flash. It means you need to have access to the uboot of the box

I am not sure how you do that unfortunately

stanleyhosiuking
Posts: 5
Joined: Mon Feb 07, 2011 6:18 am

Re: Help about installing Amahi Plug Edition on Dockstar

Postby stanleyhosiuking » Mon Feb 07, 2011 6:18 pm

Thank you for the reply. I have setuped according to the wiki.

Also, I have modify the uboot as metioned. The effect of this (according to its description) is that it would boot whatever thumb drive first, and only after this fails it would boot the flash in the Dockstar.

I have successfully booted my debian on my 2GB thumb drive (as oppose to the default flash). But when it comes to Amahi, presumebly it fails (and that's why my Dockstar falls back on boothing the flash I guess).

stanleyhosiuking
Posts: 5
Joined: Mon Feb 07, 2011 6:18 am

Re: Help about installing Amahi Plug Edition on Dockstar

Postby stanleyhosiuking » Tue Feb 08, 2011 1:23 am

This is the message after extracting

"umount: /dev/sdb1: not mounted
mke2fs 1.41.12 (17-May-2010)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
1081344 inodes, 4319948 blocks
215997 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=0
132 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000

Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 38 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
tar (child): bzip2: Cannot exec: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
umount: /dev/sdb2: not mounted
Setting up swapspace version 1, size = 2255228 KiB
no label, UUID=4537a019-e38d-411a-9831-ed84dc23c99b
You can unplug your usb disk now and boot from it!"

I guess problem occur at "tar (child): bzip2: Cannot exec: No such file or directory". But I have downloaded "amahi-marvell-1.0.tar.bz2" and put it at sba1 together with the script. Did I do it wrong?

stanleyhosiuking
Posts: 5
Joined: Mon Feb 07, 2011 6:18 am

Re: Help about installing Amahi Plug Edition on Dockstar

Postby stanleyhosiuking » Tue Feb 08, 2011 1:40 am

It turns out I havn't have bzip on my debian. Installed it and I am trying again. Sorry for making such silly mistake and bother everyone.

Who is online

Users browsing this forum: No registered users and 6 guests