Can not access the internet!

tertioptus
Posts: 4
Joined: Thu Oct 21, 2010 9:41 am

Can not access the internet!

Postby tertioptus » Thu Oct 21, 2010 9:50 am

I have a Verizon MI424WR router (FIOS).

I installed Amahi with no problem.

Then I disabled DHCP on my router. After rebooting my Windows PC, I can see it in the networking list, with it's leased IP from Amahi using http://hda.

But, I can not connect to the internet, from the server or any other PC in my network. This being after rebooting the PC as well.

Do I need to give my other machines static addresses? Should there be port forwarding established for the Amahi server?

User avatar
bigfoot65
Project Manager
Posts: 11456
Joined: Mon May 25, 2009 4:31 pm

Re: Can not access the internet!

Postby bigfoot65 » Thu Oct 21, 2010 10:13 am

Hello,

Set your DHCP back to your router. Then try the network troubleshooter at http://wiki.amahi.org/index.php/Network_troubleshooting. This will hopefully pinpoint your problem.
ßîgƒσστ65
Applications Manager

tertioptus
Posts: 4
Joined: Thu Oct 21, 2010 9:41 am

Re: Can not access the internet!

Postby tertioptus » Tue Oct 26, 2010 7:12 am

So I just went through the network troubleshooting. In the end it posted that my router is inaccessible to pastebin.


I notice that when I turn on the Amahi server, it takes over my network. The default gateway goes from 192.168.1.1 to 192.168.2.1. The internet on my windows pc is no longer available. Yet I can reach the HDA dashboard from windows xp. To get the internet again I have to shutdown the hda and do an "ipconfig /renew".


Also, I reinstalled fedora with the Amahi repositories again. The internet connection fine on the newly installed machine until I run the Amahi installer. Then I don't see my network icons anymore, and I can even get to Amahi web sites for help.

User avatar
bigfoot65
Project Manager
Posts: 11456
Joined: Mon May 25, 2009 4:31 pm

Re: Can not access the internet!

Postby bigfoot65 » Tue Oct 26, 2010 9:47 am

I notice that when I turn on the Amahi server, it takes over my network. The default gateway goes from 192.168.1.1 to 192.168.2.1. The internet on my windows pc is no longer available. Yet I can reach the HDA dashboard from windows xp. To get the internet again I have to shutdown the hda and do an "ipconfig /renew".
Yes, Amahi becomes the DHCP and DNS server. That is stated up front in the install instructions. If your gateway is wrong after install, that indicates that you did not enter it correctly in your profile on amahi.org. You may need to add a new HDA to your profile with the correct settings and reinstall Amahi.

There might be a way to adjust the settings manually, but I do not have the knowledge. Keep in mind the Amahi server is designed to be on 24/7 and server as your router basically. You can disable the DHCP and DNS server functionality in Amahi, but there are trade offs. Recommend you look at the FAQ on amahi.org for those.
ßîgƒσστ65
Applications Manager

tertioptus
Posts: 4
Joined: Thu Oct 21, 2010 9:41 am

Re: Can not access the internet!

Postby tertioptus » Tue Oct 26, 2010 8:36 pm

I GOT NOW! YEAH!!! THANKS, BIG FOOT!!!

When I first created my profile, several months ago, I had a different router. So I needed to change my internal IP addresses. Also, I did not remember the instruction to set the Amahi server to a fixed IP. I did this by assigning an IP to my server's mac address. Everything seems to be working fine now.

User avatar
cpg
Administrator
Posts: 2605
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Can not access the internet!

Postby cpg » Tue Oct 26, 2010 11:45 pm

i realize i am late to the party, however, for the benefit of others coming in here, there is one way to change the gateway IP (via the command line):

Code: Select all

hda-change-gw NEW_GATEWAY_IP
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

newtecreps
Posts: 2
Joined: Mon Mar 07, 2011 12:31 pm

Re: Can not access the internet!

Postby newtecreps » Mon Mar 07, 2011 12:56 pm

how do you turn off dhcp on this router? cant seem to find where to turn it off at?

User avatar
ciscoh
Posts: 158
Joined: Thu Mar 10, 2011 1:53 pm

Re: Can not access the internet!

Postby ciscoh » Thu Mar 10, 2011 2:20 pm

It seems the best solution is to change the router back to the subnet Amahi was on. Simply changing the gateway is not the best answer.

192.168.1.x 255.255.255.0 & 192.168.2.x 255.255.255.0 are completely different networks.

Unless there is a valid reason you have to stay on the ".2" network, i would change that.

Who is online

Users browsing this forum: No registered users and 1 guest