Amahi on esxi 4.0

faderus
Posts: 3
Joined: Sun Jul 25, 2010 8:16 pm

Amahi on esxi 4.0

Postby faderus » Sun Jul 25, 2010 8:30 pm

Hi all, thanks in advance for any help.

I am trying to add 2 data drives to my new Amahi installation, but have so far been unsuccessful. The drives were visible in Fedora, and I was able to format and mount it through fedora, but the hda-diskmount command didn't locate anything.

Any guidance would be appreciated.

User avatar
gboudreau
Posts: 606
Joined: Sat Jan 23, 2010 1:15 pm
Location: Montréal, Canada
Contact:

Re: Amahi on esxi 4.0

Postby gboudreau » Mon Jul 26, 2010 3:07 am

As root:

Code: Select all

wget "http://dl.dropbox.com/u/3022105/Amahi/hda-diskmount2" chmod +x hda-diskmount2 ./hda-diskmount2
This might work better, in that it should tell you why it can't mount the new drives, if you're in a common case.
- Guillaume Boudreau

faderus
Posts: 3
Joined: Sun Jul 25, 2010 8:16 pm

Re: Amahi on esxi 4.0

Postby faderus » Mon Jul 26, 2010 5:27 pm

No luck. Initially the drives were still mounted in Fedora and I gott this response:

Code: Select all

[root@localhost ~]# ./hda-diskmount2 **************************************************************** ./hda-diskmount2: line 222: pmount: command not found Ignoring /dev/sda1 - already mounted Ignoring /dev/sda1 - already in /etc/fstab as UUID=9813a4c3-58e2-4dff-a23f-1cfadce799dc **************************************************************** No usable Linux, Windows or Mac partitions found on your disks. If the drive you want to mount is already mounted as /media/Fedora 12 i386 DVD /media/Virtual 1 /media/Virtual 2 You'll need to unmount it from there first (right-click > Eject, from the Fedora desktop), then re-run this script.
I unmounted them and reran:

Code: Select all

[root@localhost ~]# ./hda-diskmount2 **************************************************************** ./hda-diskmount2: line 222: pmount: command not found Ignoring /dev/sda1 - already mounted Ignoring /dev/sda1 - already in /etc/fstab as UUID=9813a4c3-58e2-4dff-a23f-1cfadce799dc **************************************************************** No usable Linux, Windows or Mac partitions found on your disks. If the drive you want to mount is already mounted as /media/Fedora 12 i386 DVD You'll need to unmount it from there first (right-click > Eject, from the Fedora desktop), then re-run this script.
Thanks again for the help...

User avatar
moredruid
Expert
Posts: 791
Joined: Tue Jan 20, 2009 1:33 am
Location: Netherlands
Contact:

Re: Amahi on esxi 4.0

Postby moredruid » Mon Jul 26, 2010 11:29 pm

can you post the output of "fdisk -l"

I _think_ your disks should be /dev/sdb and /dev/sdc but we need to make sure
echo '16i[q]sa[ln0=aln100%Pln100/snlbx]sbA0D2173656C7572206968616D41snlbxq' | dc
Galileo - HP Proliant ML110 G6 quad core Xeon 2.4GHz, 4GB RAM, 2x750GB RAID1 + 2x1TB RAID1 HDD

whetu
Posts: 30
Joined: Tue Jul 13, 2010 3:32 am

Re: Amahi on esxi 4.0

Postby whetu » Wed Aug 04, 2010 10:19 pm

You've got this line:

Code: Select all

./hda-diskmount2: line 222: pmount: command not found
So try this:

Code: Select all

yum -y install pmount fuse fuse-libs ntfs-3g

Who is online

Users browsing this forum: No registered users and 5 guests