Install Amahi 5.4 from USB

veezavee
Posts: 1
Joined: Fri Jun 25, 2010 8:04 am

Install Amahi 5.4 from USB

Postby veezavee » Fri Jun 25, 2010 8:07 am

With the new Express CD iso, is it possible to install Amahi from a usb thumb drive instead of a CD? I'd like to install on to my headless server, but it doesn't have a CD/DVD drive installed. Thanks.

User avatar
bigfoot65
Project Manager
Posts: 9505
Joined: Mon May 25, 2009 4:31 pm

Re: Install Amahi 5.4 from USB

Postby bigfoot65 » Fri Jun 25, 2010 8:25 am

Hello,

Anything is possible, but I have to admit I don't know if any one has attempted it yet. Since we are such a small group of volunteers, our plates are quite full at the moment.

If I have time, I may give it a shot this weekend. If I am successful, I will post guidance in the Wiki.
ßîgƒσστ65
Applications Manager

Lincee
Posts: 73
Joined: Sat Jul 04, 2009 3:34 pm
Location: Arnhem, NL
Contact:

Re: Install Amahi 5.4 from USB

Postby Lincee » Sun Jun 27, 2010 4:42 am

at this point in time i did not get it to work..
it kjeeps asking for the install CD, where obviously it does not exist..
then it wants to load cdrom drivers from the install cd..
LANTEA: Amahi 7 (vm), HP Proliant Microserver, 8GB RAM, 2x 1TB HDD, 1GB eth

User avatar
chaosdesign
Posts: 33
Joined: Sat Mar 27, 2010 1:17 am
Location: Tauranga NZ
Contact:

Re: Install Amahi 5.4 from USB

Postby chaosdesign » Sun Jun 27, 2010 2:41 pm

Here is a solution that will work.

download the Fedora USB Creator available here.

Install and browse for existing live CD, select the Amahi iso.
Make sure you select the right USB Drive. Don't worry about persistent storage, Click on create live USB and wait till its finished.

Use a Flash drive Larger than the ISO the Amahi CD is about 400mb so using a 1gb or larger flash drive is ok.

There is a Windows and Linux version, see the link above for more info.

Let me know how you get on, i have only tried this with Fedora 12 Full install DVD, and the K12 Linux Live CD. Any issues or questions Let us know.
Image

originalsurfmex
Posts: 4
Joined: Mon Jun 28, 2010 9:41 pm

Re: Install Amahi 5.4 from USB

Postby originalsurfmex » Sat Jul 03, 2010 7:56 pm

i used liveusb creator and it tells me that it:

"cannot find kickstart file on CDROM"
whether i do regular or expert install

whetu
Posts: 30
Joined: Tue Jul 13, 2010 3:32 am

Re: Install Amahi 5.4 from USB

Postby whetu » Tue Jul 13, 2010 4:01 am

Hi there,
let me preface by saying that I'm a Linux sysadmin by day - specialising in Debian, but with some exposure to RH/Fedora. Suffice to say that had this been on a deb based system I'd have a 100% fix or workaround for you, but it's not, so I don't ;)

I used unetbootin on Ubuntu to prepare a usb drive, then I copied the iso to the root of the usb drive. This saves you a headache later on. Keywords:
Missing ISO 9660 Image The installer has tried to mount image #1, but cannot find it on the hard drive. Please copy this image to the drive and click Retry. Click Exit to abort the installation.


Boot up from the usb stick, regardless of which option you choose it'll fail to find the kickstart cfg, so click cancel and you'll get dumped into the graphical installer. Follow that through the steps, selecting hard drive as the installation source, choosing not to include the usb drive in any of the installation options such as partitioning, mbr etc, add the Amahi repo and so on.

You'll then reboot into this thread:
http://forums.amahi.org/viewtopic.php?f=9&t=1540

I've run the following:

Code: Select all

system-config-network


then configured the ip, subnet, gateway etc to suit, followed by

Code: Select all

service network restart
yum -y install ruby ruby-libs ruby-rdoc
gem install --no-ri --no-rdoc --version 0.9.4 sinatra


to ensure that all requirements are installed. Then finally:

Code: Select all

service amahi-installer restart


This is where I'm at so far. If worse comes to worst, I think this may necessitate the installation of Gnome and doing a desktop based install...

zabzoo
Posts: 1
Joined: Tue Jul 13, 2010 7:19 am

Re: Install Amahi 5.4 from USB

Postby zabzoo » Tue Jul 13, 2010 7:26 am

For install properly from usb stick you must modify syslinux.cfg in /syslinux/ dir as : append initrd=initrd.img ks=hd:sdb1:/advanced.cfg quiet . Kernel option ks=cdrom:/advanced.cfg quiet is not correct for usb stick. It is work fine. :)

whetu
Posts: 30
Joined: Tue Jul 13, 2010 3:32 am

Re: Install Amahi 5.4 from USB

Postby whetu » Tue Jul 13, 2010 11:48 pm

hey thanks for that! I had to use hd:sda1 as that's what my usb stick shows up during the install process, and syslinux.cfg is in the usb stick root when using unetbootin.

Advanced install is advised, as the "destoy everything and install headless" option will bootload onto the usb stick.

Stand by for results of my next install test...

whetu
Posts: 30
Joined: Tue Jul 13, 2010 3:32 am

Re: Install Amahi 5.4 from USB

Postby whetu » Wed Jul 14, 2010 2:20 am

ok, it's alive!

Unetbootin based instructions that worked for me:

Setup a usb stick as you normally would using unetbootin (google for instructions, I won't reinvent the wheel here)

When unetbootin has completed, exit out of it - do not select the reboot option - then copy the iso to the root of the usb stick

In the root of the usbstick will be a file named "syslinux.cfg", edit it to read as follows:

Code: Select all

default vesamenu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /isolinux/vmlinuz
append initrd=/isolinux/initrd.img ks=hd:sda1:/advanced.cfg quiet

label ubnentry0
menu label ^Expert install for Amahi headless - Graphic installer
kernel /isolinux/vmlinuz
append initrd=/isolinux/initrd.img ks=hd:sda1:/advanced.cfg quiet


where hd:sda1 represents the likely chance that when installing from usb, your usb stick will be assigned the device name sda1. If this fails, try sdb1. The rest of these instructions assume that the usb stick is sda1 and the drive you're installing to is sdb1.

Boot up your target PC from the usb stick and either choose Expert install or let it time out - you'll get to the same place either way.

Eventually the installer will complain that it can't find the Install Disc, press [tab] until [Back] is highlighted and press [enter]

You'll be asked what type of Installation Method you're using, navigate to Hard Drive press [enter]

You'll be asked to point out the partition where the installation files are, select /dev/sda1 and press [enter]

The graphical interface will fire up, follow it through, when you get to the partition editor, deselect /dev/sda1 and ensure that sdb1 is set to be booted from. Advanced users can configure their own partitions etc here, I recommend to keep it simple you choose the option to use the entire drive.

Then follow the installer through to the end.

At the end, you'll reboot, remove your usb stick and you should boot up to a command line login prompt. Login as root with the password you defined during setup.

issue an ifconfig and check to see whether you have an IP address or not. If you don't, issue a system-config-network and give your hda an ip address, gateway, dns etc and save and quit. Then issue a service network restart.

Finally, issue a hda-new-install [your setup code here], ignore the errors, let it run through and reboot when prompted.

et voila. You should now have an amahi box. Enjoy.

(note: if you cannot login, try useradd admin && passwd admin to add a user to the fedora base system)

Now, granted, I have been a bit brief in the above instructions - some level of computer nous is assumed. If you get stuck, just ask.

AUhoss
Posts: 1
Joined: Tue Feb 22, 2011 5:57 pm

Re: Install Amahi 5.4 from USB

Postby AUhoss » Tue Feb 22, 2011 6:11 pm

I have followed all the steps outlined here and in other forms but when it comes time to select a harddrive I unchecked sdb under "Select the drive(s) to use for this installation" because that is where my USB drive is and leave sda checked

Under "What drive would you like to boot this installation from" I selected sda (my harddrive) and tried the installation and then when that brought me to "Missing ISO 9660 Image" window i restarted the whole process and then selected sdb (my USB drive)

I am STILL unable to get passed the "Missing ISO 9660 Image" screen.. The only way I have been able to install Fedora 12 is livebooting from the USB and then doing the install but then that doesn't allow me to load the repo for Amahi.. So the whole thing ends up being a waste.. I even tried loading Amahi after install like it said on the website but again no luck

Is there any winning? I have been working on trying to get Amahi installed for over 3 weeks and after COUNTLESS forums I've read.. Still nothing.. I'm new to linux but fairly proficient when dealing with Windows/Mac and troubleshooting

Please help

Who is online

Users browsing this forum: No registered users and 1 guest