SOLVED: HDA Dashboard not accessable after upgrade to Amahi 11

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

SOLVED: HDA Dashboard not accessable after upgrade to Amahi 11

Postby jehali » Wed Oct 10, 2018 8:28 am

I upgraded from Amahi 10 to 11. After that is my dashboard is no longer accessable and comes up with:
"We're sorry, but something went wrong."
My HDA has address: 192.168.0.10
I followed the network troubleshooting wizard.
systemctl status hda-ctl.service gives this :

● hda-ctl.service - Amahi HDA controller
Loaded: loaded (/usr/lib/systemd/system/hda-ctl.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2018-10-09 23:19:29 CEST; 18h ago
Process: 11683 ExecStart=/usr/bin/hda-ctl $HDA_CTL_OPTIONS (code=exited, status=0/SUCCESS)
Main PID: 11690 (hda-ctl - sleep)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/hda-ctl.service
├─11690 hda-ctl - sleeping for 195 seconds
├─11691 /usr/bin/perl -w /usr/bin/hda-ctl
└─11750 dhclient

okt 10 00:19:56 localhost NET[15484]: /usr/sbin/dhclient-script : updated /etc/resolv.conf
okt 10 00:19:56 localhost dhclient[11750]: bound to 192.168.0.100 -- renewal in 34781 seconds.
okt 10 08:42:06 localhost hda-ctl[26078]: amahi.org action 'update' failed with 'HTTP::Response=HASH(0x556c87f8d5c8)->status_line'
okt 10 09:59:37 localhost dhclient[11750]: DHCPREQUEST on enp0s7 to 192.168.0.1 port 67 (xid=0x3fb58a02)
okt 10 09:59:38 localhost dhclient[11750]: DHCPACK from 192.168.0.1 (xid=0x3fb58a02)
okt 10 09:59:41 localhost dhclient[11750]: bound to 192.168.0.100 -- renewal in 40280 seconds.
okt 10 16:55:20 localhost hda-ctl[4292]: caught SIGHUP: executing programmed action.
okt 10 16:55:20 localhost hda-ctl[4295]: dnsmasq_dhcp is disabled
okt 10 16:55:20 localhost hda-ctl[4299]: dnsmasq_dns is enabled
okt 10 16:55:22 localhost hda-ctl[4308]: services restarted

systemctl status dnsmasq.service gives this:

● dnsmasq.service - DNS caching server.
Loaded: loaded (/usr/lib/systemd/system/dnsmasq.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2018-10-10 16:55:22 CEST; 28min ago
Main PID: 4306 (dnsmasq)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/dnsmasq.service
└─4306 /usr/sbin/dnsmasq -k

okt 10 17:16:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:17:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:18:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:19:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:20:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:21:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:22:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05
okt 10 17:23:23 localhost dnsmasq-dhcp[4306]: DHCPREQUEST(enp0s7) 192.168.0.188 00:60:34:16:52:f7
okt 10 17:23:23 localhost dnsmasq-dhcp[4306]: DHCPACK(enp0s7) 192.168.0.188 00:60:34:16:52:f7
okt 10 17:23:43 localhost dnsmasq-dhcp[4306]: RTR-SOLICIT(enp0s7) 0e:96:d7:f4:e1:05

systemctl status httpd.service:

● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/httpd.service.d
└─php-fpm.conf
Active: active (running) since Tue 2018-10-09 23:40:54 CEST; 17h ago
Docs: man:httpd.service(8)
Main PID: 12275 (httpd)
Status: "Total requests: 14; Idle/Busy workers 100/0;Requests/sec: 0.000219; Bytes served/sec: 0 B/sec"
Tasks: 300 (limit: 4915)
CGroup: /system.slice/httpd.service
├─12275 /usr/sbin/httpd -DFOREGROUND
├─12303 /usr/sbin/httpd -DFOREGROUND
├─12304 Passenger watchdog
├─12307 Passenger core
├─12317 Passenger ust-router
├─12334 /usr/sbin/httpd -DFOREGROUND
├─12335 /usr/sbin/httpd -DFOREGROUND
├─12336 /usr/sbin/httpd -DFOREGROUND
└─12646 /usr/sbin/httpd -DFOREGROUND

okt 09 23:40:53 localhost systemd[1]: Starting The Apache HTTP Server...
okt 09 23:40:54 localhost httpd[12275]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. S
okt 09 23:40:54 localhost httpd[12275]: Server configured, listening on: port 80
okt 09 23:40:54 localhost systemd[1]: Started The Apache HTTP Server.

What to do now?

User avatar
bigfoot65
Project Manager
Posts: 11235
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Dashboard not accessable after upgrade to Amahi 11

Postby bigfoot65 » Wed Oct 10, 2018 9:59 am

What to do now?
Did you uninstall all apps and plugins before upgrade?

This is a must, especially removing plugins or the upgrade will break the HDA.

It is fixable, but I need to know what apps and plugins you had installed.
ßîgƒσστ65
Applications Manager

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

Re: HDA Dashboard not accessable after upgrade to Amahi 11

Postby jehali » Wed Oct 10, 2018 10:04 am

I did not uninstall the following apps:
OpenVPN, NFS server, HDA Troubleshooting Tools, Amahi Anywhere, Network Time, Disk Wizard , Disk Stats, Web Apps, WEbmin, RPM Fusion (Non-Free) and RPM Fusion (Free).
Is it possible to uninstall them on the command-line?

User avatar
bigfoot65
Project Manager
Posts: 11235
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Dashboard not accessable after upgrade to Amahi 11

Postby bigfoot65 » Wed Oct 10, 2018 12:03 pm

Is it possible to uninstall them on the command-line?
There is a way to get the dashboard working so you can do the proper uninstall of the affected apps.

You will need to remove Disk Wizard , Disk Stats, and Web Apps plugin manually. Once the dashboard is restored, you will need to uninstall them from the Installed apps tab. You can then reinstall them and all should be fine.

To do the manual piece, you will need to navigate to /var/hda/platform/html/plugins/. Inside that folder are directories named for the plugins affected (i.e. 1001-disks_info). Do:

Code: Select all

rm -rf /var/hda/platform/html/plugins/plugin_dir_name
Once you have removed those three, do a reboot and the dashboard should be working.
ßîgƒσστ65
Applications Manager

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

Re: HDA Dashboard not accessable after upgrade to Amahi 11

Postby jehali » Wed Oct 10, 2018 12:16 pm

It's amazing but I can login now at my dashboard.!
Thank you very much for the assist.

User avatar
bigfoot65
Project Manager
Posts: 11235
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Dashboard not accessable after upgrade to Amahi 11

Postby bigfoot65 » Wed Oct 10, 2018 2:24 pm

That’s why we suggest uninstalling apps before upgrade.

Happy all is good now.

Will mark resolved.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 5 guests