SOLVED: Turning DHCP OFF in router cuts all network connectivity in HDA

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby bigfoot65 » Wed Mar 04, 2015 7:26 pm

The IP address of your HDA is the issue.

DHCP is handed out by the HDA starting at 100. You need to make the HDA static IP < 100.
ßîgƒσστ65
Applications Manager

mnz
Posts: 21
Joined: Thu Jul 04, 2013 9:56 am

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby mnz » Wed Mar 04, 2015 7:46 pm

ok. Thanks Bigfoot.

- So does that mean that in the router's DHCP settings I hould set "Start IP Address" and "End IP Address" at 192.168.2.10 or something like that ?

- I've pasted the results of the interactive troubleshooter in Ubuntu paste bin. Should I put the link here?

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby bigfoot65 » Wed Mar 04, 2015 7:50 pm

You can put the link here. Changing the HDA IP address may correct that issue.

As for the IP address of your HDA, it really should match what you set on amahi.org control panel. If that is 100 or greater, than make it 99 or less in your router.
ßîgƒσστ65
Applications Manager

mnz
Posts: 21
Joined: Thu Jul 04, 2013 9:56 am

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby mnz » Wed Mar 04, 2015 7:53 pm

Thanks

Before making any changes -- since I now internet access, at least! -- I will wait for your take on the command's results.

http://pastebin.ubuntu.com/10534018/

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby bigfoot65 » Wed Mar 04, 2015 7:59 pm

Nothing in the results was helpful.

Recommend you change the IP address on the HDA as discussed. Reboot it, then refresh DHCP lease on each client device. See if that fixes your issue.
ßîgƒσστ65
Applications Manager

mnz
Posts: 21
Joined: Thu Jul 04, 2013 9:56 am

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby mnz » Wed Mar 04, 2015 9:13 pm

Thank you so much, Bigfoot65. My HDA is back on track. Everything works as expected.

Just for the record :

1- I set up my router's DHCP settings "Start IP Address" and "End IP Address" both to the same address, matching the HDA "original" IP recorded in the control panel.
2- rebooted router & then turned the router OFF (to be sure)
4- turned OFF the server/HDA & all clients (Wi-Fi + wired)
5- then turned the router back ON (waited a bit to make sure everything was correctly initialized)
6- turned the server/HDA ON
7- in the HDA, entered the

Code: Select all

nslookup hda
command in a terminal to make sure that local hostnames were resolving properly (and it worked!)
8- then turned clients back ON one by one (verifying that each had LAN and internet connection)

... & now the mobile Amahi app works as expected (love it), and my good old server is my friend again.

Again : thanks Bigfoot65 and Carlos for your patience, generosity and intelligence. I know the Fedora version is the new great thing, but... I like my old Ubuntu : it works well and does what it's supposed to do. Maybe in a year or so... ;)

What I Iike with Amahi is of course the fact that it plays well with other OS & file systems. But the people behind it really make it shine.

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby bigfoot65 » Thu Mar 05, 2015 7:42 am

Great news and happy to help.

Appreciate the feedback on support.
ßîgƒσστ65
Applications Manager

mnz
Posts: 21
Joined: Thu Jul 04, 2013 9:56 am

Re: Turning DHCP OFF in router cuts all network connectivity in HDA

Postby mnz » Thu Mar 05, 2015 1:03 pm

Appreciate the feedback on support.
My pleasure. Feel free to use it.

Who is online

Users browsing this forum: No registered users and 1 guest