strange DNS issues that carried over after Amahi uninstall and Live Linux boot

Posts: 1
Joined: Wed Mar 09, 2022 11:59 am

strange DNS issues that carried over after Amahi uninstall and Live Linux boot

Postby Menfin » Wed Mar 09, 2022 2:04 pm

I installed Amahi and got things working fine, got an email telling me that my free Amahi Dynamic DNS is active after a fair bit of work.

I was working on configuring Nextcloud and noticed the warning message about being deprecated, however when I tried to update Nextcloud 14 to a newer version it only worked until I got stuck at 17.0.1 or something, there was no more button to upgrade to 18.1, which it was telling me was the next in the update path. There were problems and error or missing components that needed to be addressed before I could update to the next one, I managed to fix some but there were too many issues for me to resolve to get past that point so I decided to try another OS on the same machine.
I deleted all partition and installed Rocky Linux from USB stick, all went well but I haven't been able to connect to the Internet via LAN, could ping via IP but not name, this points to DNS issue, DHCP from router works fine got IP no problem.

I tried with various Live distros on this machine all the same results, I can ping via LAN card by IP but not name. The same network port and cable work fine with other machines, booted from Live distro or from existing systems, all the while I can do everything via WLAN once I disable the LAN on the former Amahi machine, that one was never enabled on my Amahi install. The issue for DNS resolution seems to be tied to the LAN MAC address of the one machine I installed Amahi on, I have never heard or seen something like this before, I'm quite puzzled.

Is there a way to remove the Amahi Dynamic DNS link to this PC's MAC address? Is that even the problem? I find it hard to understand how it would affect a brand new OS running on the hardware.
I'm at a loss to understand what's happening here, I reset my router and reconfigured it, thinking it might be the problem, still no difference, at least all my other machines are working fine, glad I tested this on an old laptop rather than my intended server box.

Any detectives out there that would like to try to figure this out?

Thanks for the help.


Who is online

Users browsing this forum: No registered users and 16 guests