Unable to access specific sites

chayes874
Posts: 21
Joined: Tue Jan 03, 2017 9:14 pm

Unable to access specific sites

Postby chayes874 » Mon Jan 13, 2020 7:37 pm

I'm trying to access the help page for Coursera here - https://learner.coursera.help/

With my Amahi server up and running as my DHCP server, I can't access this page. I keep getting a refused connection. However, I if re-enable DHCP on my router and power off my Amahi server, I can access this page with no problems.

I've now removed WiFi capability so everything is running on wires here to simplify the network. Before doing this, I noticed that if I used my iPhone's cell service (no WiFi), I could reach the aforementioned site without problems which made me start debugging my network.

I've also tried using the other DNS Providers listed in the Network->Settings tab. No change.

User avatar
bigfoot65
Project Manager
Posts: 11494
Joined: Mon May 25, 2009 4:31 pm

Re: Unable to access specific sites

Postby bigfoot65 » Mon Jan 13, 2020 7:43 pm

When using the HDA for DHCP, you have to renew the DHCP lease on all clients.

Did you do that step?

The reason switching back to your router works is the client probably still was using the router DHCP lease. Same for all other devices.

You likely did not follow the guidance on the transition to Amahi page.
ßîgƒσστ65
Applications Manager

chayes874
Posts: 21
Joined: Tue Jan 03, 2017 9:14 pm

Re: Unable to access specific sites

Postby chayes874 » Mon Jan 13, 2020 8:06 pm

You can do this by turning off the network and turn it back on after a few seconds on your clients (or unplugging it or turning off WiFi for a few seconds, then), so they get a DHCP lease from your HDA, which includes DNS.
I powered cycled everything (router, server, PC). For that particular Coursera site, the router DHCP works and the Amahi DHCP server does not. I haven't seen any other problems except for that specific site which is pretty odd.

chayes874
Posts: 21
Joined: Tue Jan 03, 2017 9:14 pm

Re: Unable to access specific sites

Postby chayes874 » Mon Jan 13, 2020 8:15 pm

There might be a hint from the Tor Browser for this specific site. Here's the message I get from Tor when attempting to access this site:


Error 1001 Ray ID: 554c6d77b8078cdf • 2020-01-14 03:12:19 UTC
DNS resolution error
What happened?

You've requested a page on a website (learner.coursera.help) that is on the Cloudflare network. Cloudflare is currently unable to resolve your requested domain (learner.coursera.help). There are two potential causes of this:

Most likely: if the owner just signed up for Cloudflare it can take a few minutes for the website's information to be distributed to our global network.
Less likely: something is wrong with this site's configuration. Usually this happens when accounts have been signed up with a partner organization (e.g., a hosting provider) and the provider's DNS fails.

Cloudflare Ray ID: 554c6d77b8078cdf • Your IP: 2405:8100:8000:5ca1::4b8:38c • Performance & security by Cloudflare

chayes874
Posts: 21
Joined: Tue Jan 03, 2017 9:14 pm

Re: Unable to access specific sites

Postby chayes874 » Mon Jan 13, 2020 8:21 pm

Again, the above only happens when I'm using Amahi as my DHCP server. I powered down the Amahi server, enabled DHCP on the router and then rebooted my desktop. I can now access https://learner.coursera.help without issues in any browser.

chayes874
Posts: 21
Joined: Tue Jan 03, 2017 9:14 pm

Re: Unable to access specific sites

Postby chayes874 » Mon Jan 13, 2020 8:44 pm

System 4.13.9-300.fc27.x86_64 ,x86_64
Platform 11.0.1-1
Core 11.0.0-1

DHCP Server [it's checked]
Lease Time 14400
DNS Provider OpenDNS

Gateway 192.168.0.1 [that's correct for my router]

User avatar
bigfoot65
Project Manager
Posts: 11494
Joined: Mon May 25, 2009 4:31 pm

Re: Unable to access specific sites

Postby bigfoot65 » Wed Jan 15, 2020 6:21 pm

What browser have you tested?

When using HDA as DHCP, what are you using for DNS?
ßîgƒσστ65
Applications Manager

chayes874
Posts: 21
Joined: Tue Jan 03, 2017 9:14 pm

Re: Unable to access specific sites

Postby chayes874 » Wed Jan 15, 2020 8:23 pm

Browsers tested are Chrome, Brave, Tor, Edge on desktop. Safari and Firefox on iPhone.

I've tried various settings for DNS Provider in the Network->Settings tab, but currently it's OpenDNS.

User avatar
bigfoot65
Project Manager
Posts: 11494
Joined: Mon May 25, 2009 4:31 pm

Re: Unable to access specific sites

Postby bigfoot65 » Sun Jan 19, 2020 10:16 am

Really odd that some sites don't work with the HDA.

Not sure what to suggest next. This is one of those odd issues that we don't see often.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 5 guests