Amahi 7 alpha 2 release

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Amahi 7 alpha 2 release

Postby northridgegrp » Tue Apr 09, 2013 5:55 pm

If we did a yum remove hda-platform would that work or would it be a dirty remove?

User avatar
cpg
Administrator
Posts: 2596
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi 7 alpha 2 release

Postby cpg » Tue Apr 09, 2013 6:03 pm

it may only let you if you also remove hda-ctl, probably.

or if you force. would prefer if you try to upgrade and report if upgrades work.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

User avatar
cpg
Administrator
Posts: 2596
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi 7 alpha 2 release

Postby cpg » Tue Apr 09, 2013 6:09 pm

Just a note -- this update does _not_ include new Rasp-pi packages. Only 32 and 64 bit packages. We could not access the development rasp-pi on time to make this test release.

What's new:

- new disks area
- app installs is known to be broken
- new plugin system

would like to test updates, user creation, share creation, settings, changing locales, advanced settings, fixing share permissions, etc.

things in shares are known to be broken with advanced settings on, i think.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Amahi 7 alpha 2 release

Postby northridgegrp » Tue Apr 09, 2013 7:19 pm

Just a note -- this update does _not_ include new Rasp-pi packages. Only 32 and 64 bit packages. We could not access the development rasp-pi on time to make this test release.

What's new:

- new disks area
- app installs is known to be broken
- new plugin system

would like to test updates, user creation, share creation, settings, changing locales, advanced settings, fixing share permissions, etc.

things in shares are known to be broken with advanced settings on, i think.
I tried an update and not sure if it took properly:

1. yum update seemed to work, system booted up fine after.
2. user creation worked, saw new /home/<new user>.
3. Share creation worked (share on hard disk), shared deletion worked but hda screen kept showing that it was still doing something (spinning wheel). did a page refresh share entry gone. share gone from hard disk.
4. settings, still got an Amahi Application Error screen, what this supposed to be different?
5. changing locales, was it supposed to appear somewhere?
6. advanced settings, did not see any indications of this.
7. fixing share permissions
- clear permissions shows a happy face, what does this mean?
- initial permissions were 775, when uncheck of writeable permissions changed to 777.
i am unclear what to expect in this case.

I think I am going to do a complete fresh install and see if behaviour is different.

User avatar
cpg
Administrator
Posts: 2596
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi 7 alpha 2 release

Postby cpg » Wed Apr 10, 2013 2:43 am

about 4 - thanks -- this error is a failure to initialize the "advanced" setting. Yeah, without that, no advanced settings will be visible. Will fix.

next time, for an error in the app, it would be best and save a lot of time to post the last few (hundred or two hundred lines) of

Code: Select all

/var/hda/platform/html/log/production.log
e.g.

Code: Select all

tail -200 /var/hda/platform/html/log/production.log | fpaste
about 3 - spinning after save, this is a bug in the UI and we will fix it as we redo the ui controls.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Amahi 7 alpha 2 release (F18 Install Instructions questi

Postby northridgegrp » Wed Apr 10, 2013 11:24 am

The wiki instructions indicate "taking a snapshot" after the installation of packages. What tool is being used to do this?

User avatar
cpg
Administrator
Posts: 2596
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi 7 alpha 2 release

Postby cpg » Wed Apr 10, 2013 11:33 am

most virtualization solutions will allow to take snapshots, like virtualbox, vmware, proxmox, or many of the other hypervisors out there.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Amahi 7 alpha 2 release

Postby northridgegrp » Wed Apr 10, 2013 11:37 am

most virtualization solutions will allow to take snapshots, like virtualbox, vmware, proxmox, or many of the other hypervisors out there.
ok now i understand, now that makes sense.

User avatar
bigfoot65
Project Manager
Posts: 11096
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi 7 alpha 2 release

Postby bigfoot65 » Wed Apr 10, 2013 1:55 pm

I updated the wiki to reflect that the Pro tip is in reference to running Amahi virtualized :)
ßîgƒσστ65
Applications Manager

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Amahi 7 alpha 2 release

Postby northridgegrp » Thu Apr 11, 2013 6:06 pm

Just a note -- this update does _not_ include new Rasp-pi packages. Only 32 and 64 bit packages. We could not access the development rasp-pi on time to make this test release.

What's new:

- new disks area
- app installs is known to be broken
- new plugin system

would like to test updates, user creation, share creation, settings, changing locales, advanced settings, fixing share permissions, etc.

things in shares are known to be broken with advanced settings on, i think.
I tried an update and not sure if it took properly:

1. yum update seemed to work, system booted up fine after.
2. user creation worked, saw new /home/<new user>.
3. Share creation worked (share on hard disk), shared deletion worked but hda screen kept showing that it was still doing something (spinning wheel). did a page refresh share entry gone. share gone from hard disk.
4. settings, still got an Amahi Application Error screen, what this supposed to be different?
5. changing locales, was it supposed to appear somewhere?
6. advanced settings, did not see any indications of this.
7. fixing share permissions
- clear permissions shows a happy face, what does this mean?
- initial permissions were 775, when uncheck of writeable permissions changed to 777.
i am unclear what to expect in this case.

I think I am going to do a complete fresh install and see if behaviour is different.
I did a complete install from scratch and my test results were the same.

The requested last 200 lines of the log are at:

http://paste.fedoraproject.org/7289/13657288

Who is online

Users browsing this forum: No registered users and 3 guests