Amahi Sync Appears to Have Stopped

jammastercd
Posts: 18
Joined: Mon Jan 03, 2011 11:57 am

Amahi Sync Appears to Have Stopped

Postby jammastercd » Sun Aug 28, 2016 11:25 am

I've got Amahi Sync installed on my server, and it was working for a while. I've been able to put a number of documents and pictures in the Public share, and they've successfully backed up. However, yesterday I added a number of home videos to my Public share in a Videos subfolder. I see the subfolder on my Control Panel, but no files are in it. According to the server status on the Settings > Servers screen, it's running. Any thoughts on why it's not backing up?

User avatar
bigfoot65
Project Manager
Posts: 11063
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi Sync Appears to Have Stopped

Postby bigfoot65 » Sun Aug 28, 2016 12:19 pm

You can try restarting the service and check the log:

Code: Select all

sudo systemctl restart amahi-sync tail -f /var/log/amahi-sync.log
If you see errors, recommend you submit a bug report.
ßîgƒσστ65
Applications Manager

jammastercd
Posts: 18
Joined: Mon Jan 03, 2011 11:57 am

Re: Amahi Sync Appears to Have Stopped

Postby jammastercd » Sun Aug 28, 2016 5:30 pm

I restarted the service and checked the log. The errors I receive were because it was looking for the path of the Public share that no longer exists. I recently moved the path /var/hda/files/Public to /var/hda/files/drives/sdb1/Public for Greyhole drive pooling. I've updated the location on the Share configuration screen in my dashboard, so I'm not sure why Amahi Sync is still looking for an old location. Should I still submit a bug report?
Attachments
Amahi Sync Screen Shot.PNG
Amahi Sync Screen Shot.PNG (21.03 KiB) Viewed 691 times

User avatar
bigfoot65
Project Manager
Posts: 11063
Joined: Mon May 25, 2009 4:31 pm

Re: Amahi Sync Appears to Have Stopped

Postby bigfoot65 » Sun Aug 28, 2016 5:40 pm

You cannot move the Public share as that's the only place amahi-sync App looks for it.

To get around that, create a symbolic link as follows:

Code: Select all

sudo ln -s /var/hda/files/drives/sdb1/Public /var/hda/files/Public
BTW, Amahi Sync does not work with Greyhole. It must be left out of the Storage Pool. We hope to resolve this one day, but for now the files have to be in /var/hda/files/Public and not a symbolic link.

That is probably why it stopped working.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests