SOLVED: Owncloud8 installation reports no PHP

thomasps
Posts: 138
Joined: Fri Feb 18, 2011 1:49 pm

SOLVED: Owncloud8 installation reports no PHP

Postby thomasps » Tue May 03, 2016 7:47 pm

I'm doing a fresh re-install of my Amahi. Upon installing Owncloud8 I get the following error when accessing the Owncloud web interface:

PHP module zip not installed.
Please ask your server administrator to install the module.
PHP modules have been installed, but they are still listed as missing?
Please ask your server administrator to restart the web server.

Checking on my PHP installation yields:

Code: Select all

[tspeidel@localhost ~]$ php -v PHP 5.6.20 (cli) (built: Mar 31 2016 06:11:29) Copyright (c) 1997-2016 The PHP Group Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
As for MariaDB, I get the folllowing:

Code: Select all

[tspeidel@localhost ~]$ mysql -v Welcome to the MariaDB monitor. Commands end with ; or \g. Your MariaDB connection id is 1348 Server version: 10.0.23-MariaDB MariaDB Server Copyright (c) 2000, 2015, Oracle, MariaDB Corporation Ab and others.
Restarting Apache does not help.
Not sure how to proceed from here and wondering if the Amahi repaackage of Owncloud8 is broken.

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Owncloud8 installation reports no PHP

Postby bigfoot65 » Wed May 04, 2016 6:22 am

Try the following as root user:

Code: Select all

dnf install php-pecl-zip systemctl restart httpd
Not sure why php-pecl-zip was not installed with the owncloud-8 App as it's a dependency.

Please let us know if this fixes your issue.
ßîgƒσστ65
Applications Manager

pdzielski
Posts: 1
Joined: Wed May 04, 2016 12:42 pm

Re: Owncloud8 installation reports no PHP

Postby pdzielski » Wed May 04, 2016 12:44 pm

This help for me working fine :) :D thank you

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Owncloud8 installation reports no PHP

Postby bigfoot65 » Wed May 04, 2016 2:28 pm

No problem.

Will mark as solved.
ßîgƒσστ65
Applications Manager

thomasps
Posts: 138
Joined: Fri Feb 18, 2011 1:49 pm

Re: SOLVED: Owncloud8 installation reports no PHP

Postby thomasps » Wed May 04, 2016 5:26 pm

Worked for me as well (OP).
Amahi team may want to look into the repackaging, as it seems dependencies are not satisfied.
Many thanks for the help

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: SOLVED: Owncloud8 installation reports no PHP

Postby bigfoot65 » Wed May 04, 2016 5:28 pm

Amahi team may want to look into the repackaging, as it seems dependencies are not satisfied.
The dependencies are satisfied by the app. Only a few users have reported the issue, so there may be a bug with the platform causing it not to install.

Worked fine when I tested on a pristine Amahi VM so not consistent behavior.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest