Really struggling with moving the data folder

batoum
Posts: 34
Joined: Sun Oct 04, 2015 3:53 am

Really struggling with moving the data folder

Postby batoum » Tue Oct 20, 2015 11:34 am

Hi

I am really really struggling to move the /var/hda/files/owncloud8/data folder into a user partition that is on a separate disk. I have NOT set up greyhole but have the OS on a small SSD and then a 3TB disk for personal data (e.g. media) and then a 2TB disk for my Time Machine backup. My goal is to have the owncloud data files on one of these disks and then sync certain folders with my desktop so I can replace dropbox (main goal is to sync photos to go onto my desktop)

I have edited the config file to point the directory to the correct file location, as instructed on the wiki. When i try to access the admin page, I get a white screen. The error logs shows the following (I have XXX-ed out the clients)
Tue Oct 20 19:17:55.252872 2015] [:error] [pid 36688] [client XXXXXX] PHP Warning: flock() expects parameter 1 to be resource, boolean given in /var/hda/web-apps/owncloud8/html/lib/private/config.php on line 201, referer: http://192.168.1.XX/

[Tue Oct 20 19:17:55.254169 2015] [:error] [pid 36688] [client XXXXXX] PHP Fatal error: Call to a member function getSystemConfig() on null in /var/hda/web-apps/owncloud8/html/lib/private/log.php on line 59, referer: http://192.168.1.XX/
What am i doing wrong? Pulling my hair out!

User avatar
bigfoot65
Project Manager
Posts: 11297
Joined: Mon May 25, 2009 4:31 pm

Re: Really struggling with moving the data folder

Postby bigfoot65 » Tue Oct 20, 2015 1:12 pm

Check the permissions. Not sure, but I believe they need to be 775 for the files and owned by your first admin user:users. Basically everything in the new location needs to look exactly like it did previously.
ßîgƒσστ65
Applications Manager

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Really struggling with moving the data folder

Postby northridgegrp » Tue Oct 20, 2015 1:36 pm

Ah Ha! This is not an usual request. I have seen this type of discussion on the ownCloud forums (https://forum.owncloud.org/).

Suggestion:
You might want to consider setting up the ownCloud external storage app for this as a local storage profile. I do that for sharing multi-media files with miniDLNA. I use ownCloud for managing the media collection (minDLNA to stream) thus keeping the ownCloud specific data in a ownCloud data path separate location.

I highly recommend that you get a user ID on the ownCloud forum, then to the forum section for the version of ownCloud you are using, and post a question. You will probably land up having several interactions but I have seen people get their answers fairly quickly.

PS: There is a bug in ownCloud 8.1.3 at the moment for the local storage profile I was talking about. It's an acknowledged bug by the ownCloud Community deverlopers. I am hoping it will be fixed in the upcoming release in the next few days.

batoum
Posts: 34
Joined: Sun Oct 04, 2015 3:53 am

Re: Really struggling with moving the data folder

Postby batoum » Tue Oct 20, 2015 4:01 pm

Thank you both....

I check permissions. Identical and not working

I have done more googling and i see the bug you (northridgegrp) mention. Not sure if it is the same. Meanwhile, I am not sure I get the solution you offer. Any links on how-tos??

batoum
Posts: 34
Joined: Sun Oct 04, 2015 3:53 am

Re: Really struggling with moving the data folder

Postby batoum » Tue Oct 20, 2015 4:20 pm

Me again.

I downloaded and updated to 8.20 and still no luck.

Any help welcome!

User avatar
bigfoot65
Project Manager
Posts: 11297
Joined: Mon May 25, 2009 4:31 pm

Re: Really struggling with moving the data folder

Postby bigfoot65 » Tue Oct 20, 2015 4:31 pm

Since this is clearly an ownCloud issue, recommend you seek assistance in their forum's. We cannot be of much assistance.
ßîgƒσστ65
Applications Manager

batoum
Posts: 34
Joined: Sun Oct 04, 2015 3:53 am

Re: Really struggling with moving the data folder

Postby batoum » Tue Oct 20, 2015 10:20 pm

Ha. Got a solution (i think)

I created a symlink between external folder to /var/hda/files/owncloud8/data.

I then got an error when i accessed owncloud
Data directory (/var/hda/files/owncloud8/data) is invalid
Please check that the data directory contains a file ".ocdata" in its root.
I then gave ownership to apache:user to all the folders on the partition drive and it works

One thing - will that impact the other services accessing those files (e.g. me?)

Who is online

Users browsing this forum: No registered users and 2 guests