Dashboard link not working because of "untrusted domain"

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Dashboard link not working because of "untrusted domain"

Postby jkbuckethead » Sat May 02, 2015 10:59 pm

I recently installed owncloud8 using the amahi one-click install. After installation, I rebooted the server and tried to access owncloud using the dashboard link. Upon doing so, I landed on an error page stating that I was "accessing the server from an untrusted domain." The page appears to be created by owncloud server, it was not a typical webpage error. The error message included a bit of information about contacting my admin, config.php files, and even a clickable button to add owncloud8.server.name as a trusted domain.
ownCloud.png
ownCloud.png (97.72 KiB) Viewed 1192 times
Needless to say, I clicked the button... several times in fact. I also added owncloud8.server.name as a trusted site in windows' internet options. I rebooted to make sure all changes were in effect, and still I cannot access owncloud via the dashboard link.

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Dashboard link not working because of "untrusted domain"

Postby northridgegrp » Sun May 03, 2015 7:46 am

Have a look at the wiki, it should help: https://wiki.amahi.org/index.php/OwnCloud_Other_Stuff

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Re: Dashboard link not working because of "untrusted domain"

Postby jkbuckethead » Sun May 03, 2015 10:22 am

Thanks, for the link. I had gone through most of the owncloud wiki and come up dry. I hadn't made it all the way to the appendices yet. Unfortunately, the wiki leaves out far too much to be useful for me. I'm a complete and total linux newbie, so I need a little more to go on than "Locate the "config.php" file in the owncloud "config" directory."

I've researched basic linux commands, but they are only so useful without an understanding of how linux organizes files. I know how to use cd and ls commands to navigate the directory tree, but finding one file in an unknown directory is quite a task using nothing but the command line and these two simple commands.

Can someone provide the path to the owncloud8 config file?



The wiki (below) seems to imply that the URL/IP of the HDA should be added to the config file during installation. If that is the case, then I should not be seeing this error. Does this indicate an error with the Owncloud 8 installer?
During the initial installation process for a new ownCloud instance the first trusted domain is captured (URL/IP address) and added to the ownCloud "config.php" file.

northridgegrp
Posts: 134
Joined: Sun Mar 07, 2010 9:54 am

Re: Dashboard link not working because of "untrusted domain"

Postby northridgegrp » Sun May 03, 2015 10:36 am

On Amahi "config.php" is located at: /var/hda/web-apps/owncloud8/html/config/ Before you edit the file make sure you understand how to use a text editor from the Linux command line. Edit the file as the "root" user.

Also for more user information you can go to the ownCloud web site for user documentation: https://doc.owncloud.org/

The Amahi wiki articles were written at a time when user information for ownCloud was very sparse, now ownCloud user docs are fairly up to date.

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Re: Dashboard link not working because of "untrusted domain"

Postby jkbuckethead » Sun May 03, 2015 2:22 pm

Thanks. With the path, with it I had no problem editing the config file. The owncloud URL, owncloud8.server.name was already in the file as a trusted domain. I added the IP for my HDA, which is 192.168.2.10. Unfortunately, even with the changes it still doesn't seem to be working correctly.

Now, instead of the Owncloud untrusted domain page, I get nothing... no error of any kind, just a completely blank webpage. Guess I'll dig into the owncloud docs and see if I can find a cure.

I do have another Amahi question. Amahi shows Owncloud8 under installed apps, but Owncloud is not listed s a running server. Is this correct?

User avatar
bigfoot65
Project Manager
Posts: 11191
Joined: Mon May 25, 2009 4:31 pm

Re: Dashboard link not working because of "untrusted domain"

Postby bigfoot65 » Sun May 03, 2015 2:39 pm

There is no server for any of the ownCloud versions and never has been. There is an Amahi share created per version of ownCloud; i.e. owncloud7, owncloud8.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest