SOLVED: HDA dashboard not accessible

pide
Posts: 4
Joined: Wed May 04, 2016 11:25 am

SOLVED: HDA dashboard not accessible

Postby pide » Wed May 04, 2016 11:31 am

Hi. I got problem connecting to HDA dashboard. I went through the Network Troubleshooter steps on the wiki and it failed at step 8. I'm using Amahi 6. My pastebin is here http://pastebin.ubuntu.com/16221627/. I hope you can help. Thanks.

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA dashboard not accessible

Postby bigfoot65 » Wed May 04, 2016 12:29 pm

Is this a new install as we no longer support Ubuntu. Recommend you install the latest release, Amahi 9.

If not, what changed before you started having problems?

Will try to assist, but Amahi 6 is quite old and may not be repairable.
ßîgƒσστ65
Applications Manager

pide
Posts: 4
Joined: Wed May 04, 2016 11:25 am

Re: HDA dashboard not accessible

Postby pide » Wed May 04, 2016 2:05 pm

Hi. This is an old install. I just installed some Ubuntu security updates and after reboot the dashboard did not work anymore. I do not know if it plays any role here but I also removed at the same time one hard drive from the greyhole and edited /etc/fstab. I can add it back and see if that makes any difference. Otherwise I have to update to the latest release. Thanks.

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA dashboard not accessible

Postby bigfoot65 » Wed May 04, 2016 2:30 pm

What security updates did you install?

Only Ubuntu 12.04 was supported with Amahi. Did you upgrade to a newer version?
ßîgƒσστ65
Applications Manager

pide
Posts: 4
Joined: Wed May 04, 2016 11:25 am

Re: HDA dashboard not accessible

Postby pide » Wed May 04, 2016 2:55 pm

It still the old Ubuntu 12.04.5 LTS with outdated HWE. These are all the installed packages during the last two days after which this happened.

2016-05-03 08:03:54 status installed man-db 2.6.1-2ubuntu2
2016-05-03 08:03:55 status installed libtasn1-3 2.10-1ubuntu1.5
2016-05-03 08:03:55 status installed libpoppler19 0.18.4-1ubuntu3.2
2016-05-03 08:03:55 status installed libpoppler-glib8 0.18.4-1ubuntu3.2
2016-05-03 08:03:55 status installed poppler-utils 0.18.4-1ubuntu3.2
2016-05-03 08:03:55 status installed libc-bin 2.15-0ubuntu10.13

2016-05-04 07:52:48 status installed man-db 2.6.1-2ubuntu2
2016-05-04 07:52:48 status installed libssl1.0.0 1.0.1-4ubuntu5.36
2016-05-04 07:52:48 status installed libc-bin 2.15-0ubuntu10.13
2016-05-04 07:52:49 status installed man-db 2.6.1-2ubuntu2
2016-05-04 07:52:49 status installed libssl-doc 1.0.1-4ubuntu5.36
2016-05-04 07:52:49 status installed libssl-dev 1.0.1-4ubuntu5.36
2016-05-04 07:52:49 status installed openssl 1.0.1-4ubuntu5.36
2016-05-04 07:52:49 status installed libmms0 0.6.2-2ubuntu0.1
2016-05-04 07:52:50 status installed libc-bin 2.15-0ubuntu10.13
2016-05-04 19:04:51 status installed ureadahead 0.100.0-12
2016-05-04 19:04:51 status installed ufw 0.31.1-1
2016-05-04 19:04:52 status installed man-db 2.6.1-2ubuntu2
2016-05-04 19:04:53 status installed samba-common 2:3.6.25-0ubuntu0.12.04.3
2016-05-04 19:04:53 status installed libwbclient0 2:3.6.25-0ubuntu0.12.04.3
2016-05-04 19:04:53 status installed samba-common-bin 2:3.6.25-0ubuntu0.12.04.3
2016-05-04 19:04:53 status installed samba 2:3.6.25-0ubuntu0.12.04.3
2016-05-04 19:04:53 status installed smbclient 2:3.6.25-0ubuntu0.12.04.3
2016-05-04 19:04:53 status installed libsmbclient 2:3.6.25-0ubuntu0.12.04.3
2016-05-04 19:04:53 status installed libc-bin 2.15-0ubuntu10.13

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA dashboard not accessible

Postby bigfoot65 » Wed May 04, 2016 4:07 pm

It's likely those updates broke something.

Can you check log files for errors?

Have you rebooted since the updates?
ßîgƒσστ65
Applications Manager

pide
Posts: 4
Joined: Wed May 04, 2016 11:25 am

Re: HDA dashboard not accessible

Postby pide » Thu May 05, 2016 4:25 am

I have rebooted couple of times without help. I was looking through the common Amahi log files and I only found some errors in the /var/hda/platform/html/log/production.log when I try to access dashboard (see below). I was not able to find anything specific in the system.log.

I also noticed that using the network troubleshooter again it failed now in step 4 DNS server is NOT working. Here is the pastebin for that one http://pastebin.ubuntu.com/16235303/

!\ FAILSAFE /!\ Thu May 05 13:37:01 +0300 2016
Status: 500 Internal Server Error
private method `split' called for nil:NilClass
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/request.rb:337:in `query_$
/var/lib/gems/1.8/gems/rack-1.0.1/lib/rack/request.rb:114:in `GET'
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/request.rb:426:in `query_$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/request.rb:385:in `parame$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/base.rb:1288:in `assign_s$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/base.rb:527:in `process_w$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/filters.rb:606:in `proces$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/rescue.rb:65:in `call_wit$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:90:in `disp$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:121:in `_ca$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:130:in `bui$
/var/lib/gems/1.8/gems/activerecord-2.3.4/lib/active_record/query_cache.rb:29:in `call'
/var/lib/gems/1.8/gems/activerecord-2.3.4/lib/active_record/query_cache.rb:29:in `call'
/var/lib/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstrac$
/var/lib/gems/1.8/gems/activerecord-2.3.4/lib/active_record/query_cache.rb:9:in `cache'
/var/lib/gems/1.8/gems/activerecord-2.3.4/lib/active_record/query_cache.rb:28:in `call'
/var/lib/gems/1.8/gems/activerecord-2.3.4/lib/active_record/connection_adapters/abstrac$
/var/lib/gems/1.8/gems/rack-1.0.1/lib/rack/head.rb:9:in `call'
/var/lib/gems/1.8/gems/rack-1.0.1/lib/rack/methodoverride.rb:24:in `call'
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/params_parser.rb:15:in `c$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/session/cookie_store.rb:9$
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/failsafe.rb:26:in `call'
/var/lib/gems/1.8/gems/rack-1.0.1/lib/rack/lock.rb:11:in `call'
/var/lib/gems/1.8/gems/rack-1.0.1/lib/rack/lock.rb:11:in `synchronize'
/var/lib/gems/1.8/gems/rack-1.0.1/lib/rack/lock.rb:11:in `call'
/var/lib/gems/1.8/gems/actionpack-2.3.4/lib/action_controller/dispatcher.rb:106:in `cal$
/usr/lib/ruby/1.8/phusion_passenger/rack/request_handler.rb:92:in `process_request'
/usr/lib/ruby/1.8/phusion_passenger/abstract_request_handler.rb:207:in `main_loop'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:418:in `start_request_$
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:358:in `handle_spawn_a$
/usr/lib/ruby/1.8/phusion_passenger/utils.rb:184:in `safe_fork'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:354:in `handle_spawn_a$
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `__send__'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `main_loop'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:163:in `start'
/usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:213:in `start'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:262:in `spawn_rails_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:256:in `spawn_rails_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:255:in `spawn_rails_application'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:154:in `spawn_application'
/usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:287:in `handle_spawn_application'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `__send__'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `main_loop'
/usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
/usr/lib/phusion_passenger/passenger-spawn-server:61

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA dashboard not accessible

Postby bigfoot65 » Fri May 06, 2016 2:22 pm

Please submit a bug report with the details and attach any pertinent log files.

Log in with amahi.org credentials, then select Project followed by Apps. Next select New Issue and provide the info.

We will take a look once we have all the details.

Hopefully this can be fixed, but understand there is no real support for Ubuntu. The only option may be to install the Amahi 9 on Fedora 23 and rebuild you HDA.
ßîgƒσστ65
Applications Manager

poppoppop
Posts: 1
Joined: Mon May 09, 2016 5:59 pm

Re: HDA dashboard not accessible

Postby poppoppop » Mon May 09, 2016 6:40 pm

Me too...
Just discovered I've got the same problem after I went to hda/ after installing latest ubuntu 12.04.5 updates.

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA dashboard not accessible

Postby bigfoot65 » Tue May 10, 2016 6:52 am

Not sure how much help we can be with this one.

You can submit a bug report. Use your amahi.org credentials to log in, then select Project followed by Platform. Next select New Issue and provide details, attach pertinent log files, and identify what updates were installed that lead to this issue.

Since we no longer support this OS, so not sure if we can help.

You may need to move to the latest stable version of Amahi which is Amahi 9 on Fedora 23.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest