Page 1 of 1

Amahi on Kubuntu 12 in VirtualBox on Vista

Posted: Tue May 01, 2012 7:05 am
by SpyderSnyper
Hey guys!

Currently, I'm in the process of installing Amahi on the new Kubuntu 12 in VirtualBox on my Vista machine...

So far, so good... Been following the directions listed here:

I ran the 2 CLI commands, and got my browser on to and put in my install code, and all seems fine...

It says that the install code looks fine and started installing, but seems to be stuck at 18%... Th little slideshow underneath is still running, and the rest of the virtual machine is responsive, so there's no problem there...

Anyone else get "stuck" at 18%? Or am I being too impatient here?

Re: Amahi on Kubuntu 12 in VirtualBox on Vista

Posted: Tue May 01, 2012 8:39 am
by bigfoot65
Not sure this will work with anything other than normal Ubuntu version. Keep in mind that this port of Amahi is still early Alpha. Since you referred to the wiki, I am sure you saw that not much of anything works with the latest Ubuntu and Amahi.

If you are wanting to try Amahi, recommend you use the official Fedora 14 version. Otherwise I presume you just want to play as Ubuntu is not ready for production.

Re: Amahi on Kubuntu 12 in VirtualBox on Vista

Posted: Wed May 02, 2012 4:00 am
by SpyderSnyper
Yeah, I saw that it wasn't production ready so fortunately I'm setting things up to play around with both kubuntu and amahi. And at this point, i can see why it isn't ready...

So after installing amahi, the installer came back and reported all as successful. I rebooted twice and tried to log in to amahi, and got the first (and so far only) error:
RuntimeError in User SessionsController#create

hdactl does not appear to be running!

RAILS_ROOT: /var/hda/platform/html
After this message there's a whole ton of other stuff I won't put up right now until necessary...

I also just ran a few CLI commands...
service hdactl status tells me that the hdactl service is not running (already knew that)
service hdactl start gives me an error:
syntax error at /usr/bin/hdactl line 663 near ** dns-nameservers $net.$self\n)
Execution of /usr/bin/hdactl aborted due to compilation isuues

My guess would be that to fix this issue I would have to edit /usr/bin/hdactl... But i opened it with kate, took a look at line 663, and can't see anything obviously out of place. Mind you, I don't know what i'd be looking for anyways...

Any suggestions on what to do next?

Re: Amahi on Kubuntu 12 in VirtualBox on Vista

Posted: Wed May 02, 2012 5:04 am
by bigfoot65
My best suggestion would be to experiment with the official version of Amahi versus the Ubuntu version.

I guess it depends on what your intentions are for this project. If you want to test Amahi, don't play with Ubuntu alpha builds and use Fedora 14. If you just want to play, then avoid the latest version of Ubuntu and work with 11.10 as its more stable.

Since the Ubuntu version of Amahi is being developed by one person, it will be a while before its stable enough to be productive in my opinion.

Not sure if you are aware, but we are a small team of volunteers with limited resources. While there are other OS distros being ported for Amahi our primary focus is Fedora.

I know I didn't offer any help with your current situation, but wanted you to understand that you may not get much if any with Ubuntu at this point. There are not many testing it. Development is still early alpha, hence support is extremely limited at this time.

Re: Amahi on Kubuntu 12 in VirtualBox on Vista

Posted: Wed May 02, 2012 5:14 pm
by SpyderSnyper
Thanks for the info Bigfoot.

There IS a bit of method to my madness for choosing kubuntu... Least of which is the long term support. Fedora 14 is no longer supported, and I don't want have to have to keep updating my OS every year... I want something a little more consistent and stable.

Though I figured Amahi was produced by volunteers, I had no idea the ubuntu version was handled by only 1 person. Kudos to them!

Re: Amahi on Kubuntu 12 in VirtualBox on Vista

Posted: Wed May 02, 2012 5:49 pm
by bigfoot65
If you are looking for LTS, then you might need to wait for it to become more stable. If you are adventurous, you might be able to get things working by trial and error.

Coincidentally Amahi is only developed by one person as well. Hence why it takes us longer to move to new version of Fedora.