CLOSED: HDA Shares not showing up in Network

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Wed May 11, 2016 8:49 pm

I attached the logs. What should my next step be?
Attachments
smbd.log
(4.49 KiB) Downloaded 36 times
nmbd.log
(4.31 KiB) Downloaded 38 times

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Thu May 12, 2016 6:35 am

Looking at the logs I see an issue with the MariaDB server.

Did you change the MariaDB root password?
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Thu May 12, 2016 4:11 pm

I do not recall changing any passwords, the only thing I did before I rebooted and it stopped working was add a couple of other users for each of my family to access my shares.

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Thu May 12, 2016 7:57 pm

By the way, is Amahi supposed to remember your password after one login? I do not have to enter the password in any other time afterwards, and I do not know if that is a good thing.

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Fri May 13, 2016 11:59 am

y the way, is Amahi supposed to remember your password after one login?
Can you elaborate as to where you entered it.

Also check that MariaDB server is running.

Code: Select all

systemctl status mariadb
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Sat May 14, 2016 8:55 pm

Output of command:

Code: Select all

● mariadb.service - MariaDB 10.0 database server Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled) Active: active (running) since Thu 2016-05-12 19:58:50 PDT; 2 days ago Main PID: 917 (mysqld_safe) CGroup: /system.slice/mariadb.service ├─ 917 /bin/sh /usr/bin/mysqld_safe --basedir=/usr └─1041 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --log-error=/var/log/mariadb/mariadb.log --pid-fil... May 12 19:58:43 localhost.localdomain systemd[1]: Starting MariaDB 10.0 database server... May 12 19:58:47 localhost.localdomain mysqld_safe[917]: 160512 19:58:47 mysqld_safe Logging to '/var/log/mariadb/mariadb.log'. May 12 19:58:47 localhost.localdomain mysqld_safe[917]: 160512 19:58:47 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql May 12 19:58:50 localhost.localdomain systemd[1]: Started MariaDB 10.0 database server.
I entered my login into the web dashboard.

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Sat May 14, 2016 9:02 pm

Everything looks fine.

As for the password, your browser must be caching it.

Check that Samba is running also. You can verify via the Dashboard in Settings, Server tab.

BTW if this issue persists, request you submit a bug report. Login using amahi.org credentials, then select Project followed by Platform. Finally select New Issue and add all pertinent details.

This will be best for trying to diagnose and resolve your issue.
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Sat May 14, 2016 9:06 pm

Samba is running, according to the Dash. But MariaDB is NOT. I will look in MariaDB logs and see what is going on.

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Sat May 14, 2016 9:16 pm

The dashboard indication that MariaDB is not running is a know issue. See bug 1802.

Please submit a bug report.
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Sat May 14, 2016 9:25 pm

Submit a bug report regarding the MariaDB not showing as running, or Samba not working?

Who is online

Users browsing this forum: No registered users and 2 guests