CLOSED: HDA Shares not showing up in Network

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

CLOSED: HDA Shares not showing up in Network

Postby rtcoder » Tue May 10, 2016 8:30 pm

The first time I had booted up my HDA and got it working, all the Samba shares were working. They were visible and I could write in them from my file manager in Linux Mint, Nemo. It also worked on Macs. It kept working until I tweaked a bit with the router, only adding the HDA to the list of reserved IP addresses, as I kept my router as the DHCP server and I had to make sure it wouldn't assign the same IP to another device and cause a conflict. After rebooting later, shares are no longer visible in the file manager, and I cannot access them at all through Samba. I have tried rebooting several times, to no avail. It is connected to the network, as I can SSH into it just fine, but Samba is not working. I tried restarting samba with

Code: Select all

sudo service smbd restart
and I got this error:

Code: Select all

Failed to restart smbd.service: Unit smbd.service failed to load: No such file or directory.
So what is going on? How do I fix this? My main use for this Amahi server is to be a file server, but that is not working anymore.

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Wed May 11, 2016 6:22 am

Please provide the output of the following:

Code: Select all

sudo systemctl status smbd
Also need the URL for the command:

Code: Select all

apaste --sysinfo
Odd that Samba is not working. Have you done OS updates? That might help.
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Wed May 11, 2016 11:33 am

First command:

Code: Select all

● smbd.service Loaded: not-found (Reason: No such file or directory) Active: inactive (dead)
Link for system info: http://paste.fedoraproject.org/365342/46299104/

I looked in the NMBD logs and it appears to have changed workgroups from my original local DNS address to WORKGROUP. I have no clue what is happening.

I tried updating system by running dnf check-update, dnf updateinfo, and then dnf upgrade. It seems to have updated the system, but the problems have still not been resolved. Please help me.

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Wed May 11, 2016 4:34 pm

Did you run the status command for the Samba service?

Your output did not indicate the correct command line.
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Wed May 11, 2016 7:03 pm

I ran the exact command you told me to.

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Wed May 11, 2016 7:08 pm

Sorry, it fat fingered it. Should have been:

Code: Select all

sudo systemctl status smb
BTW, the best way to start, stop, and restart Samba is via the HDA dashboard. It's listed as File Server in the Server section of the Settings tab.
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Wed May 11, 2016 7:16 pm

Output:

Code: Select all

● smb.service - Samba SMB Daemon Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled) Active: active (running) since Wed 2016-05-11 11:28:42 PDT; 7h ago Main PID: 888 (smbd) Status: "smbd: ready to serve connections..." CGroup: /system.slice/smb.service ├─ 888 /usr/sbin/smbd ├─ 889 /usr/sbin/smbd └─1041 /usr/sbin/smbd May 11 11:28:40 localhost.localdomain systemd[1]: Starting Samba SMB Daemon... May 11 11:28:41 localhost.localdomain systemd[1]: smb.service: Supervising process 888 which is not our child. We'll most likely not notice when it exits. May 11 11:28:42 localhost.localdomain smbd[888]: [2016/05/11 11:28:42.670642, 0] ../lib/util/become_daemon.c:124(daemon_ready) May 11 11:28:42 localhost.localdomain systemd[1]: Started Samba SMB Daemon. May 11 11:28:42 localhost.localdomain smbd[888]: STATUS=daemon 'smbd' finished starting up and ready to serve connections

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Wed May 11, 2016 7:22 pm

Everything looks normal.

Perhaps it's something to do with your router being the DHCP and DNS server.

Try making the HDA DNS server match your router.

Not using the HDA for DHCP and DNS will limit the capability. Many things may not work.

Have you tried accessing shares by IP Address? For example, \\192.168.1.11.
ßîgƒσστ65
Applications Manager

rtcoder
Posts: 51
Joined: Tue May 10, 2016 8:13 pm

Re: HDA Shares not showing up in Network

Postby rtcoder » Wed May 11, 2016 7:23 pm

I think I did try it and it didn't work. I will try again later when I get back to my LAN.

I do not want to make my Amahi server DHCP, just DNS if I can. But why did it work before without being DHCP or DNS server, and not now?

Would you like me to post log outputs?

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Shares not showing up in Network

Postby bigfoot65 » Wed May 11, 2016 7:27 pm

I do not want to make my Amahi server DHCP, just DNS if I can. But why did it work before without being DHCP or DNS server, and not now?
Hard to say. Sometimes things with networking get to a state where something is amiss. Often a complete network reset helps.
Would you like me to post log outputs?
That's fine, but please attach files vs a long post of log output.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest