Attempting to add unRaid user share to Amahi shares - Not Working

napster
Posts: 7
Joined: Mon Apr 11, 2016 6:46 pm

Attempting to add unRaid user share to Amahi shares - Not Working

Postby napster » Thu Apr 14, 2016 9:39 pm

Attempting to add a user share from my unRaid server into my HDA and not having any luck.

New to both Linux and Amahi.

The following screen shots indicate what I've added to the fstab file and the error I'm getting.

Thoughts?
Share 2.JPG
Share 2.JPG (54.38 KiB) Viewed 932 times
Share 1.JPG
Share 1.JPG (41.51 KiB) Viewed 932 times

User avatar
bigfoot65
Project Manager
Posts: 11241
Joined: Mon May 25, 2009 4:31 pm

Re: Attempting to add unRaid user share to Amahi shares - Not Working

Postby bigfoot65 » Fri Apr 15, 2016 6:26 am

Not sure, but you may have to add user credentials to the share line.

In order for me to mount a foreign share (not native to the HDA) I had to add user name and password to the line in /etc/fstab.

The sharing to NAS wiki page might help.
ßîgƒσστ65
Applications Manager

napster
Posts: 7
Joined: Mon Apr 11, 2016 6:46 pm

Re: Attempting to add unRaid user share to Amahi shares - Not Working

Postby napster » Fri Apr 15, 2016 6:46 am

Thanks for the reply.

My current unRaid shares are public and don't currently require a username and password to access.

As a result, I didn't create a credentials file on the HDA to authenticate against.

I did notice however that when I executed the # smbtree command on the HDA that the shares on the unRaid (//tower) didn't appear.

Wondering if that is indicative of the issue?

In contrast, the shares on the HDA were visible.

User avatar
bigfoot65
Project Manager
Posts: 11241
Joined: Mon May 25, 2009 4:31 pm

Re: Attempting to add unRaid user share to Amahi shares - Not Working

Postby bigfoot65 » Fri Apr 15, 2016 10:09 am

Wondering if that is indicative of the issue?
That may be your issue. Hope you figure it out.
ßîgƒσστ65
Applications Manager

napster
Posts: 7
Joined: Mon Apr 11, 2016 6:46 pm

Re: Attempting to add unRaid user share to Amahi shares - Not Working

Postby napster » Fri Apr 15, 2016 1:45 pm

For what it's worth....

The terminal window on the left is a Linux Mint PC and the terminal window on the right is the HDA.

The user share from my unRaid that I'm trying to mount on the HDA is //towwer/files which is visible on the Mint device and but not on the HDA.

The server (//tower) is visible.

As you can see I was checking for samba services which seemed to check out.

Thoughts??
Share 3.JPG
Share 3.JPG (221.97 KiB) Viewed 920 times

User avatar
bigfoot65
Project Manager
Posts: 11241
Joined: Mon May 25, 2009 4:31 pm

Re: Attempting to add unRaid user share to Amahi shares - Not Working

Postby bigfoot65 » Mon Apr 18, 2016 1:41 pm

Is there a firewall blocking access to the HDA for the unRaid system? By default it's off on the HDA.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests