Can't Mount Shares Locally

User avatar
bigfoot65
Project Manager
Posts: 11920
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Mount Shares Locally

Postby bigfoot65 » Tue Aug 25, 2020 11:06 am

The WIki asks line 25 to be modified with the appropriate password
I see now. Both passwords are correct, using either one will work. I'd probably just leave the password as is in the file.

The wiki was modified that way because a few years ago there was a different password. Guess we need to remove that piece now.

I would recommend you execute as stated in the wiki (root). What do you mean admin?

Did you install using Express DVD or Minimal Install CD? The Express DVD often causes issues for most users.

Starting over is probably best. Hopefully it'll work out this time. Also ensure all your shares are owned by the first admin user:users.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

gstorr
Posts: 26
Joined: Fri May 18, 2012 5:47 am

Re: Can't Mount Shares Locally

Postby gstorr » Tue Aug 25, 2020 12:01 pm

I have removed everything and reexecuted and same result. The shares appear in /mnt/samba but they are all empty. I have no idea what to do next to troubleshoot. ANy idea?

User avatar
bigfoot65
Project Manager
Posts: 11920
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Mount Shares Locally

Postby bigfoot65 » Tue Aug 25, 2020 12:42 pm

Did you install the script from /usr/share/hda-ctl/mount_shares_locally?

Also is your install Express DVD? What do you mean admin?

You did not answer my questions from the previous post.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

gstorr
Posts: 26
Joined: Fri May 18, 2012 5:47 am

Re: Can't Mount Shares Locally

Postby gstorr » Tue Aug 25, 2020 12:56 pm

I should have pointed this out before but I can access all files via Windows fine, so I have to conclude Samba is working. I just cant see the files when mounted locally. I have checked permissions, they are all set to my 1stuseradmin (which is "admin"). I have run greyhole -X to account for broken links. I am running out of ideas to troubleshoot this.

gstorr
Posts: 26
Joined: Fri May 18, 2012 5:47 am

Re: Can't Mount Shares Locally

Postby gstorr » Tue Aug 25, 2020 12:59 pm

Sorry, meant to add I installed Amahi via Amahi 11 Express CD (based on Fedora 27 Server) for 64 bit.

User avatar
bigfoot65
Project Manager
Posts: 11920
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Mount Shares Locally

Postby bigfoot65 » Tue Aug 25, 2020 1:00 pm

I understand and trying to help.

I need you to answer my questions in order to determine what else to recommend.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

gstorr
Posts: 26
Joined: Fri May 18, 2012 5:47 am

Re: Can't Mount Shares Locally

Postby gstorr » Tue Aug 25, 2020 1:39 pm

I appreciate the help. Thought this was going to be a 5 minute exercise:)

- I did install from usr/share/hda-ctl/mount_shares_locally.
- I used the I installer - Amahi 11 Express CD (based on Fedora 27 Server) for 64 bit.
- "admin" is my 1stuseradmin username
- I followed the mount locally install wiki to the letter several times, both as "admin" and as root (wiping it before I restarted the install each time)
- As mentioned the samba files are accessible on Windows PC's on the network.
- I have ensured the permissions of the shares are "1stuseradmin:users"
- The share directory (ie Movies, Pictures) are created but are empty
- Ran greyhole -X to correct broken links

I really appreciate your help - I literally do not know what to try next.

User avatar
bigfoot65
Project Manager
Posts: 11920
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Mount Shares Locally

Postby bigfoot65 » Tue Aug 25, 2020 2:44 pm

Part of the problem is the Express DVD.

That’s why the wiki states:
However, some users have identified issues with this install method relating to applications. The alternate install method below provides the best solution for most.
Would a reinstall be an option?

We have not been able to determine the source of the issues with the Express DVD, but don’t recall this being one until now.

As you stated, this should be a 5 minute exercise. If reinstall using Minimal Install CD is not an option, I’ll have to come up with something else.

BTW, have you done OS updates?

Code: Select all

sudo dnf update
That might help.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

gstorr
Posts: 26
Joined: Fri May 18, 2012 5:47 am

Re: Can't Mount Shares Locally

Postby gstorr » Wed Aug 26, 2020 5:48 am

I bit the bullet and reinstalled Amahi 11. Install went ok, ran the mount shares locally script. Also ran OS upgrade. Long story short I have the same issue. Still cannot see shares locally, but can see files from other samba devices like Windows. What can I do next to troubleshoot?

User avatar
bigfoot65
Project Manager
Posts: 11920
Joined: Mon May 25, 2009 4:31 pm

Re: Can't Mount Shares Locally

Postby bigfoot65 » Wed Aug 26, 2020 6:16 am

When you reinstalled, did you use the Express DVD or Minimal Install CD?
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Who is online

Users browsing this forum: No registered users and 2 guests