SOLVED: PHP Error after fresh Amahi install

thomasps
Posts: 138
Joined: Fri Feb 18, 2011 1:49 pm

SOLVED: PHP Error after fresh Amahi install

Postby thomasps » Sun Mar 25, 2018 12:24 pm

I'm getting the following PHP error in greyhole after a fresh Amahi install:

Code: Select all

Mar 25 12:50:27 WARN initialize: PHP Warning [2]: Invalid argument supplied for foreach() in /usr/bin/greyhole on line 533; BT: greyhole[L3634] processCommandLine() => greyhole[L3400] getRunner() => greyhole[L3436] process_config() => greyhole[L6467] parse() => greyhole[L150] init() => greyhole[L423] getShares()

Code: Select all

apaste --sysinfo
: https://da.gd/qh3X0

Code: Select all

curl -Ls http://bit.ly/gh-infos | sudo sh
: http://ix.io/12DB

I've installed a couple of packages that may have upgraded PHP and Python (see log attached)

User avatar
bigfoot65
Project Manager
Posts: 11063
Joined: Mon May 25, 2009 4:31 pm

Re: PHP Error after fresh Amahi install

Postby bigfoot65 » Sun Mar 25, 2018 12:33 pm

Have you done OS updates?

Code: Select all

sudo dnf update
ßîgƒσστ65
Applications Manager

thomasps
Posts: 138
Joined: Fri Feb 18, 2011 1:49 pm

Re: PHP Error after fresh Amahi install

Postby thomasps » Sun Mar 25, 2018 4:38 pm

Have you done OS updates?

Code: Select all

sudo dnf update
So far so good! Looks like an update fixed it.

User avatar
bigfoot65
Project Manager
Posts: 11063
Joined: Mon May 25, 2009 4:31 pm

Re: PHP Error after fresh Amahi install

Postby bigfoot65 » Sun Mar 25, 2018 5:21 pm

So far so good! Looks like an update fixed it.
Good.

Marking this as solved.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests