Greyhole Settings not sticking, randomly changing

craigtone
Posts: 17
Joined: Fri Apr 14, 2017 2:47 pm

Greyhole Settings not sticking, randomly changing

Postby craigtone » Thu Apr 27, 2017 2:18 pm

Sorry to vent but I just installed Amahi a week ago and so far it has been VERY frustrating! The Wiki is grossly outdated and incomplete.

Anyway, I installed Greyhole, selected 2 drives for the pool, added Shares and multiple copies and it would not start running fsck. I restarted Amahi and it was running now. I went to the Drive Pooling settings and my drives were checked and shares selected like I had set up. The problem is the drives uncheck themselves randomly. I check them, leave that tab go back and they are unchecked.

The log file (via Greyhole LogMon) says no drives added. I go back to the interface and all my settings are gone (nothing checked)! I re-set it up then Run fsck and the log is back to copying files again.

I thought it was working so I mounted the Docs share on my Mac and copied a file in and nothing. I went to Drive Pooling and now one of the disks is unchecked again. I recheck it go back to the log and all kinds of activity.

Is something wrong?

Yes ... I read the Greyhole Troubleshooting but I don't know Linux and most of it went over my head. I can't even log in as root on my box because when Fedora set up, it created an 'admin' account. I try to do 'su' to switch to root but have no idea what the password is as I never set anything up for a root account. During setup it told me NOT to set up a root account!

ARGH!!!!

craigtone
Posts: 17
Joined: Fri Apr 14, 2017 2:47 pm

Re: Greyhole Settings not sticking, randomly changing

Postby craigtone » Thu Apr 27, 2017 2:40 pm

Update: I found a random Google page and they suggested 'sudo passwd root'

I ran that and now can log in as root!

User avatar
cpg
Administrator
Posts: 2604
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Greyhole Settings not sticking, randomly changing

Postby cpg » Thu Apr 27, 2017 4:04 pm

Something is amiss, from what you say.

However, there is contradictory information in your post.

1) If you can do sudo passwd root, that means you were logged in as a regular user and that user had admin privileges. You can tell because you can run sudo successfully. Root has the same password as that admin user. Messing with root is not something we recommend for the mainstream Amahi users. If you really know what you are doing, then fine, our philosophy is that "it's your box" and nobody should limit your access to it. But you can break it.

2) Greyhole settings do not change randomly. We can state that categorically. I will print this message and eat the page it printed on if you can prove this without a shadow of a doubt.

3) If fsck was not started, that is a clue right there that there may be something not quite right with the set up you have. That said, we do try to cover as many cases as possible, so we'd like to help you. Go to the Amahi IRC channel and mention cpg and I will personally help you sort this out in real time (and with details). http://talk.amahi.org

4) Can you provide actual detail as to where in the wiki things are outdated or incomplete? We don't have staff to keep things up, however, our small team is dedicated to keep the wiki up in a timely basis. Any details you mention here will be corrected quickly.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

craigtone
Posts: 17
Joined: Fri Apr 14, 2017 2:47 pm

Re: Greyhole Settings not sticking, randomly changing

Postby craigtone » Fri Apr 28, 2017 2:51 pm

Something is amiss, from what you say.

However, there is contradictory information in your post.

1) If you can do sudo passwd root, that means you were logged in as a regular user and that user had admin privileges. You can tell because you can run sudo successfully. Root has the same password as that admin user. Messing with root is not something we recommend for the mainstream Amahi users. If you really know what you are doing, then fine, our philosophy is that "it's your box" and nobody should limit your access to it. But you can break it.

2) Greyhole settings do not change randomly. We can state that categorically. I will print this message and eat the page it printed on if you can prove this without a shadow of a doubt.

3) If fsck was not started, that is a clue right there that there may be something not quite right with the set up you have. That said, we do try to cover as many cases as possible, so we'd like to help you. Go to the Amahi IRC channel and mention cpg and I will personally help you sort this out in real time (and with details). http://talk.amahi.org

4) Can you provide actual detail as to where in the wiki things are outdated or incomplete? We don't have staff to keep things up, however, our small team is dedicated to keep the wiki up in a timely basis. Any details you mention here will be corrected quickly.
1. When I installed Fedora, it asked for a user account that was NOT root. I created an administrator account with login of admin. Root did NOT accept the same password but did allow me to run sudi passwd root as 'admin'. The wiki states over and over again that certain commands should be run as root. In this case, specifically the Greyhole Troubleshooting page.

2. You are going to eat paper! I don't know how I can prove it but my Greyhole settings (at least what is displayed in the GUI) change randomly. It is up and running but if I go to Settings, things are not consistent. It seems to be a problem with the GUI interface. :D

Perhaps I can create a YouTube video of what I am seeing but only if you promise to provide a YouTube of you eating that paper in return! :lol:

It seems to be working as long as I don't go to Drive Pooling settings. If I do, I can re-check the second drive and things seem to sort themselves out over time.

as for the wiki, I understand ... we have a wiki at work that is outdated as well because we all have "real work" to do. I get it. It is just frustrating for people like me that have very little Linux experience that are trying to get this up and running. Maybe we could create a forum topic for Wiki suggestions or better yet, flag them in the wiki as we see them.

User avatar
cpg
Administrator
Posts: 2604
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Greyhole Settings not sticking, randomly changing

Postby cpg » Fri Apr 28, 2017 3:42 pm

This is kind of curious behavior. Happy to help you if you can provide more details (and/or come to the IRC channel and mention cpg).
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

Who is online

Users browsing this forum: Yandex [Bot] and 5 guests