Message : "This drive will never be used !"

bertie40
Posts: 35
Joined: Sat Mar 19, 2011 3:16 am

Message : "This drive will never be used !"

Postby bertie40 » Mon May 26, 2014 2:54 pm

Hi Guys.
I trying to restore my files with the new system.

Drives attached.
FSTAB updated.

Drives are found by Fedora, and mounted on startup.

Im running a "greyhole --fsck", but it is coming up with the warning

"The directory at var/hda/files/drives/drive28/gh doesn't exist. This drive will never be used !
You should de-select and re-select this partition in your amahi dashboard in the shares storage pool page"

Problem is, of course, this page doesn't exist at the moment.

"Greyhole --stats" shows this drive28 (and another drive, drive 30), being "OFFLINE"


I've gone thorough the "manual greyhole instructions", but cannot see the problem.
Any advise would be gratefully received.

Regards

User avatar
bigfoot65
Project Manager
Posts: 11457
Joined: Mon May 25, 2009 4:31 pm

Re: Message : "This drive will never be used !"

Postby bigfoot65 » Mon May 26, 2014 3:22 pm

Is the gh folder already on the drives? Did you use hda-diskmount to add the drives? Ensure the mount point exists in /var/hda/files/drives and has the correct permissions.

If you followed the guidance in the wiki for Greyhole, then the config file should be correct.

UPDATE: If you search the forums, I believe someone else had the same issue.
ßîgƒσστ65
Applications Manager

bertie40
Posts: 35
Joined: Sat Mar 19, 2011 3:16 am

Re: Message : "This drive will never be used !"

Postby bertie40 » Tue May 27, 2014 1:46 am

Hi. I appreciate you taking the time to reply.

I performed a search but couldn't find anything similar.

Could you post that link please ?

Yes. I added the drives as per instructions (hda-diskmount) etc, and added the drives, one by one.

Question. If I manually just add the Gh directory to the problem drives. Will that fix it.

Cheers.

[ Post made via iPhone ] Image

bertie40
Posts: 35
Joined: Sat Mar 19, 2011 3:16 am

Re: Message : "This drive will never be used !"

Postby bertie40 » Tue May 27, 2014 1:55 am

Edit.
Both of my problematic drives were empty.

[ Post made via iPhone ] Image

bertie40
Posts: 35
Joined: Sat Mar 19, 2011 3:16 am

Re: Message : "This drive will never be used !"

Postby bertie40 » Tue May 27, 2014 2:32 am

I may have fixed it. I found a reference to this
I entered these (for my 2 problematic drives)

greyhole --replace=/var/hda/files/drives/drive28/gh

greyhole --replace=/var/hda/files/drives/drive30/gh

I restarted the machine, and both drives are now recognised. Hope this helps someone.

[ Post made via iPhone ] Image

User avatar
bigfoot65
Project Manager
Posts: 11457
Joined: Mon May 25, 2009 4:31 pm

Re: Message : "This drive will never be used !"

Postby bigfoot65 » Tue May 27, 2014 5:12 am

Might be something worth adding to the wiki.
ßîgƒσστ65
Applications Manager

bertie40
Posts: 35
Joined: Sat Mar 19, 2011 3:16 am

Re: Message : "This drive will never be used !"

Postby bertie40 » Wed May 28, 2014 9:54 am

yep.
Fixed :D

The same thing occurred with another two drives. Both empty.

"Greyhole --stats" showed both drives "OFFLINE"

In both cases, I had to manually navigate to the drive and create the gh folder.

(var/hda/files/drives/drive28/)

"mkdir gh"

Then I entered the command
"greyhole --replace=/var/hda/files/drives/drive28/gh"

Reboot,

That enabled Greyhole to see the drive and write to it accordingly.

My server is now happily chugging away with 15 drives !

If good enough, can someone "wiki" this for me ?

cheers.

Who is online

Users browsing this forum: No registered users and 4 guests