Greyhole service won't start

r3load3d
Posts: 3
Joined: Mon Dec 24, 2012 9:17 am

Greyhole service won't start

Postby r3load3d » Mon Dec 24, 2012 9:31 am

Hi guys, got a bit of a weird problem. I noticed that my greyhole service had stopped on the dashboard, so I checked the greyhole log and it showed that the last line was written a few hours ago (and that line was the sleep line, so greyhole was idle when it stopped). I tried restarting the service both in the dashboard and using 'service greyhole start', but both failed. A reboot of the server also didn't help (greyhole service was still stopped).

I then tried reinstalling greyhole using 'yum reinstall hda-greyhole', but that didn't help, and then I decided to try just running greyhole using 'greyhole -D' as a root user. Lo and behold, greyhole started running, as I could see the log being refreshed with sleep lines every 10 seconds. However, the greyhole service was still not shown as running in the dashboard or with 'service greyhole status'.

No changes had been made to the server that I can think of leading up to this problem. I had been running greyhole 0.9.24-1 for a while with no issues.

Any idea how I can fix this, so that it will run as a service?

User avatar
bigfoot65
Project Manager
Posts: 11521
Joined: Mon May 25, 2009 4:31 pm

Re: Greyhole service won't start

Postby bigfoot65 » Mon Dec 24, 2012 11:00 am

Check to see if you ran out of hard drive space for the landing zone. Greyhole will not automatically stop unless there is an issue.

There is guidance in the wiki that might help. Also check the logs for errors in /var/log as well.
ßîgƒσστ65
Applications Manager

r3load3d
Posts: 3
Joined: Mon Dec 24, 2012 9:17 am

Re: Greyhole service won't start

Postby r3load3d » Mon Dec 24, 2012 6:37 pm

Thanks for the reply. There's plenty of space in the landing zone (250GB), and the logs didn't show anything useful. Before I started greyhole with 'greyhole -D', the log leading up to the service stopping just showed sleeping for quite a few pages. I tried running a fsck in daemon mode, and while that seemed to complete successfully, I still couldn't start greyhole as a service.

I'm thinking this is a problem with the greyhole service (or the service config), rather than greyhole itself, because greyhole, when running in daemon mode, seems to be working fine. Unfortunately I'm not too experienced with Fedora/Linux, so I'm not sure where to look.

r3load3d
Posts: 3
Joined: Mon Dec 24, 2012 9:17 am

Re: Greyhole service won't start

Postby r3load3d » Tue Dec 25, 2012 1:54 am

I noticed that a new version of greyhole (9.25-1) was released today, and it seems that Amahi has auto updated to that version (While I knew that Amahi had automatic updating, I had no idea that greyhole was part of the automatic updates, especially because I had manually installed the repo along with the latest latest release a few months ago). The version that I was having problems with (9.24.1) was only released 2 days ago which is around the time the problems began, so that version must have been automatically installed as well.

In summary, everything is working great now. Obviously a bug made it into the 9.24-1 release which has now been rectified.

User avatar
bigfoot65
Project Manager
Posts: 11521
Joined: Mon May 25, 2009 4:31 pm

Re: Greyhole service won't start

Postby bigfoot65 » Tue Dec 25, 2012 11:42 am

Glad it appears to be working. Amahi does not automatically update Greyhole.

By adding the Greyhole repo, you set it up for automatic updating. We only update the Amahi platform automatically, consisting of hda-platform and hdactl.
ßîgƒσστ65
Applications Manager

ribbles
Posts: 11
Joined: Tue Dec 11, 2012 5:46 pm

Re: Greyhole service won't start

Postby ribbles » Tue Dec 25, 2012 1:33 pm

Yes there was a bug with greyhole stopping/starting on Debian/OMV that was being addressed and a non-working version was committed that was then fixed the next day.

User avatar
bigfoot65
Project Manager
Posts: 11521
Joined: Mon May 25, 2009 4:31 pm

Re: Greyhole service won't start

Postby bigfoot65 » Tue Dec 25, 2012 2:34 pm

Good to know. Amahi installs a version of Greyhole and never updates. We leave it up to users if they want to update Greyhole.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 4 guests