Greyhole not connecting to Samba (smdb_vfs_init)

agwerschky
Posts: 10
Joined: Wed Feb 16, 2011 6:34 pm

Greyhole not connecting to Samba (smdb_vfs_init)

Postby agwerschky » Sun Apr 15, 2012 5:26 pm

[17:49] <sparkus> hello, I'm having a smbd_vfs_init issue on amahi with greyhole, rpm reinstall doesn't help.
[18:02] <sparkus> it looks like I have multiple versions of greyhole installed, which may be the issue. rpm -qa | grep greyhole give me three different versions 9.20-1 through 9.22-1
[18:03] <sparkus> I can't uninstall them using rpm -e, they give an error of Job failed, see system logs for details. error: %preun(hda-greyhole-0.9.20-1.x86_64) scriptlet failed, exit status 1

the other information requested:
uname, smb, greyhole
2.6.35.14-106.fc14.x86_64
samba-3.5.11-79.fc14.x86_64
hda-greyhole-0.9.20-1.x86_64
hda-greyhole-0.9.21-1.x86_64
hda-greyhole-0.9.22-1.x86_64
http://fpaste.org/0zV1/ smb.conf
http://fpaste.org/MjD3/ greyhole.conf
Mount
/dev/sdc1 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sdc2 on /var type ext4 (rw)
/dev/sdd1 on /var/500Ghd type ext4 (rw)
/dev/sdb1 on /var/hda/files/drives/drive1 type ext4 (rw)
/dev/sda1 on /var/hda/files/drives/drive2 type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
Fdisk -l

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0003df5f

Device Boot Start End Blocks Id System
/dev/sda1 63 3515632469 1757816203+ 83 Linux
Partition 1 does not start on physical sector boundary.
/dev/sda2 3515632470 3907024064 195695797+ 83 Linux
Partition 2 does not start on physical sector boundary.

Disk /dev/sdc: 750.2 GB, 750155292160 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465147055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001f4f7

Device Boot Start End Blocks Id System
/dev/sdc1 * 63 163840062 81920000 83 Linux
/dev/sdc2 163840063 1456952064 646556001 83 Linux
/dev/sdc3 1456952065 1465144064 4096000 82 Linux swap / Solaris

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf5fdca1b

Device Boot Start End Blocks Id System
/dev/sdb1 63 1953520064 976760001 83 Linux

Disk /dev/sdd: 500.1 GB, 500106780160 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976771055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002ed71

Device Boot Start End Blocks Id System
/dev/sdd1 63 976768064 488384001 83 Linux

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sdc1 77G 4.1G 69G 6% /
tmpfs 940M 88K 940M 1% /dev/shm
/dev/sdc2 607G 406G 171G 71% /var
/dev/sdd1 459G 268G 168G 62% /var/500Ghd
/dev/sdb1 917G 702G 169G 81% /var/hda/files/drives/drive1
/dev/sda1 1.7T 1.4T 169G 90% /var/hda/files/drives/drive2

greyhole --stats

Greyhole Statistics
===================

Storage Pool
Total - Used = Free + Trash = Possible
/var/hda/files/drives/drive1/gh: 917G - 702G = 169G + 14G = 183G
/var/hda/files/drives/drive2/gh: 1650G - 1397G = 169G + 7G = 176G
/var/gh: 607G - 406G = 170G + 4G = 174G
/var/500Ghd/gh: 458G - 267G = 168G + 5G = 173G
==========================================
Total: 3632G - 2772G = 676G + 30G = 706G

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: Greyhole not connecting to Samba (smdb_vfs_init)

Postby bigfoot65 » Sun Apr 15, 2012 7:05 pm

You can try doing a downgrade as root user:

Code: Select all

yum downgrade hda-greyhole
Then once that is done, do a reinstall as per the wiki.

http://wiki.amahi.org/index.php/Greyhole_updating

Ensure you install hda-greyhole and not greyhole or you will have issues. Not sure if this will take care of your problems, but its a start.
ßîgƒσστ65
Applications Manager

agwerschky
Posts: 10
Joined: Wed Feb 16, 2011 6:34 pm

Re: Greyhole not connecting to Samba (smdb_vfs_init)

Postby agwerschky » Sun Apr 15, 2012 7:20 pm

Thanks Bigfoot!

unfortunately, downgrading doesn't help.
Transaction Check Error:
package hda-greyhole-0.9.21-1.x86_64 is already installed
I have three different versions of hda-greyhole installed, and I can't remove them via rpm -e because I get an error of:
error: %preun(hda-greyhole-0.9.20-1.x86_64) scriptlet failed, exit status 1
The only advice I got via greyhole irc was:
[18:38] <@gboudreau> force-reinstall the latest rpm
This doesn't fix the problem.

So I'm at an impasse.

If you have anything else in your bad of tricks I'll try anything!

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: Greyhole not connecting to Samba (smdb_vfs_init)

Postby bigfoot65 » Sun Apr 15, 2012 7:28 pm

That is all I know of is the down grade. It worked for me. I stopped Greyhole first, then did the command. You could try specifying the whole rpm name with downgrade. Not sure it will matter, but worth a shot.

If the author can't sort it out, then you may be stuck. You may have to consider reinstall.
ßîgƒσστ65
Applications Manager

agwerschky
Posts: 10
Joined: Wed Feb 16, 2011 6:34 pm

Re: Greyhole not connecting to Samba (smdb_vfs_init)

Postby agwerschky » Sun Apr 15, 2012 7:54 pm

Documentation of fix.
Figure out how many greyholes are installed with:

Code: Select all

rpm -qa | grep greyhole
Stop greyhole with:

Code: Select all

service greyhole stop
Then remove any duplicate packages with:

Code: Select all

rpm -e --noscripts hda-greyhole-0.9.22-1.x86_64
check to make sure you only have one package installed by running:

Code: Select all

rpm -qa | grep greyhole
Then force its reinstallation with:

Code: Select all

rpm -Uvh --force http://www.greyhole.net/releases/rpm/x86_64/hda-greyhole-0.9.21-1.x86_64.rpm
It may not be the right thing to do....but it worked for me.

User avatar
bigfoot65
Project Manager
Posts: 11437
Joined: Mon May 25, 2009 4:31 pm

Re: Greyhole not connecting to Samba (smdb_vfs_init)

Postby bigfoot65 » Mon Apr 16, 2012 4:47 am

This might a good thing to add to the Upgrading Greyhole page in the wiki.

http://wiki.amahi.org/index.php/Greyhole_updating

We would greatly appreciate it if you had time to do so.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests