Testers needed: eXtendable Download Manager or XDM for short

dano5
Posts: 26
Joined: Tue Sep 18, 2012 3:11 am

Testers needed: eXtendable Download Manager or XDM for short

Postby dano5 » Sat Feb 01, 2014 12:12 pm

Hi testers!

I need testers for HTPC Manager on Amahi 7, need testing for install, uninstall and use/configuration of app.

App description: https://www.amahi.org/apps/xdm

App source: http://xdm.lad1337.de/

pm me here or on irc with your amahi username so I can add you as tester if you're interested in helping out.

my nick on irc is same as here, dano5 :)

irishxlink
Posts: 43
Joined: Tue Dec 22, 2009 8:50 am

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby irishxlink » Sat Mar 01, 2014 5:33 pm

Hey dano5, i just installed and am currently having a 503 error.
I took a reading of the systemctl status for xdm and also /var/log/messages.

It looks like its trying to restart continuously.
http://pastebin.com/w6QVMFck


i sent the command "sudo systemctl stop xdm.service" a few times (mainly to clear the status readout for my benafit) and then did "sudo systemctl start xdm.service" and it looks like it ran for a second and the stopped again.


Secondary readout - http://pastebin.com/gXyUPG4F


Any idea what is happening?

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby bigfoot65 » Sat Mar 01, 2014 6:34 pm

There were some dependencies missing. I have been looking at it and not sure what's the problem now. Diagnosing and will post back when I know for sure it's working.
ßîgƒσστ65
Applications Manager

irishxlink
Posts: 43
Joined: Tue Dec 22, 2009 8:50 am

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby irishxlink » Mon Mar 10, 2014 10:35 am

I just did a little digging and found that i needed Flask-Babel using pip. Here is what i did,

sudo yum install python-pip
-installing python-pip

sudo pip install Flask-Babel
i got this

Requirement already satisfied (use --upgrade to upgrade): Flask-Babel in /usr/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): Flask in /usr/lib/python2.7/site-packages (from Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): Babel>=1.0 in /usr/lib/python2.7/site-packages (from Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): speaklater>=1.2 in /usr/lib/python2.7/site-packages (from Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.5 in /usr/lib/python2.7/site-packages (from Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in /usr/lib/python2.7/site-packages (from Flask->Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/lib/python2.7/site-packages (from Flask->Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): pytz>=0a in /usr/lib/python2.7/site-packages (from Babel>=1.0->Flask-Babel)
Requirement already satisfied (use --upgrade to upgrade): markupsafe in /usr/lib64/python2.7/site-packages (from Jinja2>=2.5->Flask-Babel)
Cleaning up...

So i added the flag of --upgrade to the end

sudo pip install Flask-Babel --upgrade

Now i can run xdm using "python /var/hda/web-apps/xdm/html/XDM.py"

When i tried to run it as a stand alone before i was getting "ImportError: cannot import name format_timedelta"

Now that i have it running by itself i tried it using the service and still got the same error as before (too many restarts). I am guessing it may have something to do with the systemctl scripts.

Thought i would share what i found so far and see if it helps.

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby bigfoot65 » Mon Mar 10, 2014 12:33 pm

Thanks for the update. We have removed the pip install piece as there are native packages in Fedora 19 that replaces the features.
python-flask-babel and python-flask
ßîgƒσστ65
Applications Manager

dano5
Posts: 26
Joined: Tue Sep 18, 2012 3:11 am

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby dano5 » Fri Mar 28, 2014 1:18 pm

looks like that native package won't work...have to test more to figure out what the issue is...

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby bigfoot65 » Fri Mar 28, 2014 2:08 pm

Not sure what the problem could be as it was working at one point with those packages. As you said, more investigation is needed.
ßîgƒσστ65
Applications Manager

dano5
Posts: 26
Joined: Tue Sep 18, 2012 3:11 am

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby dano5 » Wed Apr 02, 2014 12:53 pm

just tested on a fresh hda and default install will not work, fails with same message as above,
but the second I install "python-pip" and run

Code: Select all

sudo pip install babel --upgrade
the problem is more or less fixed,
more or less is because of an issue with ownership of the data directory, it fails when owned by apache:users,
might have to change that to root:root, will test and post results and upgrade app as needed.

not sure what to do about pip and babel though, since python-flask-babel and python-flask doesn't work...

User avatar
bigfoot65
Project Manager
Posts: 11337
Joined: Mon May 25, 2009 4:31 pm

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby bigfoot65 » Wed Apr 02, 2014 2:34 pm

Interesting. Permissions can be an issue, sometimes without knowing. Will have to see what works best I guess.
ßîgƒσστ65
Applications Manager

dano5
Posts: 26
Joined: Tue Sep 18, 2012 3:11 am

Re: Testers needed: eXtendable Download Manager or XDM for s

Postby dano5 » Wed Apr 02, 2014 3:10 pm

It might be that python-babel in repo is too old since doing a pip upgrade works. And since I didn't have to install flask through pip at least that works.

Will reset the hda and test with root ownership on data dir and pip upgrade only, hopefully that fixes the app.

Unfortunately I don't think we can leave out installing pip and upgrade Babel in the install script...unless someone else got any great ideas?

[ Post made via Android ] Image

Who is online

Users browsing this forum: No registered users and 2 guests