Torrentflux b4rt

User avatar
bigfoot65
Project Manager
Posts: 11136
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Fri Nov 11, 2011 10:25 am

Awesome.

I have updated the app to use your latest transmissioncli builds. It checks the arch and installs the appropriate one.

Can you please test and report back?
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Mon Nov 14, 2011 1:30 pm

Awesome.

I have updated the app to use your latest transmissioncli builds. It checks the arch and installs the appropriate one.

Can you please test and report back?
It works - for i386. I didnt checked the amd64 install.

But I've noticed you didnt patched the functions.core.netstat.php... It would be a good idea to patch the file, otherwise its impossible to use transmissioncli with more than 10 torrents...

User avatar
bigfoot65
Project Manager
Posts: 11136
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Mon Nov 14, 2011 2:29 pm

Is it just adding "sleep(3);" to '/var/hda/web-apps/b4rt/html/inc/functions/functions.core.netstat.php file? I can add that as well...should not be too hard.

Odd that it makes a difference with just a slight pause. If there is anything else needed, please let me know. I am happy to get this configured to work as a true one-click.

Also, we will need to build transmissioncli RPMs for Fedora 16 once we move to that version.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Mon Nov 14, 2011 2:56 pm

Is it just adding "sleep(3);" to '/var/hda/web-apps/b4rt/html/inc/functions/functions.core.netstat.php file?
Yes!

Odd that it makes a difference with just a slight pause.
The reason (copied over from one of my last postings):
At next its necassary to disable the 'bulk start' options in TFB because it seems to start the clients too quickly which means that the port-checking routines fail as the previous port may not yet have been opened and so appears to be free (and therefore gets used).
I am happy to get this configured to work as a true one-click.
Thats very important. Not everyone knows howto ssh into his machine ;)
Also, we will need to build transmissioncli RPMs for Fedora 16 once we move to that version.
Hmm.. No problem!

User avatar
bigfoot65
Project Manager
Posts: 11136
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Mon Nov 14, 2011 3:01 pm

Ok, thanks for the explanation. I have added the patch, hopefully to the right place in the file. Hehehehe. Check it out and let me know if it works as you intended.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Tue Nov 15, 2011 5:55 am

Did you applied the vlc patch? See more details on the second page from Fri Nov 11, 2011 7:57 am

User avatar
bigfoot65
Project Manager
Posts: 11136
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Tue Nov 15, 2011 6:02 am

I missed that one it seems. I presume that is #2 where I need to download something from your dropbox.

I will work it when I get home from work. I don't have dropbox access unfortunately here. Looks like a simple fix though.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Tue Nov 15, 2011 7:02 am

Looks like a simple fix though.
Yep, very simple. Just download the patch and overwrite your files inside your b4rt doc-root!

User avatar
bigfoot65
Project Manager
Posts: 11136
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Tue Nov 15, 2011 3:47 pm

Ok, check it out. I added the 3 patch files to the app. Please let me know if this fixes everything as you intended.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Wed Nov 16, 2011 8:51 am

Hey! I've finished my second test and it seems like there is a small problem: this vlc-patch works only with the RedRound theme correctly (luckily you have backups)... So: without using the RedRound-theme there is no way to stream your media.

There are 2 possibilities:

First one is to install the RedRound-theme by default. The user can stream his media.

Second: no RedRound, no stream.

everything else works except for this little annoyance

Who is online

Users browsing this forum: No registered users and 1 guest