Torrentflux b4rt

User avatar
bigfoot65
Project Manager
Posts: 10955
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Sat Oct 15, 2011 10:33 am

Do you have a Dropbox account? If so put them there and I will grab them to upload to Amahi. If not, you can get one for free. 2GB free online storage too.

Post the Dropbox links in the wiki and I will add them to Amahi. Once I do that, I can change the links in the wiki.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Wed Oct 19, 2011 4:07 am

I've tested tf-b4rt once again and I have noticed that the transmissioncli 1.34 is used. Transmission 1.34 is prohibited on many ALT. Is it possible to use Transmission 1.50 instead of 1.34?

Get the cli.c and the instructions here: http://svn.berlios.de/svnroot/repos/tf- ... nsmission/

User avatar
bigfoot65
Project Manager
Posts: 10955
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Wed Oct 19, 2011 4:51 am

It may be possible. I used the version that their web page called for, but guess that is not good. I will have to check into this updated version and see if I can add it to the app.

I followed the instructions, but did not apply the patch as noted. That could be part of the issue. Either way, I will see what I can do. Sure wished the author would update the app to work with current Transmission CLI from Fedora repo. Would be so much easier.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Wed Oct 19, 2011 9:27 am

just take my transmissioncli, I've stored it also in my Dropbox-folder. My transmissioncli works fine! (with Fedora 14 AMD 64)

Code: Select all

[administrator@amahi ~]$ uname -a Linux amahi 2.6.35.6-45.fc14.x86_64 #1 SMP Mon Oct 18 23:57:44 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

You can apply patches by

Code: Select all

patch -p1 < /path/to/tf-b4rt.patch
get the patch with wget

Code: Select all

wget http://svn.berlios.de/svnroot/repos/tf-b4rt/branches/clients/transmission/transmission-1.50/tf-b4rt.transmission.patch
https://www.dropbox.com/link/17.NBznanH ... 01ee8c81df

User avatar
bigfoot65
Project Manager
Posts: 10955
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Wed Oct 19, 2011 10:10 am

I know how to patch it, just didn't realize I needed to. Have you already done the patch on your version? If your version is not arch specific, then I will add it to the app. If it is, then I need to get the 32-bit version as well.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Wed Oct 19, 2011 10:33 am

Have you already done the patch on your version? If your version is not arch specific, then I will add it to the app. If it is, then I need to get the 32-bit version as well.
Ofc I have done the patch. I'm not sure if its is arch specific (u mean architecture specific, right?). But i will test it in my virtual machine.

User avatar
bigfoot65
Project Manager
Posts: 10955
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Thu Oct 20, 2011 4:50 am

I have downloaded your version and will add it to the app tonight. Since you have done the patch, all I should have to do it replace the current version with yours.

I am thinking this will work with both 32- and 64-bit. Hoping this fixes the last issue and its ready for some rigorous testing.

Thanks for all your interest and assistance in getting this app working correctly.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Fri Nov 11, 2011 7:57 am

I am testing tfb4rt for a couple of time now and there are still some problems:

1.) Transmission has a major bug in it :( if you got over 10 torrents started any new ones abort due to not finding a new port.

MY SOLUTION:

This can usually be fixed by increasing the port range available in the admin settings of TFB and also changing the permissions of the 'netstat' binary:

Code: Select all

[root@amahi ~]# ls -l /bin/netstat -rwxr-xr-x 1 root root 127200 6. Okt 2010 /bin/netstat [root@amahi ~]# [root@amahi ~]# chmod ug+s /bin/netstat [root@amahi ~]# [root@amahi ~]# ls -l /bin/netstat -rwsr-sr-x 1 root root 127200 6. Okt 2010 /bin/netstat
At next its necassary to disable the 'bulk start' options in TFB because it seems to start the clients too quickly which means that the port-checking routines fail as the previous port may not yet have been opened and so appears to be free (and therefore gets used). Just as example:

Code: Select all

[2011/11/08 - 00:07:31] Initialized command-facility. (/var/hda/files/downloads/.transfers/file.name.torrent.cmd) [2011/11/08 - 00:07:31] Wrote pid-file: /var/hda/files/downloads/.transfers/file.name.torrent.pid (5705) Port Forwarding (UPnP): Found Internet Gateway Device "http://172.31.2.1:1780/control?WANIPConnection" Port Forwarding (UPnP): Local Address is "172.31.2.5" Port Forwarding (UPnP): Port forwarding through "http://172.31.2.1:1780/control?WANIPConnection", service "urn:schemas-upnp-org:service:WANIPConnection:1". (local address: 172.31.2.5:49122) Port Forwarding (UPnP): Port forwarding successful! Port Forwarding: State changed from "Not forwarded" to "Forwarded" Couldn't bind port 49122 on ::: Address already in use Port Forwarding: Couldn't open port 49122 on :: to listen for incoming peer connections (errno 98 - Address already in use) Couldn't bind port 49122 on 0.0.0.0: Address already in use Port Forwarding: Couldn't open port 49122 on 0.0.0.0 to listen for incoming peer connections (errno 98 - Address already in use)
Even though transmission "knows" that a port is already in use, it is forced to use it. I've fixed this issue by altering 'function netstatPortList()' in '/var/hda/web-apps/b4rt/html/inc/functions/functions.core.netstat.php' like this (adding the 'sleep(3)' line) -

Code: Select all

[root@amahi ~]# vim /var/hda/web-apps/b4rt/html/inc/functions/functions.core.netstat.php case 1: // linux // not time-critical (only used on allServices-page), use the // generic and correct way : // array with all clients $clients = array('tornado', 'transmission', 'wget', 'nzbperl', 'azureus'); // get informations foreach($clients as $client) { $ch = ClientHandler::getInstance($client); sleep(3); $retStr .= shell_exec($cfg['bin_netstat']." -e -p --tcp --numeric-hosts --numeric-ports 2> /dev/null | ".$cfg['bin_grep']." -v root | ".$cfg['bin_grep']." -v 127.0.0.1 | ".$cfg['bin_grep']." ". $ch->binSocket ." | ".$cfg['bin_awk']." '{print \$5}'"); } break;
But be aware that this will obviously cause long delays when starting lots of torrents at once!!!!!

2) Streaming - as I wrote some weeks ago - doesn't work. But I've found a patch which solves this problem! Get the patch from my Dropbox-folder and copy&overwrite it in the b4rt-doc-root.


3) transmissioncli doesnt fill up the statistics correctly... it seems like none of my (transmission-)torrents keep track of their transfer stats, but the transfer-speed (up- and download) is correct. See "stats.png"

4.) get the fixed transmissioncli 1.50 for AMD64 and i386 from my dropbox-folder. Build on:

Code: Select all

uname -a Linux localhost.localdomain 2.6.35.14-103.fc14.i686.PAE #1 SMP Thu Oct 27 15:58:03 UTC 2011 i686 i686 i386 GNU/Linux
- and -

Code: Select all

uname -a Linux localhost.localdomain 2.6.35.14-103.fc14.x86_64 #1 SMP Thu Oct 27 15:41:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Attachments
stats.png
wrong stats from transmissioncli
stats.png (25.72 KiB) Viewed 1719 times

User avatar
bigfoot65
Project Manager
Posts: 10955
Joined: Mon May 25, 2009 4:31 pm

Re: Torrentflux b4rt

Postby bigfoot65 » Fri Nov 11, 2011 8:22 am

Hello,

Great tips for users. Would you mind including these in the wiki?

http://wiki.amahi.org/index.php/TorrentFlux-b4rt

We had updated the app recently and thought we had the newest transmissioncli inluded. If you have an updated transmissioncli that we can add to the app, please PM me the link. I would be happy to update the app to use it.

Our goal is to make the apps more solid so users don't have to make many changes for it to work correctly. Your help would be greatly appreciated.
ßîgƒσστ65
Applications Manager

stern88
Posts: 134
Joined: Thu Oct 13, 2011 8:03 am

Re: Torrentflux b4rt

Postby stern88 » Fri Nov 11, 2011 10:07 am

Hello,

Our goal is to make the apps more solid so users don't have to make many changes for it to work correctly.
Yep, thats also the aim of my tipps! Solve Problem

#1

by modifying the 'function netstatPortList()' in '/var/hda/web-apps/b4rt/html/inc/functions/functions.core.netstat.php' by adding the 'sleep(3)' line. Get the details from my last post

#2

by applying the patch for the VLC VoD-function
(technical details see Chapter 5. VLM - Multiple streaming and Video on demand: http://www.videolan.org/doc/streaming-h ... /ch05.html)

#3

by doing nothing... I dont know how to solve this problem. But thats no critical problem!

#4

I've uploaded the transmissioncli 1.50 compiled on both arch (i386 and AMD64). There is a difference between the transmissioncli for AMD64 and i386, thats why I have uploaded this again!

EDIT:
Thats my dropbox-folder: https://www.dropbox.com/link/17.NBznanH ... 01ee8c81df

Who is online

Users browsing this forum: No registered users and 2 guests