Amahi 6 Express CD Alpha 1 release!

rjwaldren
Posts: 71
Joined: Mon Jan 17, 2011 7:15 pm

Re: Amahi 6 Express CD Alpha 1 release!

Postby rjwaldren » Mon Apr 04, 2011 9:50 pm

Tested the 32-bit version in VMware briefly today, I found the same results already posted - no root device, sleeping forever.

I tried again, this time using a custom partition layout - No LVM and no EXT4.
/boot 200MB ext3
/ 6.0GB ext3
swap 500MB

This booted to a logon prompt after a few amahi setup messages, once logged in I saw the same breakage that SolaR has already reported for the 64-bit version.

Unfortunately time is a premium right now, so I wasn't able to go any further with it. I'm know the Debian installer and boot methods alot better than Fedora. I'd like to:

1. Get to a VT before the fedora installer forces a reboot - couldn't find a way but didn't have time to look real hard.
2. Strip out plymouth and other graphical crap from grub that's obscuring the boot messages. Esc allowed me to see the kernel/init message on my "bootable" custom partition install, but on the default install it never got that far.
Amahi 6.1 x86_64 ExpressCD - Intel D510MO, 2GB, Promise TX300
1x 500GB 2.5" WD Black (OS and LZ). Pool: 1x 1.5TB Samsung F2, 1x 1.5TB Samsung F3, 1x 2TB Samsung F4EG
Apps: uShare, uTorrent, Amahi Energy Saver

rjwaldren
Posts: 71
Joined: Mon Jan 17, 2011 7:15 pm

Re: Amahi 6 Express CD Alpha 1 release!

Postby rjwaldren » Tue Apr 05, 2011 4:56 pm

Should lvm2 be included in the installed rpm's on the i386 ISO, it's not :D - looking at the anaconda logs there are alot of errors relating to lvm2 missing. The anaconda storage log shows that the tools are available during install for creation of the lvm group but there is no indication that the tools are available outside of the installer (ie rebooting into the installed system)
Amahi 6.1 x86_64 ExpressCD - Intel D510MO, 2GB, Promise TX300
1x 500GB 2.5" WD Black (OS and LZ). Pool: 1x 1.5TB Samsung F2, 1x 1.5TB Samsung F3, 1x 2TB Samsung F4EG
Apps: uShare, uTorrent, Amahi Energy Saver

User avatar
cpg
Administrator
Posts: 2605
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi 6 Express CD Alpha 1 release!

Postby cpg » Tue Apr 05, 2011 6:51 pm

i am not sure. i *thought* the default was to use the whole drive, with non-lvm partitioning.

(i am also scraping for extra time for the express cd recently, so thanks for jumping in to help move this along!)
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

rjwaldren
Posts: 71
Joined: Mon Jan 17, 2011 7:15 pm

Re: Amahi 6 Express CD Alpha 1 release!

Postby rjwaldren » Tue Apr 05, 2011 8:42 pm

Just had a good boot... Here's how it went, please excuse the brevity with which was written.

Installed using all defaults. That means it created a 500MB EXT4 /boot and a lg_vol on sda2 with / and swap. Reboot fails as already noted.

Booted to rescue mode (enabled networking when prompted) and did the following.

Code: Select all

chroot /mnt/sysimage yum update yum install lvm2 dracut -f exit chroot and reboot
During reboot, it goes into some SElinux "labeling" stuff that I don't understand, which reboots the system once again. Then onto amahi installation, doesn't fail but never asks for an install code or anything else. eth0) is down at this point

Finally a logon prompt, only root user has been created, so logon as root.

Code: Select all

ifup eth0 hda-new-install <install code>
Has a few failures to remove some packages but works. After one final reboot I was able to browse to my hda's logon screen but since no users were created I was unable to logon.
Amahi 6.1 x86_64 ExpressCD - Intel D510MO, 2GB, Promise TX300
1x 500GB 2.5" WD Black (OS and LZ). Pool: 1x 1.5TB Samsung F2, 1x 1.5TB Samsung F3, 1x 2TB Samsung F4EG
Apps: uShare, uTorrent, Amahi Energy Saver

User avatar
cpg
Administrator
Posts: 2605
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi 6 Express CD Alpha 1 release!

Postby cpg » Tue Apr 05, 2011 9:13 pm

nice work! i am not sure we want lvm stuff in there for a headless system.

armed with this i will see what i can do next!

awesome!
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

rjwaldren
Posts: 71
Joined: Mon Jan 17, 2011 7:15 pm

Re: Amahi 6 Express CD Alpha 1 release!

Postby rjwaldren » Tue Apr 05, 2011 9:30 pm

Agreed, the default partition table for the installer is to use it though. Using a custom partition table and leaving out the lvm works fine and is my preferred method too. I would think that some users would like LVM to be available for storage drives though. Total size of LVM with dep's was less than 2MB if I recall.

Forgot to mention in the previous message "yum install lvm2" pulls in:
device-mapper
device-mapper-event
device-mapper-event-libs
device-mapper-libs
lvm2-libs

It seems that working out the partition layout, and getting eth0 up early enough will leave only the amahi specific config to work out. I'll help where I can but I'm better at finding breakage than providing solutions most days ;) < aren't we all.
Amahi 6.1 x86_64 ExpressCD - Intel D510MO, 2GB, Promise TX300
1x 500GB 2.5" WD Black (OS and LZ). Pool: 1x 1.5TB Samsung F2, 1x 1.5TB Samsung F3, 1x 2TB Samsung F4EG
Apps: uShare, uTorrent, Amahi Energy Saver

rjwaldren
Posts: 71
Joined: Mon Jan 17, 2011 7:15 pm

Re: Amahi 6 Express CD Alpha 1 release!

Postby rjwaldren » Tue Apr 12, 2011 3:13 pm

cpg,

I the build tree for the expressCD available? I've been playing around with pungi and lorax and would like to look at the method you use to build the images.
Amahi 6.1 x86_64 ExpressCD - Intel D510MO, 2GB, Promise TX300
1x 500GB 2.5" WD Black (OS and LZ). Pool: 1x 1.5TB Samsung F2, 1x 1.5TB Samsung F3, 1x 2TB Samsung F4EG
Apps: uShare, uTorrent, Amahi Energy Saver

rjwaldren
Posts: 71
Joined: Mon Jan 17, 2011 7:15 pm

Re: Amahi 6 Express CD Alpha 1 release!

Postby rjwaldren » Wed Apr 20, 2011 4:59 pm

Using revisor, it looks like the resulting iso is nearly the same as the 2 alpha images. Revisor adds alot of configurability but at cost of being much more convoluted then straight pungi builds.

I did confirm that adding lvm2 to the kickstart does produce an image that installs and boots fedora with the default LVM partitioning scheme. Something is pulling a disturbing amount of the X stack too - might just be for graphical anaconda though. The issue that I'm seeing right now is that the graphic.cfg ks file uses zenity to query for the install code in the %pre script. I've not seen the dialog box come up, though I do see indications that the correct ks file is loaded and it's %pre section executed. It may be due to my VM, haven't been home to try it on a real box and my laptop is having issues with qemu-kvm both with the installation of the iso's and with bridging to wlan0.
Amahi 6.1 x86_64 ExpressCD - Intel D510MO, 2GB, Promise TX300
1x 500GB 2.5" WD Black (OS and LZ). Pool: 1x 1.5TB Samsung F2, 1x 1.5TB Samsung F3, 1x 2TB Samsung F4EG
Apps: uShare, uTorrent, Amahi Energy Saver

Who is online

Users browsing this forum: No registered users and 1 guest