Page 1 of 1

Opensis - Cannot login after install

Posted: Fri Jan 29, 2010 4:50 pm
by gaelscoilraheen
Hi All,

Very impressed with Amahi. I've recommended it to my childrens schools. As part of this recommendation I want them to use opensis for student records. I've installed Opensis using the Amahi setup. All worked fine. I then went to the new website. Here I'm presented with 2 options 'install' and 'upgrade'. This is a new install so I clicked install.

Everything appears to have installed correctly but when I try to login using the account setup during installation the login fails. I've reinstalled a number of times and I am sure that I have entered the proper username and password.

Any help would be greatly appreciated.

Shane Mann

Re: Opensis - Cannot login after install

Posted: Tue Feb 02, 2010 1:33 pm
by gaelscoilraheen
Hi all,

Found the solution in the opensis support site. Resetting the year in the staff table from 2009 to 2010 for the admin account allowed me to login using the username and password setup during install. Hope this helps somebody else.


Re: Opensis - Cannot login after install

Posted: Tue Feb 02, 2010 2:37 pm
by bigfoot65

I found the issue. The year has to be updated in 2 places, the database and the data.php configuration file. I have modified the install script to fix this.

We pride ourselves in providing applications that install with minimal user invention. Unless specified, you should not have to do a manual install or upgrade on Amahi Apps.

Thanks for bringing this to our attention. Users like you are the ones who make Amahi better for everyone.

Re: Opensis - Cannot login after install

Posted: Wed Feb 03, 2010 1:34 pm
by gaelscoilraheen
Many thanks for updating the install scripts. After you changed the script I decided to do a clean install. After selecting opensis in the HDA dashboard it takes me to a blank webpage not the normal install page. Please let me know if there is something else I should be doing.


Re: Opensis - Cannot login after install

Posted: Wed Feb 03, 2010 2:21 pm
by bigfoot65
Sorry it did not work for you. I checked the script and made a minor change. Please try it again. I recommend you uninstall, reboot your hda, then reinstall.

Please let us know if this fixes your issue.

Re: Opensis - Cannot login after install

Posted: Tue Dec 23, 2014 8:45 pm
by ahmadqk
I have installed the following version:
openSIS CE 5.3 based multilingual build
and I have faced the same issue, where after finishing the installation I tried to login but unfortunately couldn't.

After tracing and investigation, I have found the issue and resolve it, and below is the description.

After installation you will find the database has a record for the admin in table "staff", and a record for the school in table "schools", and there should be another record in a table named "staff_school_relationship" to relate the staff and school, in my case there was no record in table "staff_school_relationship" and after I create, it worked properly.

My advice for anyone who has problem in login after the installation is to check the following:
1- The three tables: "staff", "schools" and "staff_school_relationship"
2- The date in table "schools"
3- Set the "LOGIN_FAILURE" value in table "staff" to "0" and ensure that "isdisabled" field value in table "staff" is also "0".

I hope this will help you resolving your issue.


Ahmad Kam
Technical & Project Manager

Re: Opensis - Cannot login after install

Posted: Wed Dec 24, 2014 3:38 am
by bigfoot65
This thread is quite old and for a different Amahi version than currently supported. OpenSIS is not LIVE for Amahi 7.

If you are willing to help test, we can get it there.