SOLVED: remote connection problem

sakis650
Posts: 3
Joined: Thu Jun 03, 2021 12:47 am

SOLVED: remote connection problem

Postby sakis650 » Tue Jun 08, 2021 4:25 am

Hi everyone
I just set up successfully my Amahi 11 on Fedora 27. Everything works perfect on LAN. I am just having problem connecting remotely through Openvpn.

HDAconnect error log is

Tue Jun 08 11:37:40 2021 OpenVPN 2.1_rc15 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Nov 19 2008
Tue Jun 08 11:37:41 2021 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Tue Jun 08 11:37:41 2021 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Jun 08 11:37:41 2021 LZO compression initialized
Tue Jun 08 11:37:41 2021 Control Channel MTU parms [ L:1544 D:140 EF:40 EB:0 ET:0 EL:0 ]
Tue Jun 08 11:37:41 2021 RESOLVE: Cannot resolve host address: sakis650.yourhda.com: [HOST_NOT_FOUND] The specified host is unknown.
Tue Jun 08 11:37:41 2021 Data Channel MTU parms [ L:1544 D:1450 EF:44 EB:135 ET:0 EL:0 AF:3/1 ]
Tue Jun 08 11:37:41 2021 Local Options hash (VER=V4): '69109d17'
Tue Jun 08 11:37:41 2021 Expected Remote Options hash (VER=V4): 'c0103fa8'
Tue Jun 08 11:37:41 2021 RESOLVE: Cannot resolve host address: sakis650.yourhda.com: [HOST_NOT_FOUND] The specified host is unknown.
Tue Jun 08 11:37:46 2021 RESOLVE: Cannot resolve host address: sakis650.yourhda.com: [HOST_NOT_FOUND] The specified host is unknown.

Openvpn tester goes green on my control panel.
Set up of HDAconnect is done by the book
Router is checked for firewalls and ports forwarding (draytek vigor 2925)
The interactive network troubleshooter was ok.

Any advice on this would be more than welcome
thanks

User avatar
bigfoot65
Project Manager
Posts: 11863
Joined: Mon May 25, 2009 4:31 pm

Re: remote connection problem

Postby bigfoot65 » Wed Jun 09, 2021 5:24 pm

Are you using your HDA for DHCP/DNS?

If not, recommend you check out the Amahi FAQ.

This could be the issue.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

User avatar
bigfoot65
Project Manager
Posts: 11863
Joined: Mon May 25, 2009 4:31 pm

Re: remote connection problem

Postby bigfoot65 » Wed Jun 09, 2021 7:09 pm

Never mind my previous post. I disproved that theory as my HDA VPN is working and I am not using it for DHCP/DNS.

Do you have the latest certificates installed? I seem to remember we generated new certificates a year ago or so.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

sakis650
Posts: 3
Joined: Thu Jun 03, 2021 12:47 am

Re: remote connection problem

Postby sakis650 » Thu Jun 17, 2021 3:02 am

problem solved. I uninstalled OpenVpn server from my hda and re-installed it

User avatar
bigfoot65
Project Manager
Posts: 11863
Joined: Mon May 25, 2009 4:31 pm

Re: remote connection problem

Postby bigfoot65 » Thu Jun 17, 2021 3:18 am

Good to hear.

Will mark as resolved.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Who is online

Users browsing this forum: No registered users and 2 guests