unable to ping username.yourhda.com from outside the network

kevmorris
Posts: 20
Joined: Mon Jan 10, 2011 12:03 pm

unable to ping username.yourhda.com from outside the network

Postby kevmorris » Fri Jan 28, 2011 3:15 am

hi,

Ive portforwarded port 1194 to 1194 udp 192.168.1.10 which is my internal server ip address when i try to access https://username.yourhda.com from my work computer it cannot find the page and if i try to ping it i get no response. Im using a netgear wndr3700 router and ive set up port forwarding to get utorrent working correctly. The server seems to be working ok other than i cant connect remotely. Any ideas are appreciated.

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: unable to ping username.yourhda.com from outside the net

Postby bigfoot65 » Fri Jan 28, 2011 5:38 am

You will not be able to ping your HDA outside the network using that address. If you are VPNed into your network, you may be able to though. Forwarding UDP 1194 enables you to VPN into the network using hdaconnect for Windows or a similar client on Linux or MAC.

That address is for accessing your web apps. In order to do that, please see http://wiki.amahi.org/index.php/Hosting_a_website for more guidance. This does require forwarding port 80 to your HDA IP.
ßîgƒσστ65
Applications Manager

kevmorris
Posts: 20
Joined: Mon Jan 10, 2011 12:03 pm

Re: unable to ping username.yourhda.com from outside the net

Postby kevmorris » Fri Jan 28, 2011 6:18 am

Thanks for the reply. What i was trying to do was get adito working, i originally set up my router as per the wiki guide i.e.

Router (Settings)
In order to use https://user.yourhda.com (substitute your user name for user) to access Adito VPN from any computer using the web browser, create a Port Forward or Virtual Server rule. This is a required step for the Map HDA Folders and Apps options to work from outside your network.

On a D-LINK WBR-2310 router, set a Virtual Server setting to forward port 443 public and 4443 private to the HDA server IP address using TCP traffic type

Is this all i need to do to access adito from a remote computer or does adito need setting up as per the "hosting a website" wiki page you linked me?

TIA

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: unable to ping username.yourhda.com from outside the net

Postby bigfoot65 » Fri Jan 28, 2011 6:45 am

Understand. I have Adito set up that way. If you followed the wiki guidance you listed, the virtual server should be set up correctly. Forwarding port 1194 has nothing to do with this setup.

You should be able to access it via https://username.yourhda.com with user name being your amahi.org user name.

If it does not work, then there may be a firewall issue somewhere. You can also try changing the public port to 8443, then add that to the end of the url like this:

https://username.yourhda.com:8443

I have been using Adito outside my network for quite some time with no issues.
ßîgƒσστ65
Applications Manager

kevmorris
Posts: 20
Joined: Mon Jan 10, 2011 12:03 pm

Re: unable to ping username.yourhda.com from outside the net

Postby kevmorris » Fri Jan 28, 2011 11:01 am

once again, thanks for taking the time to help me

i might be making a little head way... before i didnt have port 4443 forwarded to my server. I have a netgear wndr3700 router and in the port forwarding section of the settings it doesnt have public and private ports. so i have forwarded 443 and 4443 to my server address.

onto the second part of the wiki

Map HDA Apps Option 1 (Web Forwards Tunneled Web)

* Login as administrator
* Select Web Forwards (middle left menu)
* Select Create Web Forward
* Select Tunneled Web and select Next
* Enter Application Name and Description.
* Check Add to Favorites and select Next
* Enter http://application (i.e. HDA, Opendb, etc) for Destination URL and select Next. Applications that use a port other than 80, you need to specify that as part of the URL, for example http://application:8069
* Select Everyone, select Add, and select Next
* Select Finish and select Exit Wizard
* Keep in mind not all HDA apps will work outside your network
* This method makes use of Adito Agent (java web agent)
* Each time the agent is executed, the SSL tunnel uses a random port (may not work with firewalled client network)

do i have to do this to get adito working so i can download files or is this just to get web apps working? i.e. do i need to add http://adito into the application field? sorry if this is a dumb quest but i am confused on all this! :oops:

kevmorris
Posts: 20
Joined: Mon Jan 10, 2011 12:03 pm

Re: unable to ping username.yourhda.com from outside the net

Postby kevmorris » Mon Jan 31, 2011 2:38 am

i think i know have it working.. if i type https://username.yourhda.com it wont load, if i use https://username.yourhda.com:4443 it works :) Why does adding the port make it work? is it worth adding a line to the wiki about the port might need adding to make it work?

i just need to sort out the certificate issue now :)

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: unable to ping username.yourhda.com from outside the net

Postby bigfoot65 » Mon Jan 31, 2011 7:18 am

Hello,

You might have your ports switched in your router forwarding. This is specific to your system as I have mine set up according to the wiki and it works fine.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests