CLOSED: openvpn server not running

CloudBoss
Posts: 15
Joined: Fri Mar 08, 2019 1:19 pm

CLOSED: openvpn server not running

Postby CloudBoss » Fri Mar 08, 2019 1:29 pm

installed the openvpn server app, checked to see if it running, says inactive says to activate it, tried to restart it says not installed, cant uninstall or reinstall it, do not understand why it says inactive or what is going on

have gone thru the wiki to see what is what, need some help

i am sum what experienced with linux, have used raspbian, ubuntu, so i am not afraid of operating system

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: openvpn server not running

Postby bigfoot65 » Fri Mar 08, 2019 3:35 pm

You might take a look at bug 1910 and bug 1801.
ßîgƒσστ65
Applications Manager

CloudBoss
Posts: 15
Joined: Fri Mar 08, 2019 1:19 pm

Re: openvpn server not running

Postby CloudBoss » Fri Mar 15, 2019 8:29 am

tried both of the fixes still not running says that it must be activated, i am running amahi install 11 on fedora 27, this is what the install set up, rebooted several times after running fixes, tested before reboot also, openvpn server still inactive

CloudBoss
Posts: 15
Joined: Fri Mar 08, 2019 1:19 pm

Re: openvpn server not running

Postby CloudBoss » Fri Mar 15, 2019 8:33 am


CloudBoss
Posts: 15
Joined: Fri Mar 08, 2019 1:19 pm

Re: openvpn server not running

Postby CloudBoss » Fri Mar 15, 2019 1:10 pm

i have tried to use this at root
sudo systemctl status openvpn@amahi.service

this is the response

Unit openvpn@amahi.service could not be found.

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: openvpn server not running

Postby bigfoot65 » Sat Mar 16, 2019 5:49 pm

Check /var/log/amahi-app-installer.log for errors.

Sounds like the app may not have installed correctly.
ßîgƒσστ65
Applications Manager

CloudBoss
Posts: 15
Joined: Fri Mar 08, 2019 1:19 pm

Re: openvpn server not running

Postby CloudBoss » Wed Mar 20, 2019 7:23 am

could not find a log file

need instructions on uninstalling app, also installing again, i think all i have to do to install is click on openvpn app and it will install

please give me both ways

thank you

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: openvpn server not running

Postby bigfoot65 » Wed Mar 20, 2019 9:44 am

You install and uninstall the openvpn App via the HDA Dashboard.

Have to log into the server via terminal and locate the log file:

Code: Select all

cat /var/log/amahi-app-installer.log
ßîgƒσστ65
Applications Manager

CloudBoss
Posts: 15
Joined: Fri Mar 08, 2019 1:19 pm

Re: openvpn server not running

Postby CloudBoss » Thu Mar 21, 2019 8:26 am

i do not see anything about uninstalling openvpn app from control panel never have so this is not an option, if i had seen an unistall we would not have this problem, i am running on 11 ami server under fedora 27, no uninstall is shown on control panel
it shows me openvpn tester, nothing about uninstalling or anything else

as for the log it cant find file, said that before, i know where to look so that is not the problem

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: openvpn server not running

Postby bigfoot65 » Thu Mar 21, 2019 9:25 am

You don't install or uninstall apps from the amahi.org control panel.

Check the install instructions and you will see that it says to log into your HDA at http://hda or by IP address. That's where you will see an Apps tab for install and uninstall.

That's likely your issue. You only need to log into amahi.org after install to purchase apps that have a convenience fee. Those won't show in the HDA dashboard until you do so.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest