Another TLS handshake failed...

akreaxun
Posts: 40
Joined: Sun Jun 21, 2015 1:59 am

Another TLS handshake failed...

Postby akreaxun » Wed Apr 11, 2018 1:46 pm

Hi

I have seen all the posts on the forum about the TLS handshake failed problem. None quite fit my problem. I also went through the wiki troubleshoot page, which did not solve the problem (obviously).

I use:
System: 4.13.16-100.fc25.x86_64 ,x86_64
Platform: 10.0.0-1
Core: 10.4.0-1
On amahi.com the VPN-Test fails.
VPNClient: OpenVPN for Android

Client config: https://paste.fedoraproject.org/paste/Y ... Qc7FeYkh-A

Server config: https://paste.fedoraproject.org/paste/m ... GboEfpmZSQ

Log on Client: https://paste.fedoraproject.org/paste/N ... 3tSzSFmFUQ

Any ideas?

Thanks in advance!

dannyoleson
Posts: 36
Joined: Sun Feb 23, 2014 8:40 pm

Re: Another TLS handshake failed...

Postby dannyoleson » Sat Apr 14, 2018 4:09 pm

I actually just went through this myself on Windows 10. I was hitting the error until I realized that I was getting an auth error trying to download directly to the config folder. I downloaded to the downloads folder and moved them manually, giving admin permissions at each step. Then I tried again. It still didn't work. I realized I had forgotten to update the ovpn file to point to the new file names (lines 9 &10).

Also, make sure that you have port 1194 opened and pointed to your server IP. Set either to UDP or both/all.

Good luck!

akreaxun
Posts: 40
Joined: Sun Jun 21, 2015 1:59 am

Re: Another TLS handshake failed...

Postby akreaxun » Sat Apr 28, 2018 3:23 am

Thanks for the reply. I checked paths and rights on the server, but couldn't find anything wrong. I wouldn't know though how to check on android...

Who is online

Users browsing this forum: No registered users and 2 guests